Sign in with
Sign up | Sign in
Your question
Solved

DVDs stuttering on Pentium 4 system with 4gb RAM?

Last response: in Windows XP
Share
December 4, 2011 11:41:55 PM

Hello,

My system used to play DVDs flawlessly. Now all of a sudden, it stutters. I have tested multiple commercial DVDs, which are clean and not scratched. All of them stutter equally. Video files stored on the hard drive do not stutter, nor does Netflix.

My setup

Pentium 4 2.4ghz 4gb RAM
ATI Radeon 9200 video card
IDE DVD drive [ATAPI liteon]
Win XP SP3
Media Player Classic
XP codec pack

What I've checked/tried

No other applications are running.
During DVD playback, CPU usage is low (60% at peak, usually below 30%)
I have checked that the DVD drive is in DMA mode.
Data transfer tests at 2.72 mb/s
I have tried uninstalling and reinstalling the codecs, MPC and VLC.
I have cleaned the lens on the DVD drive with a lens cleaner disc.
I can play mpg4 movie files from a data DVD without noticeable stutter

I have fooled with the config of ffdshow and managed to get it so that in Media Player Classic the video doesn’t stutter much, but the sound still stutters badly. The video and audio stutter are quite bad in both Windows Media Player and VLC.

Any suggestions? Thanks
December 5, 2011 12:23:13 AM

How about when playing video on dual layer DVD you burn?

Do you have another DVD player to test?
December 5, 2011 1:39:39 AM

1. I would suspect the IDE digital cable... how old is it? is it 40 or 80 wires?

2. What Ultra DMA mode is it running on?

3. Does the drive have the 3 wire digital connector in place (red. white, black wires)

4. Is the Enable digital audio box checked on that device? (drive properties, CD/DVD Device, Properties).
Related resources
December 5, 2011 6:14:12 AM

Chicano,

Question 2 put me onto the solution. When I checked my devices, the DVD drive was set to "DMA if available" but under mode it just said "Not applicable." That was fishy, so I tried uninstalling the secondary IDE channel, then re-installing. That put it right.

Best solution

December 5, 2011 7:02:13 AM
Share

dkoneill said:
Chicano, uninstalling the secondary IDE channel, then re-installing. That put it right.
The secondary IDE Channel driver... reinstalling it must have reset UDMA. Glad you solved it.
December 12, 2011 2:50:23 AM

Best answer selected by dkoneill.
!