Sign in with
Sign up | Sign in
Your question

HDD not detected in bios

Last response: in Storage
Share
March 17, 2011 4:31:55 PM

Hello,

I built a computer for the first time last night. I got everything into the case and was able to load it up into the BIOS on the first attempt. When I look at my SATA devices my optical drive is being detected but my HDD is not. I have tried different SATA ports/wire and different power cords to no avail. The HDD is spinning up so I know it is getting power. I have also tested my optical drive in all 5 SATA ports on my MOBO and it is detected in each one. Is there something I am missing or could it just be a bad HDD? I have tried changing the BIOS settings to both IDE and AHCP (not running a RAID configuration).

When I try and install Windows 7 it also comes up with no available devices to install the OS on.

Running:
ASUS M4A88TD-V EVO MOBO
Western Digital Caviar Black WD1002FAEX 1TB 7200 RPM SATA 6.0Gb/s

I have been researching this issue on Google constantly and can't find a solution.

Thanks!

More about : hdd detected bios

March 17, 2011 7:22:24 PM

Update: Apparently the MOBO will not recognize SATA HDDs until an OS is installed and the appropriate drivers loaded from the cd that came with the MOBO.

Copy pasta from the MOBO manual: "You must install Windows XP Service Pack 2 or later version before using Serial ATA hard disc drives."

My questions now is how do I install an OS if I cannot use the SATA ports on the mother board to do it? I tried loading Windows 7 on an external drive so that I could then format my drive and then reinstall Windows 7 to it but Windows 7 cannot be installed through the USB or 1394 ports.
m
0
l
Related resources
March 17, 2011 7:24:47 PM

I just thought about this...when I start the Windows 7 installation it gets to the blank list where it asks me which drive to install to...can I pop in my motherboard CD (Or copy the files to a USB drive and install the drivers from there since I only have one optical drive) at that time and install the drivers for the SATA ports to get it enabled?

From what I can tell, SATA HDDs are treated as SCSI devices and are not intially supported. It looks like I need to use the makedisc.exe program from the CD that came with the MOBO to extract the necessary drivers and load those when Windows 7 asks me if I want to install any 3rd party drivers.

Anyone around who can either validate or shoot down my thought process here? i am stuck at work while I am thinking about this so I can't actually try it right now.
m
0
l
March 18, 2011 4:44:35 PM

Alright, quick update:

I went home last night and tried loading the AHCI drivers which didn't help. Then I remembered I had a WD Caviar Green 1TB HDD in an external case that I had never used. I took it out of the case and stuck it in my new computer, booted up and presto, my computer recognized the hard drive. As best I can tell the first HDD I tried to use (WD Caviar Black) is bad.

Tonight, just for kicks, I think I will put the WD Caviar Black into the external case and see if I am able to get it recognized and formatted and I will go from there. If that doesn't work I will RMA it I guess.

Once I got Windows 7 installed and all of my drivers updated I checked my Windows Experience Index...7.4+ in all catagories except the disk data transfer rate which is 5.3 >.<

Anyway, my first build was successful now that I have the HDD issue sorted out!
m
0
l
March 18, 2011 5:05:09 PM

I'm getting a new hard drive. I'll be back here if that doesn't work. Hopefully I have the same success? as you did.
m
0
l
!