Sign in with
Sign up | Sign in
Your question

4870X2 with 2nd core 0% load

Last response: in Graphics & Displays
Share
July 19, 2009 6:43:27 PM

Hi ive just built this computer about a month ago and havent even noticed that one core wasnt even working until now... :o 
(I am using a single 4870x2)
Here is the problem, the second core on the 4870x2 is idling for what ever game i run. i used gpu-z in the background to monitor the activity of the second core. No matter what version of direct x im using, only the first core has a load. In ccc, i can only see one 4870x2 and it always goes to 100% load when im playing a game while the second core has no activity. There are 2 4870x2s in device manager so i dont think it is something wrong with the card.
In ccc thou, there is only 1 gpu adapter:4870x2. I have upgraded all the drivers for the card and ccc thou. In gpuz, it says
"ATI Crossfire is enabled (2 GPUs)". Catalyst AI is enabled in so i dont see why the second core isnt working.

I am running on windows 7 ultimate rc 64 bit. my driver versions are as follows:

Driver Packaging Version 8.62-090520m1-081756C-ATI
Catalyst™ Version 09.6
Provider ATI Technologies Inc.
2D Driver Version 8.01.01.909
2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0001
Direct3D Version 8.14.10.0671
OpenGL Version 6.14.10.8673
Catalyst™ Control Center Version 2009.0520.1631.27815

I have already read about similar problems on various forums and tried their solutions but didnt have any luck.

Hope you guys can help! thanks in advance

More about : 4870x2 2nd core load

July 19, 2009 11:15:16 PM

First of all, it's hard to give support for Windows 7, as it's so new.
Some things that came to my mind:
Did GPU-Z read the data correctly? (was it the latest? Does it support windows 7? what does it normally do with x2's?)

I don't think that it's abnormal to see only one display adapter, being an xxxx-x2 card - As it's one piece of hardware.

Do you have another PC available for testing? I'd like to know if the same problem occurs if you install the card there.

If not, try a different set of drivers, if for some reason one core isn't used at all, the first thing I'd be checking is the driver.

EDIT:

Oh, and I almost forgot, run a Furmark and then compare it to what other people get with an 4870x2. Gives you a pretty good indication whether it's working as intended.
m
0
l
July 19, 2009 11:50:17 PM

Thanks for your reply angelusz.
Yes, i downloaded the latest version of gpu-z and crossferenced its data with ccc (first core only, as the second core doesnt appear in ccc), the temperature and load were pretty similar between the two, so i assume gpu-z was reading correctly. On the ATI website, it actually said that the driver was built for windows 7 64 bit so there shouldnt be too much compatibility issues?

but i will try installing different version of drivers as you said.

Ati should have done a better job thou, as their top of the range card, they should provide more monitoring of the gpu through ccc. For instance everything like memory clock should be x2 but it doesnt say that anywhere in ccc, to anyone else, 4870x2 would just look like a 4870 in ccc.
m
0
l
Related resources
July 20, 2009 3:01:53 PM

Make sure you are running on full screen mode. I have the same GPU, and am also running Win7 - Windowed mode does not use the second GPU. Full Screen does.
m
0
l
July 20, 2009 3:22:58 PM

yh i know thanks if u right click ccc icon on the bottom right u can actually select an option to show whether crossfire is running or not
m
0
l
July 24, 2009 10:46:48 AM

if u r running a single 4870x2 card it is NOT crossfire! u need to run two cards and connect (with a crossfire bridge) to enable crossfire!

as to ur problem, go to CCC select graphics--->information center--->graphics hardware. scroll down and u will see headings "primary adapter" and "linked adapter". if "linked adapter" appears as "disabled adapter" ur 2nd gpu is not working.

uninstall, and reinstall drivers.

also update mb BIOS.

4870x2 is a tricky card to install and get running! it took me 2 days just to get running!

hope this helps

these cards give off a lot of heat! keep it cool.

---------------------------------------
q6600 @ 3.4Ghz : asus maximus formula: 4870x2 cf : 8Gb dd2 : 150Gb raptor : 500Gb seagate : 1000W zalman PSU :vista ultimate x64
m
0
l
August 9, 2009 5:02:26 PM

I too have the exact same problem. I've chosen to "Show crossfire X status when active" thing. When loading up games with AI disable, everything works just fine, and pretty god, put no crossfire icon. When enabling AI i can see the crossfire symbole in the upper right corner when loading a game, but as soon as the first 3d thing gets to the screen i at looks and the driver stop to respond or a blue screen occur.

My spec;

I7 920
ASUS p6t Delux
Corsair 750 W (http://www.hardwaresecrets.com/article/505/8)

Pls help=(
m
0
l
August 9, 2009 5:28:19 PM

Sry for the hijack, but i thought he wanted a bumb:)  I use catalyst 9,7, and latest driver, have tested older too, without luck. All the games crashes as soon as somethin that moves are supposed to show. I've tested everything. But this only happens when AI is enabled, and the crossfire symbol is shown. Really hope i can get it to work, not to fun to pay for a x2 and get an x1
m
0
l
August 9, 2009 6:08:32 PM

Really big thx for your help:) 
This link http://www.microsoft.com/downloads/details.aspx?FamilyI...
is saying that i already has the latest, so no luck there. Really frustrating. Earlier i tried to install both xp 32 & 64 bit without any luck. Today i use vista64. Cant fins a solution on the net either.
m
0
l
August 9, 2009 7:27:18 PM

Nope, not a thing there. No warnings anywhere except the sudden crashes when the card is supposed to use both chips.. I really donät know how to continue
m
0
l
August 10, 2009 7:06:52 AM

Yhea, i will return the card. Hopefully a new one will work:)  Thx anyway
m
0
l
!