Sign in with
Sign up | Sign in
Your question

Sandybridge Turbo not quite working

Last response: in Overclocking
Share
July 1, 2011 11:43:17 PM

My 2500k/z68 rig's turbo boost just doesn't work quite right. The four core multipliers work perfectly fine, however 3/2/1 core mult's never take effect. For example, I'm currently set (through the bios) at 36/40/40/40, and regardless of the number of threads (testing with prime95) it never will never go over 36. It's not a cap on multiplier, it's a k processor, and besides I can change the four core multiplier to 40 and it works fine (albeit hot).

I'm running the latest bios revision (f4), and have cleared and re-setup the bios options several times.

Maybe I'm hitting a memory timing limit? I'm really pulling blanks here, if somebody can point me in the right direction it'd be greatly appreciated.

i5-2500k
4x4GB DDR3 1600
Gigabyte GA-Z68MA-D2H-B3
July 2, 2011 4:26:49 AM

meat_popsiclez said:
My 2500k/z68 rig's turbo boost just doesn't work quite right. The four core multipliers work perfectly fine, however 3/2/1 core mult's never take effect. For example, I'm currently set (through the bios) at 36/40/40/40, and regardless of the number of threads (testing with prime95) it never will never go over 36. It's not a cap on multiplier, it's a k processor, and besides I can change the four core multiplier to 40 and it works fine (albeit hot).

I'm running the latest bios revision (f4), and have cleared and re-setup the bios options several times.

Maybe I'm hitting a memory timing limit? I'm really pulling blanks here, if somebody can point me in the right direction it'd be greatly appreciated.

i5-2500k
4x4GB DDR3 1600
Gigabyte GA-Z68MA-D2H-B3


I see the same on my GA-Z68X-UD3H-B3. Same CPU but 2x4Gb DDR3 2000.
m
0
l
July 2, 2011 4:06:59 PM

I installed all the windows updates and now it works (I had a completely fresh install of Windows 7).

I found that Throttlestop is much better for monitoring the multiplier than cpu-z (especially with the "more data" box checked).
http://www.techinferno.com/downloads/?did=1
m
0
l
Related resources
July 2, 2011 8:02:05 PM

Now I think it wasn't anything to do with the windows updates. Using "Optimized Defaults" in the BIOS, turbo works fine. However, it stops working again when I enable XMP for my RAM. It seems that the board automatically disables Turbo when it thinks you're overclocking.

Here's how to fix it:

Go to Advanced CPU Core features in the BIOS.
1. Change Turbo Boost from "Auto" to "Enabled"
2. Change C1E from "Auto" to "Enabled"
3. Change C3/C6 from "Auto" to "Enabled"
4. Change CPU Thermal Monitor from "Auto" to "Enabled"
5. Change EIST from "Auto" to "Enabled"
6. Change Bidirectional PROCHOT from "Auto" to "Enabled"

With the above changes, my Core i5 happily turbos to my settings of 46x/45x/40x/35x for 1/2/3/4 cores.

Note that I don't know whether all 6 of the above items must be set Enabled. I want them all on anyway, but if there's one you don't one just test what happens when you diasable it!

There is a similar discussion in this thread:
http://forums.anandtech.com/showthread.php?t=331435
m
0
l
July 10, 2011 6:51:07 AM

That did it! Thanks a lot, now I'm sitting a comfortable 36/40/40/40, will shoot for 36/40/45/45 or so!
m
0
l
!