Sign in with
Sign up | Sign in
Your question

Sapphire 4870 1Gb with Amd 3800+ X2

Last response: in Graphics & Displays
Share
July 20, 2009 5:07:50 AM

Hey,

I just got Sapphire 4870 1Gb card today and having a bit of trouble getting it run well... My setup:

Motherboard: A8R-MVP
CPU: AMD Athlon 64 X2 3800+ ( @ 2.52Ghz)
RAM: DDR 400 (@210Mhz)
GPU: X1800XT, now HD 4870 (upgrade)
PSU: OCZ ModXtreme 700W
OS: Win 7 and XP
HDD: 200Gb (both OS are on this HDD) and 1Tb.

Running Windows 7

So when I got the card to work i quickly checked 3dMark scores... with x1800XT i was getting ~4900, after the upgrade (with 4870) i got it at ~6500, which wasn't what i hoped for since people are getting like 12k+ with this card. My cpu score went down from 1900 to about 1100. This could mean that my cpu is bottlenecking my system... But, i noticed when i turn my PC on and let windows load, my cpu usage is at 40% (in task manager all programs do not use any cpu as Windows Idle process is at 97-99%) Also checked with XP, cpu usage is exactly the same.

When checking with Catalyst in windows (idle - no 3D applications) HD 4870 has 99% activity (utilization) - same shows with GPU-Z. Fan speed is at 17-19% and temperature is 51C.

So if this card takes 40% of my cpu in order to "see" , then my performance will be horrible with games that utilize a lot of cpu. After upgrade, I checked Dead Space (FPS droped from 30-40 to 18-20), AoC (FPS stayed exactly the same, or maybe a bit less with the same settings) and Crysis (gives me 13-14 fps on very high no AA,AF, 1440x900 at the first turtle =P, at the beginning ), thats all i could check today, i might be doing some more game tests tomorrow.

I tried installing, reinstalling, and uninstalling different drivers (catalysts)... tried windows 7 drivers, Cat 9.3 and cat 9.6


So my question is: Why does my CPU idles at 40% and why does my GPU idles at 99% (while temp is good) ?? Is it possible for my GPU to be defective in any way?

Thanks for reading.
a b à CPUs
July 20, 2009 12:39:35 PM

Check for viruses, trojans and malware.
Do Ctrl-Alt-Del and check what processes are running.
Google any unknown processes.
m
0
l
July 20, 2009 12:53:35 PM

Thanks for the reply, but this isn't a problem, as before I put in 4870, everything was fine... Since both my Windows 7 64 bit and win XP show the same 40% idle, it must be something else... (although checking for viruses atm... in Task manager there is nothing running, all the processes at 0 cpu )
I found this:
http://forums.whirlpool.net.au/forum-replies-archive.cf...

Where it says that my motherboard might be a problem...
Also i changed my Cpu clock back to 2.0Ghz and its still idles at 40%
m
0
l
July 20, 2009 2:09:29 PM

OMG... I solved it =) I had to update my bios to beta version 0605. Now i get a score of 9253, from which my cpu score is 1795 (dropped by a 100 after the upgrade) well my score is still a bit low... but i guess its ok for DDR1 system with one of the first dual cores =)
m
0
l
!