Sign in with
Sign up | Sign in
Your question

ASUS A8N-SLI Deluxe System, Previously Bootable SATA HDD Won't Boot

Last response: in Motherboards
Share
December 23, 2009 10:57:49 PM

A friend of mine recently gave me his old desktop to play around with. I had a Sony Vaio PC that runs well, but I decided that I wanted to transplant some of the components and take advantage of his motherboard/CPU/PSU (not to mention the awesome case). The hard drive + motherboard combo is actually what seems to be giving me issues. When I started this project, I had Ubuntu Linux (with Grub2) and Windows XP Media Center Edition running on it (dual boot). I now have the same hard drive booting through MBR directly into Windowx XP Media Center Edition (I just let Ubuntu go, as I hadn't used it a whole lot, and it doesn't require much time or effort to reinstall), however it doesn't successfully boot. Safe Mode also fails. The following is what I did to arrive at this point.

Previous Steps:

1. The MB didn't detect my SATA HDD, so I tried plugging the drive into various SATA and SATA RAID connectors on the MB (no help)
2. I disabled the RAID configuration via BIOS (able to detect and boot hard drive)
*At this point, my computer would boot into Grub2...and I could run Ubuntu, but not XP. After checking various forums, I came to two proposed solutions (steps 3 and 4):
3. Use Grub's "unhide" command to unhide the partitions on the disk (supposedly the only thing between myself and the finishline). Unfortunately Grub2 doesn't exactly let you do this, and further forum searching gave me the following step:
4. Uninstall Grub2, install Grub Legacy, use "unhide".....(still no help)
*Now I started getting frustrated. I could use Grub AND Grub2 to boot Windows AND Ubuntu flawlessly on my old setup.
5. I updated the BIOS from version 1013 to version 1805. This did nothing also.

So now I have a computer with updated BIOS, Windows XP Media Center Edition (booting through MBR), and one unwelcomed blue screen. It finishes post, asks if I want to enter the RAID setup utility, starts to boot XP...shows the blue load bar w/ Windows logo...but the screen goes black and then blue after a couple seconds with the following error:

STOP: C000021a {Fatal System Error} The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x00000000). The system has been shut down.


Old Specs:
Pentium 4 3.2GHZ (32bit) blah blah
Intel D915GRO/D915VRO/D915PRO MB
1MB DDR PC3200 RAM
*Hard Drive: 300GB WD Caviar SE - WD3000
400 Watt PSU

New Specs:
ASUS A8N-SLI Deluxe
AMD Athlon 64 x2 3800+
1GB DDR400 PC3200 RAM
*Hard Drive: Same as above
500 Watt PSU

Keep in mind, after each step, I moved the hard drive back to the old system and it booted into XP...every time. It has never had an issue on the old setup. When it moves back to the other system, however, I can't get it past the blue screen.

Any help would be much appreciated!
December 26, 2009 7:45:22 PM

Bump? Anybody? :( 
m
0
l
January 5, 2010 12:42:17 AM

Please?
m
0
l
Related resources
January 11, 2010 1:15:34 PM

You may have 2 issues going on here. I have a similar setup as your new machine and I get the Boot disk Failure message. My specs are the same except I have 2 gig ram and I dual boot Ubuntu with XP Pro 64. Not a biggie.

I think your main problem might be the fact that your XP Media Centre was installed on an Intel machine with a completely different set of hardware. It is likely that your XP has all kinds of low level device drivers setup to work with your Intel Mobo and its chipset.

You may want to put the harddrive back into your old system and backup any data, emails, IE Favorites, etc. In Ubuntu make a backup of your Grub loader so you can put it back on the drive.

Now put the drive in your new system and reinstall XP Media Centre.

Good Luck!
m
0
l
January 12, 2010 3:40:14 AM

I completely reformatted a separate HDD and installed Windows XP (tried Media Center AND Windows 2007 separately, actually)... I get the same error message.
m
0
l
!