Sign in with
Sign up | Sign in
Your question

4870 1GB Crossfire Problems

Last response: in Graphics & Displays
Share
July 21, 2009 11:23:08 AM

Sorry to post another Crossfire / SLI problem but I haven't been able to get a solution from 2 other forums.

My system specs:

Core 2 Quad 8300 2.5ghz
2x2GB (4GB) 1066mhz Corsair Dominator
750GB Samsung HDD
DFI Lanparty DK Plus mobo (p45)


I've owned a 4870 1GB from Powercolor up until now as I've just recently purchased a Sapphire 4870 1GB and plan to put them in CrossFire.

Here's a basic timeline of what happened:

-Installed the GPU, 2 CrossFire bridges used to connect cards.
-Let Vista 64-bit install the card
-Noticed card isn't able to be CrossFire'd in CCC <it was greyed out>
-Checked bridges and turned out I hadn't plugged them properly on.
-Plugged them in properly; option still greyed out.
-Used the install disc attached to install the drivers, etc.
-CCC now allowed the Enable CrossFireX box to be ticked but it wouldn't stay that way, it would simply disregard me pressing Apply and Ok.
-Downloaded CCC 9.6 & drivers that accompany it.
<<Now it get's wierd>>
-CrossFireX is able to be enabled and so I enable it and it stays, etc, all seems good.
-Do the Crysis Benchmark; no increase in performance.
-Check GPU usage via Rivatuner's Hardware Monitoring feature whilst playing Crysis, FSX, Wings Over Europe, UT3, the second GPU doesn't do anything :fou: 

GPU-Z, etc says the CrossFire is working <well actually it says its working but unsure for Vista 64 bit> but the card doesn't actually contribute to anything other than increasing temperatures from 54 to 80C on the original card.
July 21, 2009 11:49:38 AM

I think that Crysis needed patching to support crossfire as it didnt when first released, im not 100% sure but im sure i read that somewhere.

Mactronix
July 21, 2009 11:57:02 AM

It wouldn't be that unfortunately, I've got Crysis already patched to 1.21 and if was just Crysis' drivers then the other games probably should have shown some usage of the second GPU.

I'm wondering if it's a driver problem perhaps or if... I have no idea.
Related resources
July 22, 2009 11:46:27 AM

Update:
Tried one bridge, no difference at all, looked through my BIOS, couldn't find anything that conflicted <As far as I know, if you have a suggestion PLEASE speak it>.
Tried re-doing the drivers, I'm at my wit's end.
July 30, 2009 9:07:00 PM

This is a wierd concidence but I'm having the same exact issue! I have exactly the same exact cards crossfired!
July 31, 2009 1:39:00 PM

I fixed the issue, forgot about this thread, what finally fixed my set-up was simply swapping the cards physically around, so the Powercolor was in the bottom slot and the Sapphire card in the top.

Despite defying logic <ATi doesn't do the Master and Slave editions of cards anymore> it worked.
!