Sign in with
Sign up | Sign in
Your question

Is my AHCI RAID Controller unnecessary/cause bsod?

Tags:
  • Hard Drives
  • NAS / RAID
  • Controller
  • Blue Screen
  • Storage
Last response: in Storage
Share
March 23, 2011 12:26:43 AM

I have just built a new computer and have gotten 3 BSOD already. Once while I was in the middle of a recording session (yikes!). Codes are as follows:

*** STOP: 0x0000007F (0x0000000000000008, 0x0000000080050031, 0x00000000000006F8, 0xFFFFF80003888F72)

When I was installing windows I accidentally picked the wrong RAID driver at first (AMD AHCI Compatible RAID Controller and I don't have AHCI) but then immediately installed the right one.

Well I think both got installed and both are running and I think this might cause problems. In my device manager I see:
AMD AHCI Compatible RAID Controller
AMD RAID Console
GIGABYTE GBB36X Controller

when I right click AMD AHCI Compatible RAID Controller I dont see the ability to disable it (or enable it for that matter). My real question here is should I uninstall this driver? Can I see if its being used at all? I dont have AHCI drives and dont think anything will be affected by this.

I should bring up that the Gigabyte controller got disabled some how a couple days after I installed windows and it made my DVD drive disappeared for some reason. It drove me nuts for a day and a half still I figured it out. This might be useless info but I figured it had to do with the controllers I am talking about and it wouldn't hurt to mention it.

My Presonus FSP is my other concern that might be causing the problem. ( I know not the right topic for this tread but...)

Only things I can think of when I got the bluescreens of death are the first 2 times I had a USB mic plugged in for Ventrilo and the other time I was using my recording interface so maybe its a sound card issue of some sort. maybe the 2 sound devises are conflicting.


Thanks for your time reading and helping :D 


Computer build:
AMD Phenom II X6 1090T Black Edition Thuban 3.2GHz Socket AM3
16 GB RAM: G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) DDR3 1333 RAM
Crucial RealSSD C300 CTFDDAC064MAG-1G1 2.5" 64GB SATA III MLC Internal Solid State Drive (mainly have OS on here, and a few heavy programs like my DAW's)
2X Western Digital Caviar Green WD20EARS 2TB SATA 3.0Gb/s (In RAID 1 Mirror, 4gb total)
ATI 6870 1GB PCI express 2.1 256-bit video card
GIGABYTE GA-880GA-UD3H SATA 6gb/s 3.0 USB 64 Bit Mobo
CORSAIR Enthusiast Series CMPSU-650TX 650W power supply
Windows 7 Ultimate 64 bit
Presonus Firestudio Project Firewire recording interface.

More about : ahci raid controller unnecessary bsod

a c 392 G Storage
March 23, 2011 1:48:24 PM

If both drivers are installed, windows should only load the correct driver depending on if your bios is set to IDE or AHCI/RAID. If you want, you can uninstall from the device manager as you suggested. If it shows up on the next reboot, then windows is currently using this device.
m
0
l
a c 353 G Storage
March 23, 2011 2:46:46 PM

First, you have verified that your ram is stable (Run prim95 for a min of two hours)

Yes it could be a driver confict.
For the SSD, is it on a marvel controler, or an amd controller. For Trim to work the driver must be the lastest amd driver (You need to verify that the lasted amd driver does indeed pass trim - I'm a Intel user), or the default ms ahci. To verify which driver is being used with the SSD, use AS SSD (do not need to run bench mark).
Upper left side it will indicat driver used and also indicate if the partition offset is correct.

Sometimes the only solution is to reinstal the operating system - ugh.
Someone more familar with AMD and SSDs may be able to clarify driver issue better.
m
0
l
March 26, 2011 7:13:50 AM

Thanks for your replies! Sorry i took so long to reply. I wanted to do as you both said.

I uninstalled the AHCI driver and as you said it reinstalled itself on the next reboot.

I updated every driver using max driver free.

I ran prime95 for 4 tests over 7.5 minutes and got 0 errors and 0 warnings.

I ran AS SSD:

  1. C:
  2. AS SSD Benchmark 1.6.4067.34354
  3. ------------------------------
  4. Name: C300-CTFDDAC064M SCSI Disk Device
  5. Firmware: 0006
  6. Controller: ahcix64s
  7. Offset: 103424 K - OK
  8. Size: 59.62 GB
  9. Date: 3/26/2011 1:38:46 AM
  10. ------------------------------
  11.  
  12. P:
  13. AS SSD Benchmark 1.6.4067.34354
  14. ------------------------------
  15. Name: AMD 1X2 Mirror/RAID1 SCSI Disk Device
  16. Firmware: 1.10
  17. Controller: ahcix64s
  18. Offset: 132096 K - OK
  19. Size: 1862.64 GB
  20. Date: 3/26/2011 1:52:38 AM
  21. ------------------------------
  22.  
  23. S:
  24. AS SSD Benchmark 1.6.4067.34354
  25. ------------------------------
  26. Name: AMD 1X2 Mirror/RAID1 SCSI Disk Device
  27. Firmware: 1.10
  28. Controller: ahcix64s
  29. Offset: 132096 K - OK
  30. Size: 1862.64 GB
  31. Date: 3/26/2011 1:52:14 AM
  32. ------------------------------


(C is my SSD with windows 7 on it and P and S are 2 partitions i set up on my RAID 1 Sata drives for Programs and Storage)


Anyways i got another BSOD after all this. i was recording again with my firewire recording interface. Im thinking its a sound card issue now.

I should elaborate more on my set up. I have my onboard sound card optical out going to a Denon DTS nice receiver. This plays back all my MP3's, games, video, etc.. anything that isnt using my recording software.

Both my Firewire interface and my optical receiver were on when the crashes happened (i think all of the crashes. but i wasn't paying attention to this on the first 2 instances as to if both the sound cards were on).

The latest BSOD gave another code this time:

*** dxgmms1.sys - address FFFFF880061B2360 base at FFFFF880061A2000, DateStamp 4ce799c1

Which i think is a DirectX error. strange.

Also should say i am running 2 screens and they are diffent sizes/ manufactures etc... yet another possible suspect.

Hope this helps.

I know (or i think) this isn't a Hard Disk issue anymore. if an admin would like to change the location of this tread please do. Id like it to be the most appropriate place.
m
0
l
a c 353 G Storage
March 26, 2011 7:08:03 PM

On Prime95
Use 15 min run if just checking Voltages under load and temps.
To verify memory/cpu stable need to run a min of 2 hours, but most here recommend 8 hours.
m
0
l
March 27, 2011 6:22:24 AM

oh lol. i thought you were saying a minute of 2 hours. (a min of 2 hours) which didnt make any sense to me. though it was i typo or miss translation or something. i get it now. i will do so. ill let it run all night.
m
0
l
March 27, 2011 4:43:03 PM

359 Torture Tests in 8 hours, 14 minutes with 0 errors and 0 warnings
m
0
l
a c 353 G Storage
March 27, 2011 5:06:48 PM

Kind of letts memory of the hook. (How did voltages/temps look) Kind of think they would have been ok as 8 hrs of testing and if voltage/temps were a problem you would have had an indication. Sounds more and more like a driver conflict.n
m
0
l
March 27, 2011 5:33:20 PM

using SpeedFan 4.42 I see:
Vcore1: 1.22V
Vcore2: 1.49V
+3.3V: 3.38V
+5V: 5.03
+12V: 12.42V
-------------------------
-12V: -5.70V
-5V: 4.05V
+5V: 3.60V
Vbat: 3.23V

Temps during test: nothing went over 47C
and idles around high 20'sC (Core around 19C)

Ive never messed with ram timing or voltages. could those hurt?
m
0
l
a c 353 G Storage
March 27, 2011 9:45:02 PM

IF Ram voltage and/or timings were incorrect I would expect memory errors. They could be running at a lower setting, but that would be more a performance issue. You did run the prime95 in blend mode??

You can download CPUID CPU-z. Install and run. there are two tabs for your memory, one show what it is running at, the 2nd tab shows what it can run at and at what voltage.

Don't worry about the -12V and the - 5 V. The 2nd +5 V is normally the +5 used for the USB ports. Most likely it is incorrect value ( should be 5 V +/- 5%)
Might try HWMonitor to verify speedfan readings. I prefer HWMonitor, But that is just a personal prference. (On my system it reports the +12 V as the -12V). Also for voltages, I always verify initially using a voltmeter, It gives me confidence that the software is correct.
m
0
l
March 28, 2011 2:31:18 AM

HWMonitor is way better. thanks! but it was identical readings as speedfan (which i uninstalled immediately after getting HWMonitor).

No quite sure how to read CPU-z yet as far as what i could set my ram at. Ill try to figure all that out later. after i read up on it.

Thanks for the tips.


-I have ran a check Disk on all 3 partitions
C: (my SSD) 0 problems, 0 bad sectors.
S: (1.62TB Partition on my RAID 1 drives for storage) 0 problems, 0 bad sectors
P: (200gb partition on my RAID 1 drives for programs) and got this error:
  1. CHKDSK P:
  2. The type of the file system is NTFS.
  3. Volume label is Programs.
  4.  
  5. WARNING! F parameter not specified.
  6. Running CHKDSK in read-only mode.
  7.  
  8. CHKDSK is verifying files (stage 1 of 3)...
  9. 7680 file records processed.
  10. File verification completed.
  11. 0 large file records processed.
  12. 0 bad file records processed.
  13. 0 EA records processed.
  14. 0 reparse records processed.
  15. CHKDSK is verifying indexes (stage 2 of 3)...
  16. 9000 index entries processed.
  17. Index verification completed.
  18. 0 unindexed files scanned.
  19. 0 unindexed files recovered.
  20. CHKDSK is verifying security descriptors (stage 3 of 3)...
  21. 7680 file SDs/SIDs processed.
  22. Security descriptor verification completed.
  23. 661 data files processed.
  24. CHKDSK is verifying Usn Journal...
  25. 9177824 USN bytes processed.
  26. Usn Journal verification completed.
  27. The master file table's (MFT) BITMAP attribute is incorrect.
  28. The Volume Bitmap is incorrect.
  29. Windows found problems with the file system.
  30. Run CHKDSK with the /F (fix) option to correct these.
  31.  
  32. 204799999 KB total disk space.
  33. 26162916 KB in 6907 files.
  34. 3300 KB in 662 indexes.
  35. 0 KB in bad sectors.
  36. 89295 KB in use by the system.
  37. 65536 KB occupied by the log file.
  38. 178544488 KB available on disk.
  39.  
  40. 4096 bytes in each allocation unit.
  41. 51199999 total allocation units on disk.
  42. 44636122 allocation units available on disk.


I ran it with /F and it fixed the problem.

Hopefully this fixed the issue. but only time will tell.
m
0
l
!