Sign in with
Sign up | Sign in
Your question
Solved

Windows 7 x64 says RAM 4 GB but 2 GB usable

Last response: in Motherboards
Share
December 28, 2009 9:19:03 PM

Hi,

In the system properties, the ram has a 5.5 windows experience, and under Installed memory (RAM) it says 4.00 GB (2.00 GB usable)

motherboard: gigabyte p55-ud3r
ram: gskill F3-12800CL7D-4GBRM
cpu: intel i7 860

System type is 64-bit Operating System,
I have no option to remap memory or something...and i have set proper timing
My BIOS sees 4GB but only 2GB is enabled, how do i enable it??
If its disabled by the bios, how come cpuz and windows sees 4gb?
With a rating of 5.5, my old ddr2-800 is rated 6.3 maybe there is something wrong with the RAM modules.
I tried to swap them, reseated them couple of times,
Flashed the bios to current F4 version,
tried to manualy reset the cmos

nothing to do...is the RMA best solution?

More about : windows x64 ram usable

Best solution

December 28, 2009 11:57:04 PM
Share

Try re-seating your processor... install a single module once at a time and add the rest modules. Check if any DIMM slot is not activated or not.
a b } Memory
a b V Motherboard
December 29, 2009 8:30:11 PM

Not sure where you get the impression the ram is disabled. System properties see's it 4gb and 2 ?available, cpu-z see's it. Where does it say disabled?
Also the 6.3 rating was from Vista not Windows 7 right? No way Win7 rates ddr2-800 as 6.3
Related resources
a b } Memory
a c 177 V Motherboard
December 31, 2009 1:32:18 AM

Typical cause on 1156s: bent or distorted CPU socket pins... Intel guide to checking:
http://www.intel.com/support/processors/sb/CS-030850.ht...
Couple times, this has worked:
go into msconfig (just type msconfig into your main menu's search bar, and hit enter...), click on Boot tab, select 'Advanced options' - see what's in 'Maximum memory' - if it's not enabled, do it there, then 'OK', and 'OK' and reboot... Don't know how or why this sometimes happens, especially as seven seems to be very good at hardware, but? ...sometimes fixes it...
January 4, 2010 5:24:38 PM

Same thing happened to me on my last build. I simply reseated the RAM and rebooted and all 4GB were then usable
a b $ Windows 7
a b } Memory
a b V Motherboard
January 4, 2010 6:37:38 PM

If you're *sure* you're running the 64 bit version of the OS, from here I see two possibilities. The first is your motherboard may have a limitation - either by design or by BIOS setting. Check your motherboard's support page to verify your motherboard actually supports 4GB of ram or more. Then check your BIOS for a feature called Memory Remapping. If Memory remapping options appear in the BIOS at all, make sure it is turned on.

If all checks out above, then Click the Start orb, and type: msconfig

Right click the msconfig app to run it as Administrator. That brings up the configuration utility. Click the Boot tab, and then click the Advanced Options button. In that window, there is a setting for Maximum Memory - Make sure the checkbox for it is clear (not checked), then reboot your computer.
January 8, 2010 5:39:09 AM

i have the same problem, 6.00gb (2.00gb usable) tried removing the ram and putting it back. updated the latest bios. tried task manager, 4.00gb hardware reserve, 2.00gb in use. anyone solve this, need help. thank in advance.

windows7 ultimate 64bit
ocz 6gb 1800mhz
gigabyte x58-ud5
intel i7 920

oliver
January 8, 2010 5:44:46 AM

i must reinstall my os? i've seen same problems 6gb or 4gb (2gb usable), but didnt find answers. i have seen this post also from other forum.

"
bump with some additional info:
I have researched this further and found that it is more likely the RAM is not bad.
The BIOS itself is having a problem with the function called remapping. when working properly, it is the remapping that makes all the RAM available and prevents windows from capturing part of it on "hardware reserve" which i can see it is doing to 2GB. I just have no idea how to get the BIOS to correctly remap again, because the setting is enabled but it only says I HAVE 2040 MB ram installed in the BIOS main screen.
I recall that the first time I noticed the issue was immediately after I booted into the older xp install (where win7 offer the option to boot into "older version of windows" and I tried it out to see if the iphn could be synced there). Right now my last resort seems to be buying the ram upgrade I was looking to buy and do a test with it, then try running all 8GB at once and see how things respond then. Is there a way to completely restage the bios? I am afraid there is a problem in the firmware that is creating the issue since it survived CMOS reset"
January 10, 2010 12:49:06 AM

i tried yesterday, putting 1 stick at a time on 3 white slots. 1 stick can boot windows on 3 white slots but the 2 sticks cant boot windows on 3 white slots. on system properties it showed 6gb (2gb usable) any suggestions, maybe i have a 2 bad ram?
January 17, 2010 7:51:44 PM

All i had to do is to re-seat my processor
February 26, 2010 2:04:19 PM

I had the same issue with:
GIGABYTE GA-X58A-UD3R LGA 1366 Intel X58
Intel Core i7-920
G.SKILL 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600

What I noticed was that right after powering the system on, I hid the splash screen and noticed that the RAM was only counting up to 4GB. In Windows it said 6GB of RAM (4GB usable). CPU-Z reported 6GB of RAM.

After hours of troubleshooting I followed a tip to check the pins on the socket of the motherboard. I removed the CPU, placed the mobo under a bright light, and noticed one pin was slightly bent to the side. I straightened it with a tiny flat-head jewelers screwdriver and replaced the CPU. After the next reboot, the BIOS counted up all 6GB of RAM and Windows reported 6GB.
a b } Memory
a c 177 V Motherboard
February 26, 2010 2:18:34 PM

At least ninety percent of the time, 'missing memory' = bent pins... The hard part is to convince people to pull their processors to look!
Anonymous
a b $ Windows 7
a b } Memory
a b V Motherboard
October 10, 2010 8:56:58 AM

Thank to this Forum, after many hours of checking and testing, i open my computer and took of the CPU, and look at the pin, but can't get a nice look, i am 40 years, and my eyes are tired.

What i do : use a lens from my canon EF 70-200 camera, and begin the checking, and what a surprise, i found the bad pin, it's hard to see it with only eye, use a lens magnifer.

I move the pin in right place and boot, and voila, 6Gb = 6Gb not 4Gb only from windows.

The only hard part is to found the bad pin.

Also becarful about your Cooler Fan seating, he has to be real strait pressure.

Thank again to every body write about the bad pin.

MM.
September 22, 2011 10:29:11 PM

I've had the same problem, seems i've touched the pins on motherboard some how and turned one in bad direction. I've been trying with camera (did around 50 pics) and i couldnt detect the one that was turned bad. So I was trying blindly.

First pin i've touched made my pc useless, didnt want to start, secound also. Some how i've destroyed more pins then fixed.

On the last try (when i was about to give up) i've made my pc working, and fixed the ram recodnizing.

Specs: I5-750 (OC 3.8ghz - Cant OC to 4ghz for some reason (nuctoa NH-U12P cooler))
RAM : 4x 2GB A-DATA Gaming series (2000mhz)
MOBO: P55-UD5 (once i bought it, the pins were already bad. The retailer is seriusly *** ass)

I'm planning to upgrade to I5-2600K soon anyway =) and a Gigabyte Assassin Motherboard.

December 30, 2011 11:43:28 AM

Guys,

I hear what everyone is saying about the bad pins etc. However this is mainly in the context of custom built PCs. I have a Dell XPS 9000 (aka 435 model) i7 core, windows 7 64 bit, with 4 GB RAM. I've now had this PC for exactly 2 years. It is only in the last 3 months or so that the "intermittent" problems with reported RAM have been occurring.

I've cleaned the dust out of the MB, swapped around ram modules but it is very difficult to trace which of the 4, 1GB modules are faulty (if any) since the problem occurs intermittently. At this point, I'm not sure if RAM modules are dying or if Ram slots in my MB are faulting intermittently.

Just before I see 4GB installed (1.99 GB usable) reported, the system usually crashed just before that, most likely due to a bad memory call.

Now I have never touched the actual CPU chip itself, and with the Dell working at long as it has (fault free), I am less inclined to think that all of a sudden there is a bent or damaged pin. The only thing that has ever been changed on the system is the video card which i swapped out for a 5770 the day I got the system. That's it.

Now I've tried calling Dell, and they have argued that they can't/won't attempt a service on a PC that "is still working" because when they walk you through their initial scripted procedures, they arrive at "Nothing is wrong with the PC" because as with all "Intermittent" problems, they don't show up when the person that is supposed to fix it is on the line.

I just bought a crucial memory upgrade kit of 12 GB (3 x 4GB) which I am hesitant to install if the MB if faulty (ing).

Any thoughts on the actual source of the problem?
What other tests do you think I can run to narrow the source of the problem?
Do you think it's still likely that there CPU may have issues or may be failing, or is it more likely to be RAM or the MB RAM slots?

By intermittent I might approximate 2 or 3 times per week the system will crash and on rebooting report that only 2 GB is usable, until I try reboot it several times before it reports all 4 GB as usable again.
!