Sign in with
Sign up | Sign in
Your question

ASUS Striker Extreme BIOS Will NOT Save Certain Settings

Last response: in Overclocking
Share
July 14, 2011 9:12:11 PM

Sup ppl?
This was posted earlier but I suppose this is the best section for it.
I am venturing into the world of overclocking, and already I have came across a problem. Everytime I change the FSB in the BIOS for my Asus Striker Extreme nForce 680i SLI MoBo and reboot, it will NOT save. It keeps reverting the FSB back to 1066 regardless of what figures I put there.

I have also tried the AI Overclock along with the NOS thing and those settings will save, but when I boot into the OS, it's still using the Default FSB and Memory Clock.

So far, I have updated to BIOS 1504 (which, from multiple posts across the Web, appears to be very good with the Q6600 C2Q I am using), i've Loaded BIOS Defaults, Clear the CMOS (cut power, put jumper in 2-3 position and held Reset CMOS, unplugged PSU and held Power Button for 40 secs, and no difference. The strange thing is that allot of settings will remain after a reboot, such as the Boot Order, RAM voltage (so does the Timings in the BIOS, except in windows, it still shows as default 5-5-5-18) and stuff like Disabling Speed Step and C1E, changing the LCD text and so on, so it can't be the Battery. The main prob appears to be with the FSB settings. I also tried Linked, Unlinked, and same damn thing.

The board is getting up in age, but does anyone have any idea as to why this is happening? Searching the entire web hasn't revealed a solution for me.

Thanks
~Des
July 17, 2011 10:13:09 PM

Is this a joke? Every time I ask a question about this MoBo I can never get an answer...
July 18, 2011 2:27:22 AM

Another user having problem with an Asus product... These tend to cause more fuss than any other brands...

Sorry but that board is kinda old, and you can't RMA it since Asus doesn't support overclocking. And nvidia's chipsets are not well overclock-friendly.

I have an eVGA Nforce 680I board in one of my PCs at home and it doesn't have that problem...

Best bet would be to try changing other BIOS' options and if it can't save it, RMA the board (and telling them those settings that can't be saved) so that your problem will be gone. They will send you a newer board for the pain with (hopefully) no nvidia chipset. Try very hard and find another problem in your BIOS (other than the overclock thing as they do not support overcling in the board's warranty).

That's what I would do cause I hate Asus and finding a solution for that board is probably pointless... Anyways their customer service is crappy so do that, else you are pretty much on your own...

BTW, don't use Ai Overclock: it's crappier that the whole Asus ugly logo... That feature isn't stable at all, even with a few hundred mhz overclock.

Just so you know, the fact that memory timings are not saved in the BIOS is well enough for me to get a RMA from Asus.
a b V Motherboard
a c 76 K Overclocking
July 22, 2011 1:30:10 AM

@ OP - your first mistake is that you haven't included your entire rig specs.
We could probably take it from there...but older hardware means its showing signs of age, so your just delaying its funeral, thas all.

A bad bios version could be the root problem, the memory not being OC friendly might not like the timmings its given and is throwing up what is being given...

That doesn't mean that the board is defective. But if its newly purchased, give it a go with RMA - though that isn't my first priority.

my 2 cents.

memory just kicked in, the nvidia's chipsets were the worst chips in history to be launched and claim that they were OC'ing friendly - rather being nightmares! Return and prchase another board, an X48 maybe or a P45 chipped ROG board if your an ROG fan.
!