Sign in with
Sign up | Sign in
Your question

ASUS mobo not reading RAM correctly. 1333 MHz instead of 1600 MHz

Last response: in Motherboards
Share
December 29, 2009 8:56:20 PM

I have an ASUS P7P55D LE motherboard and G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 RAM. When I boot my computer (with Windows 7 Ultimate) on it, the highest I can run my RAM from the BIOS is at 1333 MHz and not at 1600 MHz. How can I change this? I read it doesn't make a big deal but I would just like to it to work in case and for the future. Should I update BIOS or is there another way of changing the frequency?

Thanks!
December 29, 2009 11:25:23 PM

My asus formula reads my 1066 ram @ 667 which I had to manually set it to 1066 and the correct dram voltage in bios for it to see it correctly.
m
0
l
March 8, 2011 12:07:28 AM

im having the same issue running gskills ripjaws 1600 ddr3 ram highest option i get in the bios is 1333 :( 
m
0
l
March 8, 2011 2:27:38 AM

tymarkdown said:
I have an ASUS P7P55D LE motherboard and G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 RAM. When I boot my computer (with Windows 7 Ultimate) on it, the highest I can run my RAM from the BIOS is at 1333 MHz and not at 1600 MHz. How can I change this? I read it doesn't make a big deal but I would just like to it to work in case and for the future. Should I update BIOS or is there another way of changing the frequency?

Thanks!


What CPU are you running? that could be what's limiting you.
m
0
l
!