Sign in with
Sign up | Sign in
Your question

Keyboard not detected

Tags:
  • New Build
  • Keyboards
  • Systems
Last response: in Systems
Share
July 6, 2009 5:28:50 AM

I just bought and put together my first computer. All was going well until I tried to boot up, and even that was ok :) 

I'm not sure if I missed something or if it is a motherboard issue, but when I turn on it goes to a boot screen and tells me there is no keyboard detected. My mouse and external DVD Drive are detected, but no keyboard. Both the mouse and drive are USB, where the keyboard is the old connection (not sure of name). I don't know why it isn't being detected, I have tried multiple keyboards with this input style, all to no avail.

If anyone has ideas please pass them on. I don't think there is a connection I missed because that receiver goes straight on the MB.

If it will help here are my system specs:

MB: ASUS M4A78 Plus AM3/AM2+/AM2 AMD 770 ATX AMD Motherboard

Video card: SAPPHIRE 100245L Radeon HD 4850 512MB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready CrossFire Supported Video Card

PSU: OCZ StealthXStream OCZ700SXS 700W ATX12V / EPS12V SLI Ready CrossFire Ready Active PFC Power Supply

CPU: AMD Phenom II X2 550 Black Edition Callisto 3.1GHz Socket AM3 80W Dual-Core Processor Model HDZ550WFGIBOX

RAM: OCZ SLI-Ready Edition 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory Model OCZ2N800SR4GK

HDD: Western Digital Caviar Black WD1001FALS 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drives

Any ideas are appreciated!

More about : keyboard detected

July 6, 2009 5:54:18 AM

You said: "I don't think there is a connection I missed because that receiver goes straight on the MB."

Assuming you have plugged these PS2 keyboard connectors into the correct plug (purple I guess) on the backpanel . . . you might try removing all USB connections and trying again . . . I can't think of anything but a mobo problem.
July 6, 2009 6:08:45 AM

Unplugged mouse and drive, got better. It detected the keyboard, but the problem is that I need the drive to load an OS.

tried booting with the two and had same problem.

But it was a good start. Could this scenario be pointing at a misconnected USB wire?
Related resources
July 6, 2009 6:13:43 AM

Ok, tried again with USBs plugged in, same problem. then I unplugged them again and it isn't working, another no keyboard detected message...
July 6, 2009 6:29:24 AM

Ok so upon booting the message is basically this:

We detect your stuff, you're running X ram, and then at the bottom of the screen:

No Keyboard Detected !
USB Device Over Current Status Detected !!
System Will Shut Down After 15 Seconds
July 6, 2009 7:57:16 AM

One more post before bed.

I have now tried disconnecting the USB from the MB and I still get the USB Device Over Current Status Detected !! warning.

I also tried resetting the bios by taking off the cap and moving it onto the other pins then replacing it. Now I have a CMOS warning when I boot up.
July 6, 2009 1:01:43 PM

1. Ok, take of the motherboard battery and hold power on button for 10 seconds to discharge any electricity left put back the battery. Load BIOS default settings. Restart. Than load up the BIOS again and look trough all settings connected to USB and other peripherals.

See you motherboard manual for guidance.

2. If still doesn't work maybe a BIOS flash is needed.

3. Try with USB keyboard insted of PS2, you may have faulty port or something other on the motherboard itself.
If it doesn't work with USB keyboard you shold change/return tne motherboard , because is probably faulty.
Hope this helps :) 

July 7, 2009 1:28:32 AM

I removed battery and held down power switch. I'm still getting the USB error.

I have semi-solved the keyboard problem, I got a new USB keyboard and it is getting detected fine, but now I need to solve the USB Device Overcharge Status Detected problem.
July 7, 2009 7:03:52 PM

Thanks for the help everyone, I figured it out. I tore it apart and found I had an extra spacer behind the MB that was directly underneath a USB port.

thanks :) 
!