Sign in with
Sign up | Sign in
Your question

Move RAID HDDs from ASUS Mobo to Giga GA-EP45-UD3R

Last response: in Motherboards
Share
December 30, 2009 11:11:16 PM

The mobo or CPU (or both) in my old system died. I got a new Gigabyte mobo, E8400 CPU and bigger+faster RAM and about to start the upgrade.

Since I built the old system myself (full specs below), I feel quite comfortable doing the upgrade with all the chassis/fan/cpu fan/etc details.

The one thing that I don't know how to do is use my existing HDDs, which are setup as RAID 0, with the new mobo.

I want to preserve the OS+data on them, so just nuking it and creating new RAID volumes is NOT good for me.

Any idea what I can do and how to do it safely, so the old data won't be overwritten by mistake?

Many Thanks

Specs:
==========
MB (old): ASUS P5N32-SLI Deluxe
MB (new): Gigabyte GA-EP45-UD3R

CPU (old): P4 650 3.4GHz
CPU (new): E8400

RAM (old): Crucial Ballistix 2x1GB DDR2 667
RAM (new): OCZ PLatinum 2x2GB DDR2 1066

Grfx: BFG 7800GTX 512MB
HDD: 2xWD Raptor 74GB, 10K RPM, RAID 0
PSU: Thermaltake Pure Silent 680W
Case: Thermaltake Armor full tower

OS: WinXP 32-bit, SP3
a b à CPUs
a c 177 V Motherboard
December 30, 2009 11:38:48 PM

Can't go from nVidia nForce southbridge RAID implementation to Intel ICHxR implementation - just ain't happening, sorry...
December 30, 2009 11:43:22 PM

bilbat said:
Can't go from nVidia nForce southbridge RAID implementation to Intel ICHxR implementation - just ain't happening, sorry...

Billbat - thanks fo rthe VERY quick reply!

So, I'm you say I'm SOL?
Any chance of retrieving the data on the HDDs?
If I used another ASUS mobo with nvidia sb, would it work?
Any other crazy options?

Thanks
Related resources
a b à CPUs
a c 177 V Motherboard
December 31, 2009 1:22:30 AM

My guess would be you'd need the same chipset - nForce 4, but that should work, then back it up to a portable or something. My experience w/nVidia's RAID implementations (admittedly limited, as I won't touch their stuff for anything I'm gonna actually own...) has been that it's pretty flakey - you will, however, love the Intel implementation. I had Ubuntu installs trash my first RAID0 pair of VelociRaptors a couple times in the last few weeks (for some damned reason, debian just doesn't 'like' my first RAID - never bothers the second RAID0 pair, or the third RAID1'd RE3s...), 'broke' the RAID, re-paired it, and off to the races - never a byte lost! Then, after probably eight months, lost one of the RE3's; everyone impressed me - took all of five minutes at WD to confirm the drive was in warrantee and set up an RMA; two mornings later, the replacement showed up on my doorstep; shut down & tossed it in - Intel's RAID manager told me 'rebuild in progress' - two hours later, never would have known it died! Then, to ice the cake, WD gave me a couple bucks off return shipping to print a prepaid UPS label - must make their internal processing cheaper - walked into UPS, threw it on the counter, smiled & nodded, walked out - deal done! Several years of data retrieved cost me a total of about thirty-five minutes effort :sol: 
December 31, 2009 1:33:27 AM

billbat, All - this is a cry for help!

The data on those HDDs is very important to me. If anyone can help we with this, I will really appreciate it.

I plan to revive my old MB for a few hrs just to backup the data. I will replace the CPU first and if it doesn't work try a similar working MB.

The types of CPUs I can put on my old MB are: Pentium EE / Pentium D / Pentium 4 HT / Celeron D. If anyone has a spare old one they don't need, pls contact me.
Or - if anyone has an old ASUS MB (P5N32-SLI with the nForce RAID chip) they don't need, please do the same.

Thanks again. Hoping for some good will and good luck on this.
a b à CPUs
a c 177 V Motherboard
December 31, 2009 1:41:28 AM

I'm gonna try some searches - seems to me someone mentioned here, a few weeks or a month back, that they had luck with some utility that's made just for recovering data off 'broken' RAIDs, but can't remember the circumstances, chipset, or name of the thing... Reminds me of an old secretary of mine - "I took a message for you, and I didn't get the name or the phone number, but it was someting about a dire emergency!"
a b à CPUs
a c 177 V Motherboard
December 31, 2009 2:21:37 PM

Acck! That's the one that was mentioned, but I never saw the 'spam' post - someone cited it... What I can't recall is whether he endorsed it, having used it, or simply did read that spam, and referred it. Had no luck searching - simply turns up too many posts about GPS and atenna aiming... There is also RaidReconstructor:
http://www.runtime.org/raid.htm?gclid=COf_1d6IgZ8CFYdd5...
which might be found on PirateBay? Says it's 'read-only' 'till it determines whether it can recover, which sounds safe...
December 31, 2009 2:28:05 PM

Yeah, I noticed the spam msg too. I saw RaidReconstructor's web site, and does seem safe.
Just to be clear on the approach here before I start this project - can you tell me if these are the right steps:

- Install new MB, memory and CPU
- Install another HD (not the RAID ones!!!). It'll have to be IDE, b/c that's what I have right now
- Install bare-minimum OS plus MB drivers etc. (I wonder if going to XP64 is going to be a problem? I'd like to use all of the 4GB......or should I stick to the old XP32 for compatibility's sake)
- Install the old HDDs as INDIVIDUAL disks and let the OS recognize them. I assume this is safe b/c the OS doesn't need to write onto them (and it won't be able to anyway, right?)
- Install this (or other) RAID reconstruct tool
- Run it and see what it says
- Take it from there...

Makes sense?
January 10, 2010 2:54:11 AM

Well, the saga continues. I finally got some time to try a few things and here are the results:
- I got a used Celeron D on eBay for the old ASUS board. I tried to boot but the board literally told me its fried. Smoke and flickering lights....I gave up on reviving the old board
- I now moved to setup my new Giga MB with the CPU+Memory I got for it (decsribed at the beginning of this thread)
- Everything moved along fine (had to move components around in my case due to diff. location of IDE and FDD connectors)
- I put the XP32 CD and it booted from it
- It finished loading all the drivers from the CD and then switched to "Starting Windows"
- I got the blue screen of death
- The message after the usual bla-bla says "pci.sys - Address ......."
- I tried many different things in the BIOS (disable or slow down the OC. I really want NO OC to being with; Disable Virtualization support; etc.)
- I tried to put the memory in both banks (1&3 and then 2&4). Same results
- I tried with a simple VGA card and with my BFG 7800GTX 512MB. Same results

- The CD ROM is a Lite-On
- The HDD is Maxtor DiamondMax 100GB
- I am only using the IDE channel at the moment
- All I really want to do is install the OS and then attach the old RAID-0 disks and run a RAID recontructor utility

Is there anything special I need to do when install XP32 on this board with 4GB of RAM. My HW config is very simple, so what could be wrong (given that the CD boots and SW does run....)?

Any help would be appreciated.

Thanks
January 10, 2010 3:24:06 AM

You can INGORE my previous post. Stupid me. I thought I was using an XPSP2 CD, but it was actually an original XP CD (pre-SP1).
Just didn;t see the add'l SP2 text....
Now that I put the XPSP2 CD, it installs happily.
!