Sign in with
Sign up | Sign in
Your question

Rampage 2 Extreme won't boot

Tags:
  • Asus
  • Intel i7
  • Thermaltake
  • Motherboards
Last response: in Motherboards
Share
December 31, 2009 3:08:29 PM

I have a new build WC'd R2E w/ i7 920. Just finished my 24hr leak test last night and connected everything up. When I hit the power switch everything came on for a second and then nothing. I checked the lcd poster when I tried again. It just says pwr_off briefly and then goes back to a timer. I have it connected to a thermaltake 850w PS. I tried connecting it to another thermaltake 700w I have laying around. Same thing. I have pulled and reseated the CPU and memory to no avail. Anybody have any thoughts?

Asus R2E
i7 920
OCZ OCZ3G1600LV6GK
Thermaltake-850-Watt TR2 RX PSU W0319RU
EVGA 896-P3-1255-AR Geforce GTX 260 896MB
D-Tek Fuzion2 CPU block
Bitspower BLACK FREEZER Asus R2E NB/SB Block
Bitspower BLACK FREEZER MOS AMOSII & III Water Blocks
Swiftech Komodo GTX275-P897 Water-Block
Thermaltake Spedo Advanced Full Tower Case

More about : rampage extreme boot

December 31, 2009 11:17:34 PM

Pulled my MB from the case and only had 1 dimm and the cpu. Still the same thing. Pulled off the nb/sb and mosfet blocks and the darned thing started up. Looks like i had some metal on metal contact. Now in the process of thermal taping the hell out of it. Hope this helps anyone that may run into the same problem.
m
0
l
!