Sign in with
Sign up | Sign in
Your question

Game crashes, hangs after new Graphics card installation

Last response: in Graphics & Displays
Share
July 29, 2009 9:29:37 AM


Hi,

Below is my current system configuration:

AMD Phenom II X4 940 3.0GHz with stock cooler
MSI 790GX platinum M/B
4GB, Transcend aXe DDR2 RAM, 1066MHz
XFX Radeon 4850, 512MB GDDR3, XXX edition
1TB, 250GB Samsung SATAII, 7.2K RPM drives
DVD RAM drive, 17" ViewSonic monitor, Pinnacle TV card.
Thermaltake litepower 400Watt PSU.
Windows XP pro SP2, 32-bit.

Recently I have bought XFX Radeon 4850 (512MB) XXX edition graphics card. Previously I was using XFX Geforce 9600GT. I sold the 9600GT and used integrated graphics card in the M/B for two days. After installation of intgerated graphics driver, I unistalled nVIDIA graphics driver (mistake??? :pfff:  ). After I had phycally installed Radeon 4850 card I unistalled the display driver with CCC (for integrated card) provided by MSI and installed latest catalyst 9.7 driver.

I am playing "Assasin's Creed" and it crashes to the desktop after playing some times. While playing "NFS Undercover" the game hangs for some times (3-4 secs) and proceeds without crash. Also the camera view is closer compared to 9600GT card for EEII, III and CaesarIV.

What might be the resolution for the issues. Please help.

Enayet
a c 107 U Graphics card
July 29, 2009 1:38:32 PM

go into the bios and disable the on board video or make it point to peg or pci-e.
m
0
l
a b U Graphics card
July 29, 2009 1:44:38 PM

Turn off the on board, as swifty suggested^
Go to the add remove programs feature, unistall ALL nVidia and ATI drivers, software, etc. ALL OF IT.
Reboot and let windows load the generic VGA driver.
Download and install the lastest version of Catalyst drivers.
Then last, but not least, if that doesn't do it, buy a better PSU.
m
0
l
Related resources
July 29, 2009 6:35:03 PM

swifty_morgan said:
go into the bios and disable the on board video or make it point to peg or pci-e.


Sorry. :D  . I forgot to disable the on-board graphics. I have disabled on-board graphics, set HPET (High Precision Event Timer) to Enabled. Primary Display adapter was set to [PCIE]. Now "NFS Undercover" does not hang for some seconds, it runs smoothly (played several times). But "Assasin's Creed" still crashes and now the computer gets reboot after every crash :(  . When the system comes up then Windows shows a message "The system has recovered from a serious error". Camera view for EEII, III and Caesar IV remain the same.
m
0
l
July 29, 2009 6:38:05 PM

jitpublisher said:
Turn off the on board, as swifty suggested^
Go to the add remove programs feature, unistall ALL nVidia and ATI drivers, software, etc. ALL OF IT.
Reboot and let windows load the generic VGA driver.
Download and install the lastest version of Catalyst drivers.
Then last, but not least, if that doesn't do it, buy a better PSU.


I will uninstall all the display related software and install as suggested. Lets see what happens then. :) 
m
0
l
July 31, 2009 10:58:33 AM


I have uninstalled all display related software and reooted the system. Windows loaded generic VGA driver. After that I installed Catalyst 9.7 driver for the card. Installation was successful. But when I tried to play "Assasin's Creed" it keeps crashing to the desktop, also "NFS Undercover" also hangs for 3-4 secs during play. Camera view is still closer compared to the previous nVIDIA card.

What to do? Do I have to re-install Windows? Or should I write to XFX or MSI?

m
0
l
October 25, 2009 10:01:45 PM

I have also been having these problems, does anyone have a solution? Sorry for resurrecting a dead thread, but any help at all would be great. I have two of these cards and they crash with and without crossfire, and with no OC'ing (except from the factory OC).

Thanks in advance!
m
0
l
November 7, 2009 4:03:10 PM

freedo50 said:
I have also been having these problems, does anyone have a solution? Sorry for resurrecting a dead thread, but any help at all would be great. I have two of these cards and they crash with and without crossfire, and with no OC'ing (except from the factory OC).

Thanks in advance!


The cause of my issue was the BIOS and voltage of RAM. When my RAM was running @1066MHz the system became unstable and crash happened. I contacted MSI technical support for the issue and I updated the BIOS two times and increased RAM voltage from 2.0V to 2.1V. After BIOS upgrade and increasing of voltage I not facing any crashes, hangs or BSoD for some days.....

I think the main reason of my problem was BIOS compatibity of 1066MHz DDR2 and voltage.
m
0
l
November 7, 2009 4:10:36 PM


Also graphics card driver has been upgraded to Catalyst 9.10.
m
0
l
!