Having Problem with installing HD4870 please help

I have just recently purchase the HIS HD4870 1G and try to install it on on pc with the following specs

CPU - Q8200
Mobo - GA-EP45T-UD3R
RAM - 2G Kingston DDR3 1333
Hard Drive - Sata Seagate 360G
PSU - Antec True Power 550W

(nothing overclocked)

I have uninstall the old video card driver 9400gt, insert the HD4870 into the PCI exp and plug the 6 pin power cable and tried starting it up.

The pc starts with some wield beeping sound and all the hardware seems to start properly and even the fan on the HD4870 runs. But no image on the monitor displayed.

I unsure if this is the hardware problem on the pc or what is affecting it. I reinstate the 9400GT and the computer runs perfectly again.

I appreciate any help and thanks everyone in advance for responding to this thread
7 answers Last reply
More about having problem installing hd4870 help
  1. First, you need to completely dlete the old nVidia driver, using driver sweeper in safe mode. ATI and nVidia drivers dont mix, and even a lil left over, which seems the case with nVidia drivers, as it seems it causes lots of peoblems with ATI cards, just a bit left is enuff, probly something like nvnukeatidriver.ex J/K
  2. I had the same problem had to reformat. driver conflicts are not good. what might of been left is a awful .dll that can not be remove for some odd reason even with driver sweeper. enjoy the upgrade.
  3. @ Kensf3: It is probably just a typing mistake but you say you plugged in THE 6 pin power cable, the HD4870 requires two, and both must be connected or it will not run.
    Look in the box, there should be a "Y" connector you can use if the PSU has only one 6 pin cable.
  4. hey thanks guys i think is my psu that could not support 2 x 6 pin.

    Try plugin and the power supply having problems to startup
  5. Which PSU is it? Please give us the make and model of the PSU or the output on the +12 volt line/s (not just the Wattage).
  6. Coozie 7, try the following link:

    http://www.antec.com/Believe_it/product.php?id=MTc1OA==

    It shows the required detail.

    Please let me know if this sufficient, as i was planning to buy new psu.
  7. coozie7 said:
    Which PSU is it? Please give us the make and model of the PSU or the output on the +12 volt line/s (not just the Wattage).


    Coozie 7, try the following link:

    http://www.antec.com/Believe_it/pr [...] d=MTc1OA==

    It shows the required detail.

    Please let me know if this sufficient, as i was planning to buy new psu.
Ask a new question

Read More

Graphics Cards Graphics