Sign in with
Sign up | Sign in
Your question

Maximus Gene III USB issues

Last response: in Motherboards
Share
January 4, 2010 2:15:47 AM

I'm no expert at building. But I made myself a nice rig for christmas.
Everything went smoothly not a hint of an issue except for the recent discovery of some usb problems. :heink: 


OS: Windows 7 64-bit Up to date & Tried 'Fresh Install'
CPU: Intel i5 750
Mobo: Maximus Gene III
RAM: 8 gigs Patriot Viper 5 Series
HD: WD Cavair Black 500g & Seagate 350g
Video: evga nVidia 250 GTS
Disk: LG DVD/CD RW
Power:Corsair HX650w


I can't seem to be able to use any of the usb ports properly. It detects hardware and installs the drivers as normal for generic devices like portable hard drives etc.
But anything too specific or such it fails to recognize and install drivers for.

Specifically I'm trying to install a USB Network Adapter which I've had no problem installing in the past for the same OS on different machines.
It recognizes the device and tries to install the driver but fails. But in case it might be an OS issue so I tried a reformat and clean install. No difference.

Just as another test I tried plugging in a "USB Xbox 360 Wireless controller receiver" it fails to install the driver as well.
Also when I look at the device manager properties. It recognizes device names and such but no manufacturer, dates, etc. details.

I've also tried it with just fresh OS Install with no hardware driver installation then with Intel chipset drivers installed and the whole suite of drivers that came with the mobo.
Problem still persists. Also manually installing the drivers does not work as well. It just loops the driver installation.

Also I can't shut down until the unrecognized or failed driver devices are removed from the usb ports otherwise it will just loop the shutting down screen as well.
So basically it seems like the USB ports are not functioning properly like they are missing controllers or drivers themselves?
I'm going to install the updated chipset drivers from the asus download site right away to see if that makes a difference.

It might be some incredibly obvious reason, it usually is with me but.
I'm no expert and any input, suggestion, feedback or help here would be greatly appreciated.

Thanks. :D 
January 5, 2010 4:55:59 AM

Bah. No reply from asus support yet.

Managed to install some drivers manually.
Basically it seems to be locked out of all 'plug n play' features and freezes up when trying to fix problems manually.

Going to try resetting the board and some other stuff.

Edit:
Tried removing 2 sticks of ram, because I hear this board likes 4 gigs.
Played with every bios function that relates to the usb ports.
Removed all case extensions and had it board & vitals only.

Nothing.
January 5, 2010 7:19:45 AM

Solved!

Just updated from the default 0402 bios to the latest. It installed the device driver automatically for a usb network adapter and another device.
So it appears the usb ports are back to life.
Related resources
January 5, 2010 11:12:21 AM

I was about to say! I have this board on a similar build and I've had zero problems with the USB ports. Sorry no one was able to help and glad you got it figured out.
September 4, 2010 1:42:53 AM

I have the same problem as you, im running an asus gene III with windows 7 64bit and the USB ports are not working right, i can connect and run the mouse just fine, but tried an external hd and a cellphone with its cable and its not installing anything! i updated the motherboard to the lastest bios on its website and ran the cd that came with it and installed all drivers, still nothing. Please respond!
October 10, 2011 2:47:02 AM

Holy Crap! I just run a search in google and came across this thread, amazing what you can find if you try hard enough.

I have had the exact same problem, I noticed it when I attempted installing a USB Network Adapter that worked in one of my other computers. I spent all weekend formatting and reseating the hardware etc... I almost bought a whole new motherboard.


I will try an update the BIOS when I get home tonight, maybe that will fix it...

CiberX did you ever end up finding a fix?

I know this is an old thread but I just had to reply :sarcastic: 
December 12, 2011 5:54:57 PM

My USB ports just failed. It started with the Logitech wireless game pad and now all the flash drives have exclemation points on them as well. I started with Logitech's support. They basically tell me to to all the troubleshooting steps I already did. Then the seond reply is it's defect, return with receipt. It's registered with date and store. Anyhow, I have been running the latest BIOS since it's release.
!