Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte P55-UD6: Help with single graphics setup

Last response: in Motherboards
Share
January 4, 2010 2:34:45 PM

Hi all. I was hoping someone could help me with a problem I'm having with my new P55-UD6 running Windows 7 Ultimate 64-bit. My system has one graphics card, a Sapphire Radeon 4890, located in the first x16 slot. The entire layout is:

PCIEX1_1: Empty
PCIEX16_1: Radeon 4890
PCIEX1_1: Blocked by graphics card
PCI1: Empty
PCIEX8_1: Empty
PCI2: TV Wonder 650 PCI
PCIEX4_1: USB/1394B controller (slot set to x1)

No matter what I try, the Radeon 4890 runs at PCI-E 1.1 x8! It won't run PCI-E 2.0 OR run at x16! This is according to both GPU-Z and the Catalyst Control Center.

Now, I know that populating the x8 slot turns the x16 slot into x8, which is why it's empty.

I just don't know where to turn for help! I tried using Gigabyte's Tech Help, but that's like butting your head against a hard brick wall. They are basically useless! After a week and a half, they have yet to give me one single piece of useful information.

Any ideas on how to fix this would be greatly appreciated!

Thanks!
a c 177 V Motherboard
January 4, 2010 3:16:42 PM

My guess is that you've run into a lane limit of some sort; the PCIe channels for 1156 platforms are on the CPU, limited in number, and 'handed out' by the P55 - just to clarify, before I start digging, is that a P55, or a P55A?
m
0
l
January 4, 2010 3:23:08 PM

It's the original P55, without USB 3.0 or SATA 6 GB support.
m
0
l
Related resources
a c 177 V Motherboard
January 4, 2010 4:51:18 PM

Well, that's good - I know for a fact that both USB3 and SATA3 'suck-up' lanes (if enabled) - I'll look see if there's an adjustment you can make... Back in a bit...
m
0
l

Best solution

a c 177 V Motherboard
January 4, 2010 6:21:06 PM

Well, I'm flummoxed! It's one of those 'this shouldn't be happening' deals... The first two PCIe's should only depend upon the CPU's 16 available PCIe lanes, while the remainder of the crap (the last x4/x1, the other x1's, the ESATAs, aux SATAs, LAN chips, etc.) should use the lanes available from the P55: (direct from the P55 docs)
Quote:
PCI Express Interface - The PCH provides up to 8 PCI Express Root Ports, supporting the PCI Express Base Specification, Revision 2.0. Each Root Port supports 2.5 GB/s bandwidth in each direction (5GB/s concurrent). PCI Express Root Ports 1-4 can be statically configured as four x1 Ports or ganged together to form one x4 port. Ports 5 and 6 can only be used as two x1 ports.

I dunno what the *&^% can be happening with your CPU-hosted ports, and I can only think of a few things to try:
1 - pull your CPU and carefully check for damaged socket pins; while these are usually manifested by wierd memory symptoms, I could envision the possibility of the CPU initialization 'narrowing' the lane count if it detects 'unconnected' bus pins (and they are incredibly easy to damage)...
2 - load the latest BIOS (which I believe is F7c, here: http://china.giga-byte.com/FileList/BIOS/motherboard_bi... ) to see if it helps...
3 - save your BIOS' CMOS settings, clear CMOS, and try another 'Load Optimized Defaults'...
4 - make sure that 'Init Display First' on the "Advanced BIOS FeaturesZ" page is set to 'PEG' (it defaults, for god only knows what reason, to PCI)...
5 - on the "Integrated Peripherals" page, disable any hardware you're not actually using (and maybe some you are, just to test): eSATA, GSATAs, LAN chip(s), and try the x4/x1 slot on both settings (though why this should affect anything, I'm hard pressed to answer - as I said, the first two slots use the CPU - the rest of it uses the P55 - and never the twain shall meet! ...at least in theory, but, then again, I didn't write the &^%$ BIOS!)...
Share
January 4, 2010 9:14:18 PM

Dude! That was more information in one post than the @!%! Gigabyte so-called "Tech Support" has been able to muster in nearly two weeks!

(I feel obliged to pass this on, if only for the humor value.):

I wrote to them and asked this same exact question. I gave them the PCI and PCI-E card layout exactly as I did above, which, BTW, uses the slot numbering out of their own user manual. Both GPU-Z and the ATI Catalyst are reporting the card is running PCI-E Gen 1.1 x8. I also made it clear that ALL of my drivers are up to date.

The first reply was "How do you know it's running x8?" So I told them again. The second reply was "If you have a card in the x8 slot, it will slow the first slot to x8" So I told them AGAIN that that slot is empty. The third reply was, "Is the graphics driver up to date?" and "Did you update the graphics card BIOS?" And, finally, "Swap out the graphics card." THAT'S IT! And this took a week and a half! I understand it was the holiday week, which is why I didn't begrudge the time it took. However, this is the level of response I've come to expect from Gigabyte's Tech Support. They are utterly useless!

Anyway, I'll try your suggestions! Thanks! Pulling the CPU will have to be a last resort, given that that will essentially involve me taking a good portion of my system apart.

I do have 5 HDD and two Blu-rays in the tower. The two system HDD attached to the PCH are RAID 1 mirrors. The Blu-rays are also attached to the PCH. The next two HDD are on the JMicron controller, also as RAID 1. The last HDD is external, connected to the first eSATA port running in AHCI mode.

I'd only thought of the slots as being involved here, not the other resources on the board itself. Thanks for clearing that up!

So could you please confirm my understanding of what that P55 spec says? According to the Device Manager, I have four P55 PCI-E root ports. Are the four PCI-E ports mentioned in the spec the three x1 slots (counting the x4 as x1) plus the eSATA ports? Which is why, if you set the x4 slot to actually USE all four lanes, you lose the other two x1 AND the eSATA ports?

BTW, my root ports are 1, 4, 5, and 7. So it seems that any of those can give up their bandwidth to make a single x4.

I never understood why I also have one "Intel Processor PCI Express Root Port"! THAT'S the beauty on the Lynnfield CPU, isn't it? (And that's the one giving me a problem.)

You have just singlehandedly increased my understanding of this CPU/Chipset by like a factor of 100! :D 

Anyway, I'll try your suggestions and report back!

Again, I really can't thank you enough! Now I can approach this with a lot more understanding of how my system is interconnected.

-geo
m
0
l
January 4, 2010 9:57:08 PM

You have a add on card in a pcie-4 slot. Is that correct ?
I believe you are hitting a limitation of the cpu/chipset.
You have 16 pcie lanes, total. Thats it.
The way the logic switch works, is if you have a card in the main slot alone 16 lanes.
Cards 1 and 2 , the logic switch goes 8x 8x,, (we all know that....)
Cards in 3 pcie slots 8x 4x 4x = 16 lanes
But having a card in the 4x slot creates a similar situation, the switch again
goes 8x, 4x, 4x,
its sort of all or nothing and in slot 1, but it can give you 8
lanes in your primary pci-e and then two more slots dividing the remaining 8.
Take out the card in the bottom slot and it should give you the 16x
m
0
l
a c 177 V Motherboard
January 4, 2010 10:28:45 PM

Nah, notty - you've got it wrong; like I said, there are sixteen CPU-sourced lanes (which service the first two graphics card slots - you want your fastest, most tightly-coupled 'blasters' on the GPU, as it's the major bandwidth hog in a modern system, especially if you're using something like the ATI Avivo codec for your transcoding tasks, to take direct advantage of the GPU's specialty, video encoding...), then, everything else on the system that's hooked up, one way or another, to PCIe gets what's left over, sourced from the P55 itself... What we can't figure out is why, as you have said, when the CPU's lanes are servicing one GPU (again, it's either 1x16, or 2x8 - no 1x8, 1x4, + 1x4), it's 'kicking down' to x8 for a single card; although I suggested a few experiments with the other ports, they really shouldn't have anything to do with it - as, the CPU is servicing the first two slots, and only them, and doesn't have a real difficult decision to make as to whether there are one or two cards 'present and accounted for...'

Geok, I thought of a (probably irrelevant) question - do you happen to have a pair of displays hooked up to that card? It just occurred to me that my displays (four, two per lowly 3850 card) 'look' like four cards to the driver (though not to the hardware hook-up) - wonder if it might be the driver somehow 'misrepresenting itself' to the BIOS' OS start-up init routines... Have you maybe tried it under Ubuntu, or some other flavor of linux?
m
0
l
January 5, 2010 12:37:25 AM

Try updating both your board's and graphics's BIOS to latest.
And, update the system drivers such as chipset & graphic.
m
0
l
January 7, 2010 11:38:05 PM

Well guys, I am totally stumped. Bilbat, sorry for the delay in responding, but, no, I'm just using one monitor and one graphic card!

As you said, the x16 and x8 channels are on the CPU's on-die PCI-E controller. As the x8 slot is empty, I should get all 16 lanes, but I'm NOT!

Oh, and guys, for the love of god, don't ever bother with Gigabyte's "technical" support. They're response is ALWAYS either, "It's someone else's problem," or "Sorry, can't help. Goodbye." I've NEVER, in my 20 years as a NASA system administrator, run into a support staff that is less willing to lift a finger to help their customers, and that INCLUDES all of the government agencies I've had to deal with! In the five or six years that I've been using Gigabyte motherboards, they have never ONCE answered one of my questions.

Please do let me share this latest, classic example! As you probably know, if you're using Gigabyte motherboards, it's common for them to block the first x1 slot with a heatsink. Well, I wanted to know, on the P55-UD6, what's the length from the edge of the motherboard to the heatsink. I forgot to measure it before I built my system, and it seems to me even shorter than the standard Gigabyte fare. They've been unable to answer my question! Their first reply was, "That depends." Given that all I'm asking for is a fixed measurement, set in stone by their engineers when the board was designed, it does, in fact, not DEPEND at all! I've tried every way I can possibly think of to rephrase the question, but they are literally incapable of answering me! This is the standard caliber of support that Gigabyte provides its customers.

Anyway, back to the issue at hand. I'm at the point of giving up. I've tried everything I can think of, but two. All of my drivers and firmware is up to date. I even applied the latest beta BIOS to the board, but it changed nothing. Just for kicks, I did remove the board in the x4 slot, although Bilbat already explained why that shouldn't affect this whatsoever, and, indeed, it did nothing.

In fact, I've actually added a board. In addition to the USB/Firewire adapter in the x4 slot, I just installed a USB 3.0 card in that first x1 slot! (Hence the length question to Gigabyte, which did me no good.) Of course, that first x1 slot in on the chipset, the same as the x4 slot, so it hasn't made a difference, not that ADDING a card would help!

The only things I haven't tried are Bilbat's suggestion of taking out the CPU and checking the mobo pins to make sure that they're contacting the 1156 pads correctly. That will be my very last test, given how difficult it will be for me to take off my CPU cooler.

I also haven't swapped out the graphics card. I've misplaced my DVI to HDMI adapter that I was using with my old HD 3870, and I need it to plug my HDMI cable into that card. As my current card has an HDMI port, I'm not using any adapters right now. I'll probably find it in the next couple of days and then try my old board. Seriously, I don't WANT the old board to run at x16, as that would mean that there's a problem with my new board! :( 

That seems to be all I can try. To be honest, I'm at the point of deciding that I've spent too much time on this already. The display IS working just fine. I'm able to play Blu-rays perfectly, so, obviously, x8 throughput is easily enough.

Thanks again guys!

-geo
m
0
l
February 18, 2010 7:24:55 PM

Hi,

I just noticed that this thread had been marked [SOLVED]. In fact, I'm no closer to figuring this out than I was when I first noticed the problem!

Despite all of the terrific, insightful feedback I received from forum members, I've yet to find an actual solution. I just said I was giving up, not that I'd fixed the problem.

In fact, the only reason I'm challenging this [SOLVED] tag is because I don't want someone who might have a similar problem seeing this and thinking, (incorrectly), that they'll be able to find the solution here.

Thanks!

-geo
m
0
l
!