Sign in with
Sign up | Sign in
Your question

PC won't post - damaged mobo? advice required

Last response: in Systems
Share
July 15, 2009 12:33:41 AM

To cut a long story very short, I removed my CPU fan and heatsink in order to clean it thoroughly and now the computer won't post. It had been working fine before now, for just over a year (so probably out of warranty unfortunately).

My tampering would suggest I managed to damage the mobo when I was playing with the heatsink. I'll admit having some trouble getting it back on as one of the plastic clips bent out and wouldn't go in the hole, and only after a bit of extra shoving did I realise this.

Fans and mobo LEDs come on and immediately switch off again.

I've tried removing all but the basic components to no avail.

Have tried switching out my RAM, using different slots and older RAM which I know still works from a different machine.

Have tried an old, but working, P4 775 socket CPU in it and nothing different happened.

So I've basically narrowed it down to either the mobo or the PSU.

The mobo is an ASUS P5KC and the PSU is the stock one bundled with the Antec Sonata III case.

I was just hoping if I could get any extra advice or tests before I buy a new mobo. There are power lights on the mobo, but these are just simple LEDs. The fans start which leads me to believe it's not the PSU, and I don't think I would have been able to damage that (I hope). If it is down the pan, then I'll just have a nice excuse to purchase a better mobo :) 
a b B Homebuilt system
July 15, 2009 2:36:33 AM

Well, if you can't get one or more of your heatsink pins into its hole, you are going to need a new heatsink in any case. So if you can't overcome that, and make certain the heat sink is TIGHT on the cpu, buy that first.

Did you put thermal paste on? Correctly?

Heat could shut your system down VERY quickly. You could try forcibly holding the heat sink down while starting up and see if that changes anything. Just don't press down hard enough to touch the mobo to the tray beneath it, or you will cause a short :) 
July 15, 2009 3:06:10 AM

4(8)pin cpu connector? It's close to the cpu and could have been knocked loose...

Even without thermal paste it would boot and overheat after a short while.
Related resources
July 15, 2009 9:26:33 AM

Well I fixed the heatsink (which is an Arctic Freezer 7) enough to get it to fit correctly as far as I can tell. It was only one of the tiny teeth that had bent out and I was able to bend it back and now it goes in the hole again and works like it did before. As luck would have it, it was the one between the PSU and extractor fan so I didn't notice straight away, which is probably why I forced it more than I should have to get the heatsink on properly. There's no gap between the heatsink and CPU as far as I can tell and no wobble which indicates it's pretty firm. Thermal paste should be fine. I'm using Zalman thermal grease on it and used the same amount as I did which ran fine for just over a year.

It is an OC'd E2180, but not too aggressive. If I remember correctly it's at 8 x 333 and shouldn't overheat within under a second of booting up. It ran a little hot, but that was why I was installing a middle 120mm fan when I noticed it needed a spring clean. I literally only plugged the 120mm fan into the connector once and tested for a boot and spin to make sure connections were ok before I screwed it in when I noticed a problem, and all I had done prior to that was take off the CPU fan.

It seems to me like there's either nothing coming back from the mobo to tell the PSU to keep power on, or a short which is just causing it to shut off completely. All fans and lights go but it is literally for a split second. Unfortunately I don't have an old PSU or mobo to play with and test. All screws are accounted for, but I will check further for any shorts.

I'm guessing it'll be a breadboard test later today that will hopefully determine the problem. If the mobo has gone I guess I'd have to remove it at some point anyway.
July 15, 2009 4:24:06 PM

r-sky sad it ^ 4/8 pin.

Otherwise try a good old reset cmos.

And maybe you damaged it with esd.

I hope you had the psu off and unplugged while playing around.
a b B Homebuilt system
July 15, 2009 8:27:58 PM

OK, with the cooler fixed and its fan running, heat is not likely the problem.

First thing to do would be a CMOS reset and clear back to default settings. If that fixes the problem, fine, and you can begin to restore the proper OC. If not . . .

Yes, sounds like psu or mobo now. This is a time when its a good idea to have a spare psu you can swp in lol. Antec's psus in the Earthwatts line are quite good, their other economy lines less so. I don't know which you have, but in any case . . .

If you don't have access to a spare psu, and if you don't see specific damage on the mobo, it's little more than a guess in your case. Based solely on problems reported here, the odds are its a psu. So I'd buy a quality psu knowing that if I guessed wrong that spare part would prove useful to me in the future.

Good luck.
July 15, 2009 8:51:27 PM

Cheers for all the help guys. It was the CPU 4pin connector. It was half in, half out haha.

A school boy error, I am ashamed to admit.


Everything has booted up fine. Mobo detected a new CPU for some reason and decided to lower the clock speed to default but leave the multiplier at 8, but I'll sort that all out. Thanks once again.
a b B Homebuilt system
July 15, 2009 8:54:55 PM

Grats r-sky!
!