Wireless only works in safe mode

I cannot connect to my router (WEP key) in normal mode.
I turned off all firewalls, peerblock, spybot etc but it just hangs on connecting.
This is XP SP2 and I am using Wows wireless to manage the setting.

However, using safe mode with networking it immediately connects and internet works.
Any ideas what could be wrong?
9 answers Last reply
More about wireless works safe mode
  1. Safe Mode disables most drivers and Malware... my guess is your system is infected specifically the TCP stack... Start in Safe Mode with Networking and do an Online Virus Scan,

    Online Antivirus Scanners HERE

    Other options:
    How to Repair the Networking Stack
    http://www.windowsmaven.com/How_to_Repair_Network_stack.htm
  2. Chicano said:
    Safe Mode disables most drivers and Malware... my guess is your system is infected specifically the TCP stack... Start in Safe Mode with Networking and do an Online Virus Scan,

    Online Antivirus Scanners HERE

    Other options:
    How to Repair the Networking Stack
    http://www.windowsmaven.com/How_to_Repair_Network_stack.htm


    No viruses detected, I used 1 online scan and also comodo and spybot, nothing.
  3. Post the output from ipconfig/all here when your computer is in Safe Mode & Normal Mode.
  4. Quote:
    Post the output from ipconfig/all here when your computer is in Safe Mode & Normal Mode.


    It is like this on both connections but in normal mode it disconnects after a few mins sometimes.


    test.txt

    C:\Documents and Settings\K.K-953208E7>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : k-953208e7
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Broadcast
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : gateway.2wire.net

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Co
    roller
    Physical Address. . . . . . . . . : 00-16-D4-E0-99-6F

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : gateway.2wire.net
    Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
    Physical Address. . . . . . . . . : 00-19-7E-A9-9F-3B
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.2.12
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    Lease Obtained. . . . . . . . . . : December 30, 2011 5:02:39 PM
    Lease Expires . . . . . . . . . . : January 2, 2012 5:02:39 PM
  5. I turned off SKype's port 80, could that be it?
    Not sure why it would have worked before and not now though.

    If it blocks again, I am going to try a netstat -aon and compare the PID with the PIDs in the task manager.
  6. qwertyjjj said:
    It is like this on both connections but in normal mode it disconnects after a few mins sometimes.


    DNS Servers . . . . . . . . . . . : 192.168.2.1
    Lease Obtained. . . . . . . . . . : December 30, 2011 5:02:39 PM
    Lease Expires . . . . . . . . . . : January 2, 2012 5:02:39 PM



    Your ipconfig /all results, specifically DNS Server and Lease acquisition - expiration date, show your computer is connected to the internet, the problem may be Winsock corruption.. to repair it Download "XP TCP/IP Repair 2.1" from http://www.xp-smoker.com/freeware.html.

    Use the TCP/IP reset button and restart the computer... and next use the Repair Winsock button and restart the computer again.
  7. qwertyjjj said:
    I turned off SKype's port 80, could that be it?
    Not sure why it would have worked before and not now though.
    As far as I know, port 80 is the default port for Internet Browsers, so it's possible that caused your problem. Enable port 80 and assign another port number for Skype in the Windows Firewall.
  8. Stopped working again.
    However, nothing seems to be bound to localhost:80.
    Email works though.
    Any ideas?
  9. qwertyjjj said:
    Stopped working again.
    However, nothing seems to be bound to localhost:80.
    Email works though.
    Any ideas?
    E-mail through an email client? (Outlook, Outlook Express, Thunderbird?)... the difference between Internet Browsers and Email Clients are the ports they use to connect to the Internet. Have you added an exception for port 80 in the Firewall?

    Default Ports for Email Clients: Pop, Imap, w/wo SSL
    http://hostbaby.org/wiki/Default_Ports_for_Email_Clients:_Pop,_Imap,_w/wo_SSL

    my HTTP port 80 internet connection won't work
    http://www.daniweb.com/hardware-and-software/microsoft-windows/web-browsers/threads/100533
Ask a new question

Read More

Wireless Safe Mode Windows XP