Is my power supply good for my graphic card? hd 4870 x2

i have purchased an hd 4870 x2 graphic card, it and all the computer powers off as soon as i go to bios main menu
it is not a heat issue so i'm thinking it's either the power supply or the motherboard
my board workes 100% fine with nvidia 8800 gt but not with the ati; it also takes vert long to go to the bios
my motherboard is an asus p5ne sli
my power supply is an easy cool 700 w
it's voltage are as follows :
+3 3dc = 36a, + 5vdc = 40a, +12v 2dc = 20a
-12vdc 0.aa +5vsb = 3.0a

the graphic card needs 40amp
is my psu enough? or should i change my motherboad with an intel cheapset

1 more thing; my bios with the nvidia card is latest
when i put ati card it goes to original, i couldnt upgrade it because it will shut down before i do anything
i do get motherboard logo on startup all the time with ati

could you pls help?
8 answers Last reply
More about power supply good graphic card 4870
  1. As far as I know your PSU should be fine for that type of card, but shutting down does sound like a power issue. I have 2 4870 running with a 700w PSU and its running just fine.

    Have you uninstalled your previous drivers of your other card? I believe that can cause issues if you have not. Well it did for me a few years ago anyway.
  2. hi drak, would you give me the model number of your power supply so i can compare it wihth me. i am using the single card
    also i am using a converter 2 molex to 8 pin.
  3. I am using an X-Power ATX-700TW. I am using the two 6-pin connectors (one on each card) and I am also using two molex connectors (again one on each card).

    Oh also, I have the converters on separate molex rails. It wouldn't get enough power for two of them on only only rail. Actually, if you have them on the same rail, then perhaps that is the problem.
  4. I wouldn't risk it, get one from PCP&C, antec , corsair or seasonic an the same wattage range.
  5. Helloworld_98 said:
    I wouldn't risk it, get one from PCP&C, antec , corsair or seasonic an the same wattage range.


    Is that to me or pcfixed? :)
  6. well your powersupply gives 24amps on the 12v! i cant beleive its running your cards
    actualy i am only running one card called "hd4870x2) not two seperate cards, and
    aparantly it needs 40amps on the 12v rail.

    but in your case you should need even more! unless i am wrong
  7. Its running fine actually. I don't have any power issues. I'm running Crysis with max settings and everything is going well. I'm getting a huge boot in speed compared to the previous card.

    I just spent the past day pushing it as hard as I could to see if there would be any problems. Still stable and no sign that there is any inefficiencies.
  8. drakenabarion said:
    Its running fine actually. I don't have any power issues. I'm running Crysis with max settings and everything is going well. I'm getting a huge boot in speed compared to the previous card.

    I just spent the past day pushing it as hard as I could to see if there would be any problems. Still stable and no sign that there is any inefficiencies.



    ok i got a 850w 35ams power supply and its no longer switching off, the problem now its V slow, even to go to the bios
    it takes 5min and to load OS takes 10 minutes i know it needs bios upgrade but the mobo wont allow me, i think anything
    not intel chiped wont work well with ATi

    if you have the HD4870x2 2gb Graphic card, what is your model number for the mobo so i can buy same as yours?
    cheers...or can you recommend any that your friends are using and not having huge problems with.
Ask a new question

Read More

Graphics Cards Power Supplies HD Graphics