Sign in with
Sign up | Sign in
Your question

Canon eos rebel digital driver

Last response: in Windows 7
Share
September 28, 2011 11:31:09 AM

Hello,
I have a Canon EOS digital rebel camera. My OS is Windows 7. My computer indicates I need a driver. Canon says no driver is available. What can I do?
a b \ Driver
a b $ Windows 7
September 28, 2011 1:10:22 PM

Do u have USB drivers installed?

What happens when u connect the camera to the PC?

Any message comes up?
a b \ Driver
a b $ Windows 7
September 28, 2011 1:13:17 PM

BTW, did it worked before? Or is it your first time?

Make sure u turn the camera on, after the connection.
Related resources
a b $ Windows 7
September 28, 2011 2:08:16 PM

or take the card out and use an sd/cf readers, it'll be a lot quicker.
December 26, 2011 6:23:13 PM

martha Allen said:
Hello,
I have a Canon EOS digital rebel camera. My OS is Windows 7. My computer indicates I need a driver. Canon says no driver is available. What can I do?


Martha,
I had the same problem(albeit Windows 7 64 bit) and finally called Canon. You need to change the setting of how the camera communicates withthe computer. It's reall easy:

1) On the camera, push the "MENU" button
2) Toggle over to the second set of tools (the last one on the right)
3) Toggle down to "communication" and change it from "normal" to "PTP"

Your computer will automatically take it from there. I did get a few error messages when trying to download pics the first few times, but it works smooth now.

slc
February 21, 2012 7:33:02 PM

unafraid leroy said:
Martha,
I had the same problem(albeit Windows 7 64 bit) and finally called Canon. You need to change the setting of how the camera communicates withthe computer. It's reall easy:

1) On the camera, push the "MENU" button
2) Toggle over to the second set of tools (the last one on the right)
3) Toggle down to "communication" and change it from "normal" to "PTP"

Your computer will automatically take it from there. I did get a few error messages when trying to download pics the first few times, but it works smooth now.

slc



Changing the "communication" from "normal" to "PTP" works great! Now I can view my images directly in photoshop.

Thank you,

Rick J.
!