CPU-Z not showing overclock with Gigabyte mobo and i5 2500k

I just picked up a Gigabyte GA-Z68XP-UD3 and i5 2500k from Microcenter for my new pc. For my Corsair memory to work properly, XMP has to be enabled and that overclocks my cpu to 3.7ghz. Thats cool.

The overclock shows up in the bios fine and my PC runs fine, but CPU-Z does not show my overclock at all. It still says 3.30.

Ive tried 2 different versions of CPU-Z and im just frustrated. (messed around with BIOS settings, disabled a few power saving ones and nothing changed)

Does anyone know why this is happening? Is my i5 2500k or motherboard bad?
4 answers Last reply
More about showing overclock gigabyte mobo 2500k
  1. Try use lavaly everest , this soft had CPUID
  2. thanks, i think i got it working finally and not sure what i did >.>
  3. Make sure your BIOS is up to date. When updated it sets all BIOS settings to default.

    XMP should not overclock your CPU automatically.
  4. I5-2500k. Generally speaking on stock the Speed will be around 1.6 GHz @ idle, If an application is single threaded it will run upto @ 3.7 GHz on one core and for multi threaded applications all for coures will operate @ 3.3 GHz -> 3.7 depending on percentage of utillization.

    As Photonboy stated XMP should not effect CPU speed as that is a funtion of Bus (which for SB should be 100 MHz and NOT Bumped up) and the CPU multiplier.

    Mine is set to 4.2, but as I did not disable power features it is @ 1.6 GHz when idle ( on Internet), but if I run furmark it jumps upto 4.2 Ghz.
Ask a new question

Read More

Intel Overclocking CPUs Gigabyte Intel i5