Sign in with
Sign up | Sign in
Your question

Raid help

Last response: in Storage
Share
April 22, 2011 6:03:42 AM

So after countless days upon trying to solve my modern warfare 2 loading levels very slowly, i came to the conclusion it was my main hard drive being slow. It takes 30+ seconds on the first load (Accessing the hard disk) and 6-8 seconds on its next loads (in the RAM). So i decided to dive into the world of RAID. Here is my setup.

750GB Seagate. Main Hard Drive. I DONT want this to be in the RAID setup as i dont want to reinstall everything, plus i dont have an identical drive.

80 GB Seagate. Raid drive.
80 GB Seagate. Raid drive.

I would like the 2x80 GB to become part of a raid 0. I am having so much trouble doing this i feel mentally retarded.

My motherboard is a GA790FXTA-UD5. I have tried countless numbers of options in the bios. i want to do a hardware RAID because from what ive read a software RAID is alot slower.

Questions:
What exactly do i need to do in the BIOS because every tutorial has a completely different RAID controller setup in the BIOS.

In my messing around with things, sometimes if i set all the SATA Controllers in the BIOS to RAID, i get a bluescreen when windows is getting ready to start. Also, if i do that, the bios doesnt even see ANY of the drives, even the main one.

There are 3 RAID options in my bios with 1 of them i dont know what to do in, it doesnt even let me do anything in it, it is called GSATA, and from what ive seen on the web, the drivers are poor. Then there is an ESATA and a SATA controller which i can set to IDE,RAID or AHCI

Do i need to format my 80GB's or do i make it unallocated?

Do i need drivers on my Windows 7 64bit?

Am i doing this right?

Sorry for being so 'idiotic' but ive never messed with RAID before. :cry: 

More about : raid

a b G Storage
April 22, 2011 6:59:36 AM

I suspect that because your main drive has Win 7 installed on it already your OS is set to start up in standard SATA. If you activate the RAID Controller then that drive has to be seen by the controller as a RAID array drive even though the drive is neither mirrored or striped. Therefore Win 7 becomes unhappy when the controller presents the drive as part of a RAID array when the drivers Win 7 using is plain SATA. Normally you are required to have the RAID controller activated at install and Win 7 will load the drivers it requires and treat the drive as a single drive in a RAID array. This is why you will be getting the blue screen. The way forward is to make sure the 80 GB drives are not on the same controller as the System Drive. Do not activate the ESATA controller as RAID leave it as SATA. So System drive on Controller 1, the 80 GB drives go on controller 2 and ESATA is left as standard. Hope that helps.
m
0
l
April 22, 2011 3:51:21 PM

That makes sense now, but how do i tell which controller my 80GB are on? how do i change them?
Im pretty sure i have two controllers because after the tiny bits of info, the people were talking about more advanced raid topics, but they said the GSATA was the slower raid, which i would probably use for my main drive, and the other controller that im apparently using now is for the 2 80GB. Thanks for all the help.

[edit]

Ok now i have put my main drive on one of the 2 GSATA Controllers, and i put my 80GB in the SATA controllers, then i went in the bios and set the SATA controllers to RAID. It didnt bluescreen like it always would, but windows doesnt see the drives, not even in the Disk Management tool. Any suggestions?

[edit2]

Ok so i have it in the setup that i think would be the best way to do it, but Windows still doesnt recognize it. What i did was set the Main hard drive into Port 4
RAID hard drives into Ports 0/1

Because in my BIOS it has ports 0/1/2/3 in one channel and 4/5 in another channel so i set the 0-3 in RAID, and my 4-5 in IDE. Then i went in the RAID configuration (ctrl+f) and all it had seen was the two RAID channel drives which is good i guess, then i set the two drives into raid, i start my system, my BIOS doesnt see the 2 drives, then it flips to the RAID utility scanning for drives and it sees the RAID drives, then Windows starts up and it only sees my main drive. It was weird though because it said that my 'drivers' for my ATA device were ready and that i needed to restart, so i restarted, and still no luck in seeing them.

I do see a RAID Controller in the Device Manager, but it has a yellow exclamation mark. Im not sure what drivers i need.

[edit3]

Ok im making progress, my raid device has a driver now, but it still isnt detecting the drive. The bios detects the IDE main drive, but then when the RAID UTIL comes up after the bios, it says it cant find any RAID Configs, then it does a scan for it real quick and finds them. I have no idea what to do now. So basically, its in a raid, i have the right drivers, my main is successfully in IDE on a different channel, but it still does not detect the RAID setup.
m
0
l
Related resources
April 22, 2011 6:12:45 PM

Ok now i see the combined RAID Drives in the Disk management! YAY! Still one problem, i dont know what to do about it, do i format it? Because it says 'unallocated' and therefore i cant use it. Any help?

[edit]

K i got it to work, i just formatted it :D  im happy now.
m
0
l
April 23, 2011 5:53:11 AM

Hey so iam having the same problem as you. i put my ssd which has my os in sata port 6 and had my two hdds in sata ports 1 and 2. Right now it won't recognize the hard drives and i have the yellow exclamation point as you did. any advice?
m
0
l
a b G Storage
April 23, 2011 6:47:42 AM

You need the RAID driver that applies to the RAID Controller. Go the website that the motherboard manufacturer will have in place to provide Drivers.
m
0
l
!