Sign in with
Sign up | Sign in
Your question
Solved

USB 2.O HELP !!!!

Last response: in Systems
Share
July 23, 2009 12:09:52 AM




I have just recently built a new custom PC. It incorporates an ASUS M4N72-E motherboard, AMD Phenom II 3.0 Gig liquid cooled Quad core processor, twin Nvidia 9800 GTX 512mg graphics cards (running in SLI mode), two 2-gig sticks of 1066MHz DDR2 corsair ram for a total of 4-gigs, Twin SATA 3 hard drives (250 gig & 500 gig), Sound Blaster X-Fi Xtreme Gamer (PCI express) audio card, twin DVD lightscribe drives, an 800 watt power supply all housed in a Smildoon raidmax lime green lighted case running WindowsXP Pro 32 bit operating system. Everything seemed to be operating fairly well until I downloaded "Driver Detective" to update all of my drivers. When I updated my USB drivers, the USB 2.0 driver load failed and froze the PC every time. I tried to contact driver detective for a fix with no response until they finally refunded my purchase price as they had no answer for this problem "GREAT". I noticed that in device manager I had lost my two listed "USB 2.0 root hubs" and two "Standard Enhanced PCI to USB 2.0 Host Controllers". Now all that showed up was two - "Standard Enhanced PCI to USB Host Controllers" , two - "Standard OpenHCD USB Host Controllers" and four "USB Root Hubs", NO USB 2.0 Components listed. I tried everything possible to correct this, even deleting all of the USB components in "Device manager" letting windows re-install them, all with the same outcome (did not show back up). After all of this I gave up and wiped the "C" drive clean and re-loaded windows, all of the software for the motherboard, graphics cards, audio card, etc. Then went on to microsoft's website and updated everything possible with all of the latest updates and fixes. Well to my total frustration, the problem is still apparent as I still have NO "USB 2.0 components" listed in device manager ????????? How in the world is that possible after re-loading windows on a fresh drive? Please, Please, Please can anyone help with this matter???? I have pulled many hairs out trying to fix this nightmare!!!!!! I also checked in the system Bios and all of the USB functions are enabled including hi-speed controller mode. WTF !!!!!!!!!!!!!!!!!!!!
Shadowman2k

More about : usb

a c 136 B Homebuilt system
July 23, 2009 12:22:45 AM

what happens when you plug in a usb device?

does it work ?

what are transfer speeds like ?
m
0
l
a b B Homebuilt system
July 23, 2009 1:08:33 AM

System restore is your friend, or you could try rolling back the drivers.
m
0
l
Related resources
July 23, 2009 3:21:54 AM

I could not perform a system restore, it stated that it could not restore to any of the points I attempted due to no drivers being backed up ??? That is why I wiped the hard drive and re-loaded Win XP Pro as I stated. Even after loading WinXP Pro on a clean drive, I still show no USB 2.0 devices in device manager. All of my USB devices work but I am unaware of how to check transfer speeds. The whole thing is that I do not understand why I lost the 2.0 portion of the two "Standard Enhanced PCI to USB Host Controllers" and the two "USB Root Hubs". When I first built the PC and loaded windows for the first time, all of the software for the ASUS motherboard, etc. i had USB 2.0 listed in my device manager for both above. Me confused !!!!
m
0
l
a c 136 B Homebuilt system
July 23, 2009 4:46:55 AM

so everything works ... and thats a problem?
m
0
l
a b B Homebuilt system
July 23, 2009 6:02:09 AM

You could download a free trial version of Sandra or Everest and check the transfer rate of your USB memory device if you get much over one Mega Byte per second transfer rate then you are running at USB 2 speeds and I would forget about it. If window’s doesn’t automatically install the correct drivers, then the Motherboard drivers should do so.
m
0
l

Best solution

a b B Homebuilt system
July 23, 2009 4:34:53 PM

I fail to understand exactly what the problem is if everything is working as well, but I can tell you one thing, don't use programs like "Driver Detective". If you feel you need a driver update to fix a problem, go to the manufactures website and get it.
But I think the very best advice is, if it ain't broke, don't try to fix it.
Share
July 24, 2009 2:23:49 AM

Everything is working but I am unsure if my USB ports are running at the correct speeds (2.0 speeds). And believe me, I will never download any of that crappy software ever again. It still does not make any sense as to why the USB 2.0 does not show up in device manager as it did when I first set the system up on the initial install of WinXP Pro. I may try one of the trial programs suggested by "pjmelect" to see if they are all running at 2.0 speed and if they are then no problem.
m
0
l
!