Sign in with
Sign up | Sign in
Your question

Strange RAM upgrade problems

Last response: in Memory
Share
January 15, 2010 5:40:39 PM

This is a strange one, and I have done everything I can think of. And apologies in advance if I include too many details. Just thought that my various attempts to resolve this might shed some light on the problem.

I previously built a HTPC that was very stable.

Gigabyte GA-945GCM-S2C
Intel E4500
2 GB (2x1GB) DDR2 667 Kingston RAM
SAPPHIRE Radeon HD 3850
Vista Ultimate 32bit.

Again, for two years, no complaints. After picking up a PS3 I really wasn't using this anymore so decided to upgrade to Win 7 x86, bump the RAM to 4GB and re-purpose as secondary work PC.

Before I upgraded the OS and before I swapped cases, I upgraded the RAM just to confirm that it would still post (call me paranoid...). This particular board only has two RAM slots, so I had to replace the two 1 gig sticks with two 2 gig sticks. Same brand (Kingston), same voltage (1.8), certified to work with this MB as per Gigabyte's website. Anyway, I swapped them out and all was good. Motherboard posted fine and recognized all 4 gigs of RAM, as did Vista – actually 3.25 gigs, but I expected that given the 32 bit limitations. Then, I upgraded the OS via a clean install, leaving the new RAM in place. Again, all was fine.

I transferred everything to the new case, only removing/unplugging what was absolutely necessary -- left CPU, heatsink and memory in place. Took all the normal anti-static precautions, etc. etc. Reinstalled everything in new case and powered on.

Nothing. Would not post. All fans (heatsink, video card, case) turned on, DVD drive worked, but could not get it to post. Tried everything I could think of, including removing all hardware that wasn’t absolutely necessary, re-seating memory, rechecking all connections, even removing front case header connections just in case they were causing a short. Still nothing. At this point it was late so I gave up for the night, figuring I had fried something during the case switch. I turned off the PSU and unplugged it.

Next morning, I decided to revert to old RAM to see what would happen. This time, it booted. Obviously very happy that it did, since it meant that the MB was OK. But still… weird. I finished doing some tweaks, installing software, reconnected all hardware and other case connections and restarted several times. No problems.

Tried installing new RAM again. Didn’t post. Tried different RAM (2 GB Crucial DDR2 800 sticks from home PC) that I know are good. Didn’t post (and when I reinstalled them in my home PC, they were recognized as before, so I don’t think I am killing these things when I’m installing/reinstalling – plus, the original sticks of 1 GB Kingston RAM from the HTPB work fine).

Gave up and reinstalled the original 1 GB sticks. STILL won’t post. Once again, unplug AC from PSU, leave overnight. Next morning, boots fine, and has for the past several days.

I'm going crazy trying to figure out what is going on here. I know that the easiest solution would be to leave well enough alone and stick with the 2 GB of RAM I have running now. But it WAS working with 4 GB at one point (and on two different OS’s).

What I have not done (yet) is update the BIOS. Everything worked fine at one point using the current BIOS, so I don’t think that's the problem. I guess I am just wondering if anyone has any thoughts or suggestions before I go down that road. Is there something else I'm not thinking of? Maybe clearing the CMOS?

Thanks and apologies again for the length of this post -- hope I didn't put anyone to sleep with this!




a c 128 } Memory
January 15, 2010 7:27:49 PM

You can try clearing the cmos; can't hurt. Also check for a "memory mapping" option in the bios. Try changing that setting.
m
0
l
January 15, 2010 9:13:54 PM

Definitely try clearing the CMOS.

Two additional thoughts come to mind. It could be that something is shorting out in the new case. Please try to breadboard the system using JSC's guidelines:
http://www.tomshardware.co.uk/forum/page-262730_13_0.ht...
If everything works outside of the case, then carefully put things back inside making sure that the motherboard standoffs are in the right locations.

Before making any case wiring connections to the new motherboard after you have it installed in the case, just short out the startup pins to see if it will post. If it posts then turn it off, connect the case start button wiring and try again. Do this with each connection to be sure that there is not a short in the wiring that could be causing the PSU problems.

Last of all, what power supply are you using. Do you have a spare that you can use?

Please report back your findings. Good luck!
m
0
l
Related resources
January 16, 2010 5:26:39 AM

Like other 2 said before ,do a CMOS clearing.
I clean my PC once at month, and when i clean my heatsink i have to remove one RAM stick.
Almost every time there is no post, only after a CMOS clearing . But i have an overclocked machine, with non standard timings Ram. For me is normal.
m
0
l
January 16, 2010 12:42:20 PM

Thanks a lot for the suggestions! Will work on this today and let you know what happens.
m
0
l
January 19, 2010 1:49:48 PM

Well, looks like clearing the CMOS did the trick. I also flashed the BIOS to the newest stable (non-beta) version.

To be honest, it wasn't totally seamless. The MB would not post with the 4GB of Kingston memory (DDR2 667), no matter what I tried. However, it would post with the 4GB of Crucial memory (DDR2 800) I pulled from my home PC. I left it running all weekend, restarted several times and all seems fine, so at this point I am going to stick with Crucial and chalk up the Kingston problem to a compatibility issue.

(Oddly enough, on Kingston's website, when I select my Gigabyte motherboard to search for appropriate RAM modules, it states that the MB supports a maximum of 2GB RAM, and does not suggest/list any 4GB kits. When I go to Crucial's site, they list my MB as maxing out at 4GB. Have no idea if this is just a coincidence, but there you go.)

Thanks again for all the suggestions. Much appreciated.
m
0
l
January 19, 2010 1:51:19 PM

o1die said:
You can try clearing the cmos; can't hurt. Also check for a "memory mapping" option in the bios. Try changing that setting.


Thanks -- couldn't find any memory mapping option in the BIOS, even for latest version.
m
0
l
!