PC won't post

Hi, I recently bought a new mobo/cpu/heatsink&fan/RAM and PC case to upgrade my old system.
I put it together, turned it on, the fans started whirring, Lights inside came on, but there was no beep from the chassis fan or anything to the monitor. It won't post.

Most of the stuff was taken out of my old PC I upgraded from, so I know they work perfectly, here's the specs:

Intel i5-750 2.66GHz processor
Gigabyte GA-P55A-UD3 Motherboard
Arctic Cooling Freezer 7 Pro Rev 2 CPU Cooler
Corsair Dominator 4GB (2x2GB) DDR3 PC3-12800C8 1600MHz Dual Channel RAM
Powercolor ATi HD Radeon 4850 512Mb -- definitely works
Asus d2x xonar pci-e soundcard -- definitely works
Zalman zm600-hp 600w psu -- definitely works
Samsung 1tb f1 HDD -- definitely works
SATA blu-ray disk drive -- definitely works
IDE DVD-RW drive -- definitely works

Tried plugging it in sat on the mobo box with just the psu, mobo, ram and graphics, got exactly the same problem- fans whirring, lights on but no beeps, no post.
Tried taking the Graphics card out and trying it without that to see if I even got beeps indicating it was that that was the problem, no change.
Tried taking the ram out, and even the cpu, always the same result.

After looking it up, i'm guessing, but not certain, that it's NOT a DoA mobo, as they seem to either not power up at all, or run into an endless rebooting cycle.
9 answers Last reply
More about post
  1. Got the CPU power plug (4/8-pin) connected?
  2. Yes, although on that PSU it comes as 2x4-pin for the 12v 8-pin rail, i looked it up and it says it can be used in either 4-pin or 8pin, it's just split up for adaptability with different mobos, so that shouldn't be the problem
  3. Forgot to say sorry- Thanks for the quick reply :)

    If it's any help, I was abit concerned when putting the CPU in that the cover for it was very tight (yes, I checked it was seated properly), and the heatsink is also a tight fit.
  4. Hi thanks for the reply :)
    i've ran through everything on that list and still get nothing, which according to your thread says it's mobo/psu/cpu issue.

    PSU works fine in my older athlon 64 x2 6000+ system, so almost certain it's not that.

    Leaving only the mobo/cpu
  5. Do you have a system speaker installed?
  6. Yes, as I said in my original post- no beep or any sound at all from it :(
  7. Sent the motherboard back after contacting overclockers UK(The ones that sold me it).
    They returned it saying they tested it and it posted and booted fine, although they've updated the bios

    just gotta wait to see if it was the bios thats a problem.

    Bit annoying if you need to update your bios for a cpu to work... but you can't get into the bios cos it needs a working cpu. Not gonna buy 2 cpus every time i buy a new mobo -.-
  8. Got the mobo back today, with the updated bios, according to their testing it works perfectly, with an updated bios too.
    However, I have the same problem still.
Ask a new question

Read More

Motherboards