SATA 123 not detected in BIOS ?

My PC a Dell XPS400 2.8GHz Dual Core with 3GB's DDR2 RAM & a 250GB Samsung internial 7200RPM SMART drive, a 320GB externial Seagate FreeAgent USB drive O/S WindowsXP MCE2005 ATI PCI-E Graphics and a ATI TV Wonder Elite TV Tunes card PCI !
Any way I just has to perform a fresh install of the O/S after it refused to bootup , all the test I ran in the diagnostic tests finished showing all the H.W. devices as working with no problems ! So I know the hard drive was still good. This PC is set up with a SATA Array/RAID configuration (What ever that is) After the fresh install my system seemed better then ever ,fast like when it was new ! However one problem thats a minor inconvience is on bootup after two beeps a prompt on a black screen states SATA drive 1,2&3 are not detected ? In the BIOS they are set to on by default ,however I do not have any H.D. in those ports ,my only internial H.D. is on SATA 0 and is set to AHCI/ATA Autodetect ? Some reading I've done said I had to change it to combination in the BIOS however when I try that setting Iam warned by the system that this will cause me to lose the other settings and my PC may not be able to read the H.D. ,no thanks its working this way untill I find a better fix I will continue to press F1 .One ? I do have is if I set SATA 1,2&3 to off in the BIOS would this have any ill effect on any other hardware on my system, USB devices etc. If not then this may allow the system to bootup without the press F1 to continue prompt ? Any suggestions (besides buy a new PC) would greatly appreciated :-)
Thanks in Advance to All
1 answer Last reply
More about sata detected bios
  1. Dell is intensely annoying this way, although some other motherboard manufacturers commit the same sin.

    In the BIOS, disable each individual SATA port that does not have a drive on it. Most mobos just scan and ignore the port if there is no drive, but Dells are obnoxious about it.

    I back up my girls' computer with an eSata drive. I have to boot to bios, enable the port, reboot, do the backup, boot to bios, disable the port, remove the drive, and reboot.
Ask a new question

Read More