Sign in with
Sign up | Sign in
Your question
Solved

Partition peril

Last response: in Storage
Share
April 27, 2011 6:41:52 PM

i finally have my first build up and running! :D 

i got it to boot and am attempting to install windows 7 ultimate into my hard drive.

my hard drive is a used, completely wiped out 1tb drive. windows says i cannot install on it because the partition is not the correct type. it says i have a GPT, and it needs to be ESP. i have no idea how to even begin to fix this problem. and it will not accept a format attempt.

can someone help me with this?

gawd! learning curve is steep! :p 

More about : partition peril

Best solution

a c 377 G Storage
April 27, 2011 6:45:52 PM

During the install you should be given the chance to create/delete partitions. At this stage, delete all partitions, then create a new one. If it asks for GPT or MBR, select MBR since you can't boot from a GPT partition.
Share
a c 415 G Storage
April 27, 2011 6:53:40 PM

Hawkeye is right - here's what you need to look for:

- on the screen that says "Which type of Installation do you want?", choose "Custom (advanced)".

- on the next screen ("Where do you want to install Windows?"), click the "Drive options (advanced)" link in the lower-right portion of the window.

This will give you options to select and delete all of the existing partitions and create new ones.
m
0
l
Related resources
April 27, 2011 7:00:48 PM

i am encouraged by your help, my friends.

sminlal, apparently w7ultimate didn't think it was necessary to offer the "advanced" link.

i have not loaded the drivers for the motherboard yet. would this rectify my situation?
m
0
l
April 27, 2011 7:11:53 PM

i found the advanced option. you have to back all the way out and start over again. however, the advanced option didn't offer any options. *sigh* i clicked on it and it simply tried to format it like the other format button. i'll try a cold boot.
m
0
l
April 27, 2011 7:18:02 PM

should i delete the partition in question then try the format option again?
m
0
l
April 27, 2011 7:34:42 PM

okay. i'm still stumped.
m
0
l
a c 377 G Storage
April 27, 2011 7:38:13 PM

You can't switch from GPT to MBR without deleting all partitions first. Then when you create a new partition is when it should ask for GPT or MBR.
m
0
l
April 27, 2011 7:38:32 PM

is there anything in the BIOS that would prevent me formatting it?
m
0
l
April 27, 2011 7:44:02 PM

thanks, hawkeye. but i doesn't ask the question. my drive is totally unallocated, yet i keep getting a message that it is GPT. it doesn't offer to change it.

i do get a screen that tells me the size of the drive, with an apply or cancel button.

do i have to allocate some space for a new partition first? if so, how much space is recommended?
m
0
l
a c 377 G Storage
April 27, 2011 7:54:17 PM

I don't use multiple partitions on my drives. I normally delete all partitions and create a new one using all of the unallocated space (entire drive). So, when you create the new partition it doesn't ask if it should be a MBR or GPT partition? You are creating at least one partition, right? After all, windows will ask you which partition to install to.

If it doesn't ask for MBR or GPT, I'm surprised it doesn't just alter the boot info since Windows already knows it can't boot from a GPT partition.
m
0
l
April 27, 2011 7:56:07 PM

perhaps i need to delete the system partition too. let me try that and see if i get a different prompt.
m
0
l
April 27, 2011 8:09:29 PM

i am such an e-tard!

if i'd read your first response (hawkeye) correctly it would have been solved immediately.

i have it installing now. thank you very much, guys!
m
0
l
April 27, 2011 8:12:59 PM

Best answer selected by Googlybear.
m
0
l
a c 377 G Storage
April 27, 2011 8:13:00 PM

No problem. Now that I think about it, I don't think it will ask for MBR or GPT during the install, but will through "disk management".

Worse case, you could have slapped the drive in another machine and ran diskpart with the "clean" parameter and that would do the trick too.

edit for spelling, doh!
m
0
l
!