Sign in with
Sign up | Sign in
Your question

SATA HD not detected in BIOS

Tags:
  • New Build
  • SATA
  • Hard Drives
  • BIOS
  • Systems
Last response: in Systems
Share
July 26, 2009 11:06:36 PM

Hi all- new to forums here but not Toms hardware... I joind the forum 'cause I need help!

I have the P6T with i7 920 DO. I'm starting a new build and my BIOS won't detect the WD caviar black 1TB sata i have plugged in. I already did the dummy checks on myself- checked cables switching between the DVD drive and HDD to make sure they're good, reset the BIOS doing the jumper trick in the manual. Used different sata ports. I tried going back and forth between IDE/SATA/AHCI settings. The POST shows there is a HDD there, but nothing detected in the BIOS. I even disabled the JMICRON to see if that would change anything. I was going to flash the BIOS to the newest but I read what the changes are from the version I have and the newest version and it says nothing about SATA updates or changes.

I plugged the HDD into a SATA to USB cable/converter I borrowed from a friend and when I plug it into my laptop (running xp sp3) it says a mass usb storage device is detected- but I can't see it in "my computer". I tried plugging it in through this usb method to the new build and in the POST it shows the same thing- usb mass storage device detected. When I get to windows 7 rc load screen it says I can't load windows through usb HD- plus it won't let me do anything with the drive (format) and it doesn't show info on it- just generic label that its a HDD.

I tried one more time through the SATA connection on the mobo and it hangs up in the POST where it says detecting SATA port 1- it just locks up and stays there. I hear a "click, click, click, clack" pattern with a pause between- repeatdly. I'm pretty sure its a bad hard drive after all this testing. I'm ready to RMA this bad boy to Newegg. Any thoughts from anyone else? I'm tapped on ideas and think it's the HDD. I've been out of the PC building trade a while (I was in the Army a bit and slacked on my geeking skills) so SATA is new to me. Please help me out or confirm my diagnosis.

Thanks a lot!
Jeremy

More about : sata detected bios

August 10, 2009 7:52:15 AM

Sometimes the correct explanation is the simplest. RMA that failure of a hard disk!
August 10, 2009 10:13:35 AM

Yup, I got a new HD back from new egg; plugged it in and it worked fine. Thanks for the reply though. Sometimes it really is the easiest answer that solves the problem.
!