Cant get windows7 64 to see sata HDD during install

I am having a issue installing Windows7 64bit on a Sata HDD. I have everything correctly set in the bios and I have updated the BIOS. I have all the needed drivers loaded on a usb flash drive, I point the installation to the drivers and they load fine but the drive still doesnt show. The hard drive even shows in the bios as ide slave. My set up is a i5 750 cpu- GA-P55-UD3R mobo, 500 gb Western Digital sata HDD. Any help would be greatly appreciated.
5 answers Last reply
More about cant windows7 sata install
  1. I had a similar situation happen to me which I overcame by enabling AHCI in the BIOS.

    Different motherboard here so your mileage may vary but that's what worked for me.
  2. I tried that in the BIOS but it still wont see the drive during the install
  3. Make sure you have the SATA hard drive plugged into an appropriate SATA port as on some motherboards there are ports designated for a specific purpose to be used in a particular way.
  4. i ahd that problem turned out i was missing the scisi thing ro somethign liek that happen in xp vista and 7 each time i had to have someon else look at it he said when i formatted my drives the os cleared the entire drive but i also found out that it was bios related later on. if you give us your mobo info and hdd info we can help you quicker adn better. i think the guy at the shop had to use a diffrent computer or program to install the os.
  5. the mobo is GA-P55-UD3R, the harddrive is 500 gb Western Digital 5400 rpm. Thanks
Ask a new question

Read More

Gigabyte SATA Hard Drives Windows 7 Motherboards