Sign in with
Sign up | Sign in
Your question

Intel D945GCLF2 - Brand new - VGA not working... help please?

Last response: in Motherboards
Share
January 19, 2010 8:45:19 PM

I just got a Intel Atom D945GCLF2 board from Newegg.

I put it in a case, popped in some RAM, put in SATA HDD, 400W power supply (much more powerful supply than necessary for this board but its all I have atm), plugged in USB keyboard, and finally LCD connected via the VGA.

I power the thing on and...... nothing shows up on the VGA. Everything is powered on though. Board has a green LED lit up next to the RAM and the chipset fan is running just fine. HDD is spinning up fine. Power supply is obviously running. The LCD is on and set to VGA input. But no VGA video.....

I tried setting the BIOS jumper to 1-2 (which is what was default) as well as 2-3. Neither made any difference.

I have also tried multiple LCD monitors as well as multiple VGA cables. No difference whatsoever.

Am I missing something here? I don't see anything in the manual about VGA not being enabled by default.

If anyone can help I would really appreciate it...
Anonymous
a b V Motherboard
January 27, 2010 2:37:08 PM

Hi from spain, i had the same problem some weeks ago, you can made a recovery bios form usb, only nedd the .BIO files and one usb stick with fat, take out the bios jumper(recovery mode) and plugin the usb and start the computer, wait 10 minutes and restart, in my D945GCLF2 after this y have vga and s-video signal.

Sorry for my english.

Bye
m
0
l
Anonymous
a b V Motherboard
January 27, 2010 2:56:41 PM

Sorry again, before restart take out usb and plugin the jumper un normal mode(2-3)

Bye
m
0
l
Related resources
January 27, 2010 3:48:58 PM

Thanks for the tip. I sent the board back to NewEgg to get another one. Hopefully it won't have the same stupid problem.
m
0
l
Anonymous
a b V Motherboard
January 28, 2010 9:45:34 AM

Ok.
Bye
m
0
l
!