Sign in with
Sign up | Sign in
Your question

Computer won't recognize router unless I unplug/replug the router

Last response: in Components
Share
October 25, 2009 3:32:49 AM

I have been having a WEIRD problem on the older one of my two computers for the past few months. Most of the time, when I turn on my computer, there is NO Internet connection unless I unplug and replug the router. (This is a desktop computer directly connected to the router with a cable.)

If I go to Network Connections on my control panel right after I boot up, my Local Area Connection (Ethernet card) will say "connected", but the actual Internet Gateway will not even be listed at all. The unplug/replug will make it appear and connect, then no problems for several hours.

Before you say this is a router problem, I replaced the router about a month ago to upgrade to an N router, and the problem happened with both the old and new routers. Never had the problem for 2 or 3 years with the original router, then one day it just randomly started.

I also replaced the Ethernet card on this computer with a new one just in case that was the problem. Nope; same thing still happens.

As a final irony, my second computer (a newer one running a quad core) is plugged into the same router and never loses Internet connectivity ever. Neither do my Xbox, PS3, Wii, Tivo, wireless Skype phone or anty of the other half-dozen wireless devices in my house.
October 25, 2009 3:55:09 AM

Well you have eliminated any hardware problems so the problem must be a software one. A clean reinstall of the operating system will probably fix the problem, but you could try and looking at the device properties in device manager for the network card and check that the “allow the computer to turn off this device to save power“ box is not ticked.
m
0
l
October 25, 2009 5:45:26 AM

pjmelect said:
Well you have eliminated any hardware problems so the problem must be a software one. A clean reinstall of the operating system will probably fix the problem, but you could try and looking at the device properties in device manager for the network card and check that the “allow the computer to turn off this device to save power“ box is not ticked.


Ugggggghhh.... I really do not want to reinstall Windows if I can help it -- probably like most people that have a 5-year-old computer, I know it would make all my problems go away, but I have so much stuff that I don't want to lose, that doing that is a last last last last resort.

However, I am 100% sure that the "allow the computer to turn off this device to save power" option IS checked. When I installed the new ethernet card, a menu box came up and that was what it was set to by default, and the box was checked. Stupidly, I didn't think it would affect anything, so I didn't change it.

I will go try changing that option and see if it helps.

Thanks --- hopefully!
m
0
l
October 25, 2009 3:44:22 PM

update: Nope, that didn't fix the problem. Internet Gateway still is not even listed at startup. :pfff: 
m
0
l
Related resources
!