Sign in with
Sign up | Sign in
Your question

Monitor changes "whiteness" depending what is showing on the screen

Last response: in Graphics & Displays
Share
August 16, 2009 8:34:08 PM

I have a very strange issue with a client's machine. It is a Gateway e4000 (yes, it's an old machine) with an Intel 82845G/GL/GE/PE/GV onboard integrated graphics controller. It is connected to my main monitor via a generic KVM which has (to date) given me no video problems.

When I have the desktop visible, the screen is rather rich in colour. When I bring up something white (like Windows Explorer or Notepad) that is maximized, the screen changes shade so that the application (and the entire screen, including the start button and the blue status bar) appears to have a "dirty" or dishwater grey shade. Minimizing the app causes the screen to return to its rich colour pallette.

This is a visible, very noticeable, non-instantaneous change that takes about 2-3 seconds to implement *after* a large white area appears on or vanishes from the screen. It appears to be something that the video card is doing, on purpose, in order to make the maximized program look "less brightly white". Problem is, I have never come across something like this before, and have no clue whatsoever as to how to turn it off.

This change only occurs *after* there is a maximization/minimization of a program's window. This "greying" of the screen is specifically with large white backgrounds, and appears to be linked to how much white is appearing on the screen. Dialogue windows which have a grey background or which cannot be maximized don't induce such a significant "auto-greying" of the screen.

I can only guess that the programmers thought it might be "nice" to prevent large white areas from blinding the user, but my client works in a bright area to begin with and this "auto-grey" feature is just pissing him (and me) off. If he maximizes Word or Windows Explorer, he can barely make out the text at times (depending on how bright the room is).

PS, the machine does not have an AGP slot, and it pre-dates PCIe. We have no choice but to work with the graphics card built into it. The client is NOT open to purchasing another computer just to fix a software issue.

All drivers are up to date, fresh install of XP SP3, but Microsoft Update does provide a "driver update" which is incorrect, and reduces the screen to 640x480 at 8-bit colour.

Clues? Suggestions? How does someone turn this (rather annoying) feature off?
a b U Graphics card
a b C Monitor
August 20, 2009 3:43:07 PM

Update the graphics driver.
Try optimizing the graphics software and degaussing the CRT (?).
Change the CRT color temperature.
If this does not work and it has a PCI slot, get a PCI video card.
a b U Graphics card
a b C Monitor
August 20, 2009 3:43:37 PM

Work on monitor contrast and brightness.
Related resources
August 20, 2009 10:51:47 PM

evongugg said:
Update the graphics driver.
Try optimizing the graphics software and degaussing the CRT (?).
Change the CRT color temperature.
If this does not work and it has a PCI slot, get a PCI video card.


It has the latest graphics driver, according to IBM (the motherboard *and* graphics chipset manufacturer).
The graphics software doesn't have anything that controls application-specific or content-specific changes in screen whiteness, hence my question.
Degaussing the CRT doesn't help. Neither does monitor colour, brightness or temperature. Tried that as one of my first operations, and none of the three other machines that connect to this monitor through the KVM have the same issue, so this issue is monitor-independent.
Changing the KVM port doesn't help, BTW (just to head you off at that particular issue), so it is KVM-independent, as well.
I don't have access to a PCI video card. The last one I saw was 5 years ago, haven't seen or heard of one since.

Eliminate monitor, eliminate KVM, only source of effect left is the computer itself and/or the software/drivers installed.
August 21, 2009 4:29:32 PM

That still doesn't change the fact that the customer doesn't want to spend money on hardware to fix what clearly appears to be a software issue.
!