Sign in with
Sign up | Sign in
Your question

Quad Q9550 running at 2,23GHz (bus speed 266MHz) - how to fix?

Last response: in CPUs
Share
October 25, 2009 3:25:42 PM

Hey all, I have a question about a new CPU I bought, an Intel Quad Core Q9550 (replacing my trusty old E6750).
For some reason, it's speed is only 2,23GHz: it says so during POST (Cores 4 @ 2,23GHz), as well as in Windows (CPU-Z and Sandra Lite). I noticed that the bus speed is only 266MHz (resulting in a Rated FSB of 1067MHz), so I think that might explain the slow CPU speed: 266MHz x 8,5 = 2,23GHz, whereas it should be 8,5 x 333MHz = 2,83GHz (Rated FSB 1333MHz).
All settings in the BIOS are defaulted (Auto), except the boot order and two power saving settings (SpeedStep and C1E), which are disabled). I've tried playing with manual settings (FSB Frequency, DDR speed, stuff like that), but so far to no avail, so everything's back to auto for now.

My question is what I need to do to have my CPU/bus speed operating at normal speeds? I'm not interested in overclocking my system (at least not for the time being - first want everything to run the way it should be) btw., so all I need is some tips on how to fix this problem in order to get everything running at stock speeds.


System specs:
- Asus P5K motherboard P35 chipset (BIOS version 1201; is most recent)
- Intel Q9550 (stock cooler)
- 6GB RAM DDR2 (2GB kit OCZ Platinum XTC + 4GB kit OCZ Platinum XTC)
- EVGA Geforce GTX260 SC 216 55nm.
- Seagate Barracuda HDD 320GB S-ATA
- Seagate Barracuda HDD 160GB IDE
- Chieftec 560 Watt PSU
- Cooler Master Centurion 5


CPU-Z screenshot 1:


CPU-Z screenshot 2:


CPU-Z screenshot 3:


Sandra Lite screenshot:



If more info/screenshots are needed, just let me know.
Thanks in advance!
Related resources
Can't find your answer ? Ask !
October 25, 2009 5:49:39 PM

Thanks, guys!

I've had a look at the BIOS settings, and tried fiddling with them a bit, but no matter what I do, the bus speed stays at 266MHz (and the Memory speed at 320MHz, I found out). The FSB/DRAM ratio is 5/6 (266/320), which should be the right value also for the desired speeds (FSB 333MHz and DDR 400Mhz = 5/6).
Somehow whatever I try, it just doesn't make a difference: I've tried setting the values in the BIOS manually, but even when I change FSB to 333 and RAM Freq. to DDR800 (basically the same values it should use when on Auto), according to CPU-Z and Sandra Lite the values in Windows are still FSB 266MHz (resulting in a CPU speed of 8,5x266 = 2,23GHz) and RAM Freq. 320MHz :??: 

Am I overlooking something here? Could it be a hardware defect? Or what else could be the reason why my CPU and memory are running slower than they should be?
a b à CPUs
October 25, 2009 5:59:56 PM

If the BIOS settings are not being saved when you hit f10 to exit the BIOS screen I would be tempted to re flash it.
a b à CPUs
October 25, 2009 7:22:53 PM

Speedstep being enabled in BIOS is what is causing the CPU to auto lower the multiplier. Disable it to stop the auto downclocking of CPU.
a b à CPUs
October 25, 2009 7:31:32 PM

I think Mousemonkey has the answer. The BIOS needs to be updated to a version that supports the processor. What is happening (CPU runs but downclocked) is typical to what happens when the BIOS does not support the CPU. I missed where Speedstep was disabled earlier.

EDIT: 1201 should support the Q9550, but not the recently release 'low power' edition f the Q9550. Check the CPU support list.
a b à CPUs
October 25, 2009 7:31:47 PM

Edited because Badge posted whilst I was typing.
a b à CPUs
October 25, 2009 7:34:23 PM

It is possible OP has the 'low power' edition of the Q9550 and that processor is not supported. The 'normal' Q9550 should be supported. I will check his MB support page.
a b à CPUs
October 25, 2009 7:43:36 PM

These links rarely work propwerly, but his P5K CPU support list show support for EO stepping with the 1201 BIOS. I wonder if OP just dropped the Q9550 in and was using a dual core Prior to upgrading in this manner. Check device manager under CPU and see if the Q9550 is display correctly. I had a similiar problem droping in a Q9450 in place of am e8400. The quad was not recognized properly in device manager. I reinstalled the OS to get everything straightened out with the upgrade from dual to quad core. ASUS BIOS thing.

http://support.asus.com/cpusupport/cpusupport.aspx?SLan...
a b à CPUs
October 25, 2009 7:49:08 PM

Mousemonkey said:
Edited because Badge posted whilst I was typing.


I should have read the Original Post more carefully, sorry for jumping in butt first. I know if the BIOS does not fully support a CPU, this is typical behavior of the CPU. If it were me (and it's not), I would try a BIOS flash. If that did not work, I would try reinstalling the OS.
a b à CPUs
October 25, 2009 8:03:55 PM

badge said:
I should have read the Original Post more carefully, sorry for jumping in butt first.

No worries mate, I've done worse, much worse. [:mousemonkey] :lol: 
October 25, 2009 8:16:34 PM

According to this review there are 3 versions of the Q9550: a C1 stepping with 95W TDP, an E0 stepping with 95W TDP, and a E0 stepping with 65W TDP (also known as Q9550S).
I have checked the serial number on the box, and it's sSpec is SLB8V, meaning my CPU is an E0 stepping with a TDP of 95W, so probably not the 'low energy' you guys mentioned. Correct me if I'm wrong, though.

On the Asus website I found out that the Q9550 E0 I have is supported from BIOS version 1103 upwards. But before replacing the CPU, I already too care of the BIOS, and upgraded it to version 1201, which is the most recent version available on the Asus website (and one version later than than the minimum required version for my CPU).
So should I still reflash it with the same BIOS version? Or perhaps try one version lower (1103)?

I tried upping the FSB in the BIOS manually (tried 333MHz, as well as 400MHz, just to see what happened), but after rebooting, the POST still mentioned 4 cores @ 2,23GHz. After entering the BIOS, the speed was also still 2,23GHz, even though the FSB value was still the same value I set manually. In Windows however, CPU-Z and Sandra Lite still claim it's running at 266MHz >_<
Also: SpeedStep and C1E are already disabled in the BIOS, but it makes no difference. Obviously, when enabled, the multiplier is lowered to 6 when the CPU is not stressed, but the FSB remains at 266MHz, regardless of whether these two values are enabled or disabled.


btw: thanks again for your help so far, guys - I really appreciate it!
a b à CPUs
October 25, 2009 8:32:47 PM

I assume you've tried resetting the CMOS?
a b à CPUs
October 25, 2009 8:37:21 PM

You are doing everything right. MB/BIOS (possibly OS) causing the problem. Interesting you were running BIOS version 1103, but before installing the Q9550 you updated to BIOS 1201 before trying 1103. So, perhaps try 1103 now. Which CPU were you using successfully with BIOS 1103?

I have been reading through the ASUS forms regarding the P5K P35 supporting the Q9550 45nm. There are various problems discussed, but I have not found any which apply directly to your problem of the downclocking.

The 266MHz. FSB is default for a 65nm CPU. I don't know. I have the same CPU as you on an ASUS X38. I originally had an e8400 and dropped in a Q9450. There were problems. The Q9450 was not correctly recognized in Device Manager. No problem with the 333MHz. FSB, but I had to reinstall the OS to get the Q9450 recognized correctly in Wndows. May not apply to you. I think you're issue are BIOS/MB related. You could veify that by installing the Q9550 in another MB. Anyway, here is my Q9550 EO screenshot.



With Speedstep on. I OC medium hot and use speedstep.

a b à CPUs
October 25, 2009 8:38:29 PM

Mousemonkey said:
I assume you've tried resetting the CMOS?


+1 especially after flashing the BIOS before dropping in the Q9550.
a b à CPUs
October 25, 2009 9:06:13 PM

reload bios defaults. take a digital camera and take screenshots of bios after you change the settings.

number one problem is still user error.
(not saying it is in this case)
October 28, 2009 5:05:50 PM

Sorry about my late reply, guys - I've been quite busy the last few days, so I didn't have time to address my PC problem.

Anyways, I've tried downgrading the BIOS to 1103, I cleared the CMOS, played a bit more with the BIOS settings, but all to no avail. For some reason the FSB remains 'fixed' at 266MHz. Also, the DRAM speed is just 320MHz instead of 400MHz, which is the exact same percentage less than it should be.

btw: when I bought this mobo, it already had BIOS version 1201.
It's a long story, but it boils down to this: I already had a P5K board when I bought the new Q9550. I read that I had to update the BIOS, so before swapping the CPU I flashed it to version 1201, and then did a testrun with the old CPU. All went ok, so after that I went on to replace the CPU. And after that nothing went: I couldn't boot Windows or run Windows setup - the system just froze. So I brought my PC to the computer store where I bought the CPU (a good one with knowledgeable staff), and they checked all components. Turned out the mobo was busted. So they offered me to remove the old one, install the new one, and upgrade the BIOS to version 1201 (so basically all I had to do was to pick it up and plug it in back home).
When I came back home, I noticed the CPU speed was just 2,23GHz - couldn't find anything to fix that, so that's why I decided to post this thread here.


rand_79: what do you need? A pic of the POST message, or the screens of the BIOS itself (which would basically be a list of all settings set to Auto)?
a b à CPUs
October 29, 2009 10:49:16 AM

So, the old CPU (Which CPU is that?) runs fine in the P35 MB you have now. But when you install the Q9550, the CPU is downclocked and does not run correctly and BIOS cannot be configured manually to make the proper adjustments. Well, the MB (BIOS) is not suporting the Q9550 properly. Or the CPU has some 'fault' of which I have no idea. Is it possible to try the CPU in a different MB to see if the Q9550 is recognzed and performs correctly? If so, the MB has some issues, rather BIOS related or physical damage of some nature. Micro cracks within the structure of the board causing some form of current failure? Then, like rand-79 said, user error is a number one problem.
a b à CPUs
October 29, 2009 11:31:24 AM

Your CMOS battery is buggered. Replace it. Everything in your BIOS will be lost when you reboot unless you do.

Basically, the CMOS RAM stores settings for your BIOS, and uses a battery to keep those settings within the RAM. It is a much better process than using EEPROM (Electronically Erasable Programmable Read Only Memory), as EEPROM has a usage limit.

When the battery fails, you set the BIOS settings, but it CANT save them. You can replace your CMOS battery fairly easily, consult a guide to do so.
a b à CPUs
October 29, 2009 4:29:15 PM

deadjon said:
Your CMOS battery is buggered. Replace it. Everything in your BIOS will be lost when you reboot unless you do.

Basically, the CMOS RAM stores settings for your BIOS, and uses a battery to keep those settings within the RAM. It is a much better process than using EEPROM (Electronically Erasable Programmable Read Only Memory), as EEPROM has a usage limit.

When the battery fails, you set the BIOS settings, but it CANT save them. You can replace your CMOS battery fairly easily, consult a guide to do so.


OP's old CPU runs fine. BIOS works fine.
a b à CPUs
October 29, 2009 5:40:47 PM

Heh, it would appear I missed a key point.
Thats odd really. If the CPU had compatability issues with the mobo it simply wouldnt work.
The BIOS clearly doesnt need an update.
Its not the CPU, because its the system bus thats causing the problem here, not the processor.
If the System bus is running at 266Mhz, that would give it an effective bus speed of 1066Mhz, which is typical of 65nm Processors. But for a 45nm Processor to work, It would require a 333Mhz system bus.
Gah, I hate to say it but Badge may be right, User error.
October 29, 2009 5:43:36 PM

When my PC was at the store, they tested all components, and eventually singled out the mobo as the culprit (they tried another CPU of a different type, and it didn't work either), so the employee suspected that the most likely cause of death of my first mobo was due to micro cracks.

What I just remember is that on the first mobo (the one that died), the CPU speed was recognized correctly: the first BIOS version I tried was 1006 (at that time I thought it was the right version for all steppings, only later realizing that the E0 required version 1103 or up), and although the mobo didn't detect the exact CPU model (it just mentioned Core 2 Quad), it did display the right CPU speed. And if I recall correctly (at that time I mainly focused on the - much more urgent - problem that Windows itself nor Windows Setup would run), the newer BIOS versions I tried later also recognized the speed correctly, as well as the CPU model. But I guess I would have noticed if the POST would mention a different CPU speed...

Anyways, I've tried a few more things, like reinstalling the CPU, running all possible combinations of RAM strips - however, the problem stubbornly persists... >_<

The old CPU I used was a Core 2 Duo E6750, which also has an FSB of 333MHz. However, I haven't tried that one on my replacement mobo, so I'm about to do that. Maybe the mobo can run that CPU at FSB333, which could mean the Q9550 is faulty indeed (although, as said, it was recognized correctly on my old board, and it ran at the intended speed).

However, since the tests at the store didn't reveil any other faulty hardware components, I lean towards a faulty replacement mobo (sigh, does the pain ever go away :p  ). I'll try the old CPU now and go back to the store that gave me the replacement mobo if that yields anything interesting. I'll keep you guys posted.
a b à CPUs
October 29, 2009 5:51:40 PM

Was the replacement MB a new retail MB? This is the MB you have now. I suspect not. Yeah, if there is any way you could get a 'known working' or 'different' or 'new' MB that supports the Q9550 and test it yourself, that would confirm the MB you have is defective. I have received a lot of defective MB's as RMA replacements from the MB distributors over the years.

EDIT. I want to mention that P35 MBs can be purchased for like $19 online from company's who 'specialize' in selling refurbished junk.
October 29, 2009 7:07:27 PM

I've tried my old E6750, and it turns out it had the same problem: instead of 2,67GHz at FSB333, it only ran at 2,13GHz at 266FSB - so I think the problem has been solved, or at least pinpointed - now I need to get my money back and find me a decent, and most importantly, a brandnew replacement mobo. I suspect it was quote-unquote new mobo indeed, so I'm going to demand a refund (I'm not going to buy a new board there as well).

Do you have any suggestions for a replacement board? I'm not interested in an ultrafast, hardcore overclockers' board with gazzilions of settings and tuning options, but rather a decent middle-of-the-road model. Oh, and preferably not one with a P35 chipset, nor one by Asus (unless their newer models have a better reputation that their P5K series). Because to be honest, I'm kinda done with them for now, after seeing two die on me in quick succession :ange: 


Oh, and thank you (and the others that took time to reply) for all your help and suggestions - I really appreciate it!
a b à CPUs
October 29, 2009 8:01:34 PM

Something with a P45 chipset from Gigabyte or MSI perhaps?
!