Sign-in / Sign-up
Your question
Solved

Asus 4870 1GB Dark Knight Performance

Tags:
  • Radeon
  • Asus
  • Performance
  • Games
  • Graphics
Last response: in Graphics Cards
August 18, 2009 7:45:45 PM

Good morning/afternoon/evening,

Since installing my 4870, the performance when playing battle for middle-earth 2 rise of the witch king hasn't improved much. If I use ultra high settings @ 1280x960 (no idea if this includes aa or af) the game lags when there is a large war going on (100+ characters) on the screen all at once. Does anyone know the difference between the settings in this game?

I was expecting better performance over my x1950 pro 256mb card. I do admit, bfme2 is a dx9 only game. When I play far cry 2 in dx10 mode on high settings at the same resolution, it looks and plays smooth, though I have not tried anything higher in that game yet. Am I to expect these kind of results from games that are 2-3 yrs old and dx9 only?

-- MaSoP

More about : asus 4870 1gb dark knight performance

Best solution

August 18, 2009 8:30:19 PM

that seems weird. i dont know much but it could be driver issues, a defective card or your cpu is holding you back since rts are more cpu intensive.
Share
August 18, 2009 8:38:09 PM

CrispyMango said:
that seems weird. i dont know much but it could be driver issues, a defective card or your cpu is holding you back since rts are more cpu intensive.


Well, I've got an Athlon X2 5600+ (65W) Dual Core in my system. I've considered that as a possibility. I've got more troubleshooting to do. The drivers in use are the 9.8 catalyst under Windows 7 and DirectX 11. I am going to try pushing Far Cry 2 to higher settings to see at which point that game lags. I'm limited to 1440x900 due to having a 19" samsung lcd.

-- MaSoP
m
0
l
August 25, 2009 12:56:25 AM

I put Far Cry 2 at highest settings and it looks sweet. i even started a fire and got in a fire fight in fields with trees in the foreground and it ran smooth at 1440x900. I'm thinking it is either a cpu bottleneck issue with games that more heavily rely on the cpu or it is a dx9 vs dx10 performance issue. I topped off the settings to high on all settings in nfs undercover and that game looks and runs smooth as well. it seems this issue will go away in time, as dx10 games replace dx9. I'm lastly going to load crysis to see how that runs as well as gtaiv, both cpu and gpu heavy games. so far so good. i still have a crackling sound issue when playing games, though minimal. likely a mb issue. i'm considering the matter closed. thanks. :-)

-- MaSoP
m
0
l