USB HD Disconnects During Transfer

Hi,

I have a PC running Gentoo, and I am trying to copy some files through my external USB hard drive. The drive mounts without issue, but after a minute or so of copying files to the PC, the drive disconnects. The only way to "see" the hard drive again is to connect the USB drive to a different USB port, but even then, the drive fails around the same time during the second copy attempt.

I have tried using two different brands of USB hard drives with the same data on each, and I have tried copying to two different PCs with identical software and hardware. All of them fail. Could this be an issue with the OS? Possibly a driver error?

Let me know if you need more information. I appreciate the help!

Sincerely,
Brian
1 answer Last reply
More about disconnects transfer
  1. Weird, my first thought was that the drive was overheating and giving errors like I used to see on an external hdd with no cooling - "delayed write failed". Second thought - is this Gentoo related or hdd related?
Ask a new question

Read More

Hard Drives USB Storage