Sign in with
Sign up | Sign in
Your question
Solved

GA-MA785GPMT Bios won't recognise SATA- tried everything, help!

Last response: in Motherboards
Share
January 23, 2010 2:08:45 AM

Motherboard: GA-MA785GPMT-UD2H (rev. 1.0) - [http://www.gigabyte.com.tw/Support/Motherboard/BIOS_Mod...]
Drives: 3.5 CAVIAR GP, 1.5TB, INTELIPOWER, 32MB, SATA II, 3YRS (WD15EADS) - [http://www.wdc.com/en/products/products.asp?driveid=575]

- I've upgraded the bios (flashed it) to the latest available version
- I've swapped out the PSU, tried different power connectors from the PSU
- I've tried placing it in Native IDE mode, AHCI, RAID - but Bios won't detect the drives regardless of mode. - Question on this, surely i don't need drivers for the BIOS to read drives - only when I want to install an OS correct?
- I've tried the drive in another machine - works fine and it's formatted correctly. I've tried another WD 1 TB drive, same model line in this machine, with the same results - no detect.
- The drives are spinning up. I've tried all the SATA connector plugs on the motherboard, no difference.
- I'm reasonably certain my bios setting are correct.



I'm at a loss. Unless it's some bios setting i've missed, i don't know what more I can do. Everything else is functioning on the motherboard, can it be possible that the entire SATA chipset and plugs on the mobo is dead? I'm not sure if there is much point in life anymore.
January 23, 2010 4:23:11 AM

Additionally I've taken the motherboard out of the case, plugged everything in (in case there was a short or a riser touching something etc)....same thing
January 23, 2010 6:59:06 AM

So I guess my question is:

Do I need to install some kind of SATA driver from Gigabyte during the initial Windows 7 install...in order for the BIOS to detect? I thought BIOS and an OS were entirely seperate with respect to this.

I have tried to load various drivers at the which volume do you want to install on stage, (I'm installing from a USB drive), and at no stage has it ever displayed either hard drive partition (just my USB drive). They are both formatted NTFS

I'm struggling to believe that the SATA ports/chip on the motherboard could be dead whilst everything else still works....help!
Related resources
January 23, 2010 5:57:08 PM

Here try this, connect the HD to the board (sata) and connect power to the HD. Go into bios and set the SATA ports to IDE. save the bios settings and restart the computer. Then go into bios again and see if you can see the HD under "Standard CMOS Features".

The thing is, The bios detect page does not refresh itself, until after you restart, If you set the SATA ports to AHCI or RAID they will not detect at all. Only setting it to IDE will it "maybe" appear under "Standard CMOS Features".

If that doesn't work, let me know, I have a few other tricks up my sleeve to see if the board is FUBAR.
January 23, 2010 5:58:41 PM

Oh for your question, installing windows 7, both IDE and AHCI should not require drivers, only raid might. I don't remember off hand if Win 7 ships with RAID drivers or not.
January 23, 2010 11:03:11 PM

Hi weilin,

Thanks alot for your response mate.

I've powered down, replugged drives to board and power. Switched on. Set Sata ports to native IDE mode. Restarted, and checked Standard CMOS Features - all display as None. I restarted a few extra times for good measure (not necessary but did it anyway) but still - None.









January 23, 2010 11:59:35 PM

hmmm. try this, keep drive plugged in and set bios to RAID. Restart, the board should go through normal post, followed by a raid post. you should recognize the raid post as it gives you a combination of keys to enter raid setup. its like "Press CTRL + i to enter RAID setup" or something. Anyways, get in there, and poke around and see if you can see your drive. If that doesn't work, get back to me again.
January 24, 2010 1:06:41 AM

Yep, cool.

I've tried this previously, and giving it a crack this time produced the same result. It's actually interesting, probably should have mentioned it in my first post....

So when you load the RAID setup - it displays the menu with the options .

1. View Drive Assignments
2. Define LD
3. Delete LD
4. Controller Configuration

Now the menu doesn't respond to an input of 1, 2, or 3 on the keyboard. Only to 4 - which displays AHCI HBA MMIO Base Address FEO2F000 - which i'm assuming is the base address of the AHCI Rom or something.

There are no other options, and nothing else I can press.

This guy appears to have the same issue (different motherboard though) [http://www.tomshardware.com/forum/254650-32-raid-proble...]
January 24, 2010 4:53:33 AM

While i'm not entirely sure if you can enter raid setup with only 1 HD for an AMD machine, I am under the impression that you can just so you can view devices. (Someone please correct me if i'm wrong)

That just leaves me to believe that some piece of hardware is dead... Do you have a spare HD you can test your questionable board with? or another computer you can plug your questionable HD into and see if it gets detected? Idealy you would do both.
January 24, 2010 6:54:57 AM

I've got 2 drives plugged in at the moment
a 1.5 tb WD
and a 1 tb WD

I know both of them work, as i've tried them both another machine

Best solution

January 24, 2010 2:48:27 PM
Share

Given that information, It may be time to set up a RMA procedure with Gigabyte. Go contact them (Their support is actually rather good, they respond usually within 24 hours) and see what they say.
January 25, 2010 12:23:06 AM

Thanks,

I had suspected this from the beginning, I just found it so hard to believe that a motherboard would arrive with the entire SATA module dead....especially considering I recieved a DOA RAM stick in the same order...what are the chances of that - let alone a mobo too.

It got me thinking that perhaps there is something else going - power surge etc, but there isn't any issue the the psu - it's a known brand and good product, and I doubt there would be any issue with power fluctuations causing damange in my abode. Case is also fine...pure chance I guess.


If you, or anyone else think of anything else to try in the meantime (whilst i go through the RMA), please let me know.
February 8, 2010 11:08:34 PM

Just to tag on this threat, I have a GA-MA785GPMT-UD2H and I was able to get my Seagate 500Gb drive running (SATA_0) and even had my WD10EARS (SATA_2) working, for a few days and now my system seems to have "lost" the drive. Even plugging it into SATA_3 - 6 doesn't work, and if I do get the drive to work, I eventually "lose" it and windows just ignors it because it's not an OS drive.

Anyways, if there's any new information out there I would like to hear it. Check my thread: Disappearing WD10EARS w/ GA-M785GPMT-UD2H

Good luck with the RMA, I may soon join you.

-jt
a b V Motherboard
February 17, 2010 1:05:53 AM

Best answer selected by r_manic.
!