Sign in with
Sign up | Sign in
Your question
Solved

With GA-MA770T-UD3P, 150 GB WD Raptor can't be made bootable drive

Last response: in Motherboards
Share
January 23, 2010 10:24:35 AM

Hello, I'd like to ask for help with this problem I'm having:

I Bought a new Gigabyte GA-MA770T-UD3P Motherboard and a Western Digital Raptor SATA 150 GB WD1500ADFD. I already had a Seagate Barracuda ST3250823A 250GB ATA100 drive, and a Seagate Barracuda ST3200823A 200GB ATA100 drive, which I wanted to use for data storage along withn the Raptor. The Power supply is a CoolMax AP-450X

The problem is that, when I installed Windows XP SP3 from the CD drive (a TSSTcorp CDDVDW SH-S203B), it installed onto the WD Raptor 150GB alright, but the drive showed up as "Drive E" in Windows, with the 200GB drive as "Drive C"

The system would not boot to Windows without the install CD in the drive, it just hung after the "boot from CD....." option, so I tried to re-install, but the Raptor won't boot at all now, the system just stops after "boot from CD....." The Raptor is always recognized by the BIOS, no problem there...

I've tried so many things to get the system to accept the Raptor as the bootabe C drive, but nothing changes the result.

This Raptor works fine as long as the OS is installed on any other IDE drive (I'm using the machine right now), but it just will not be set as the boot drive under any combination of work-arounds I can come up with. I'm starting to wonder if I've got a bad Raptor drive or motherboard.

I've tried re-installing the OS with only the Raptor connected, installing the SATA RAID drivers during install via "F6" key, re-ordering the drive boot priority in BIOS, pressing "F12" during boot to manually load the Raptor as boot volume, plugging the Raptor's SATA connector into different SATA ports on the MB, changing the power plugs between drives (including switching between the SATA power plug and the old standard plugs), switching out the CD drive for another older one for the install, re-installing the Northbridge/Southbridge drivers from the Motherboard driver CD, plus everything else I could think of...

Can anyone here think of what might be the problem? -- THX

Best solution

a c 177 V Motherboard
January 23, 2010 1:22:12 PM

Sounds to me like you have a 'broken' MBR (master boot record)
http://en.wikipedia.org/wiki/Master_boot_record
These may help:
http://www.tech-recipes.com/rx/483/xp_repair_fix_master...
http://support.microsoft.com/default.aspx/kb/69013

I use a muti-boot utility, BootIt_NG, from Terabyte:
http://www.terabyteunlimited.com/bootit-next-generation...
that allows you to rewrite MBRs on a 'per-boot' basis, and it's very powerful, but I have never found a cure for the 'drive letter other than C' problem when installing Xp to any other place than the first physical drive - so I've wound up simply always installing it there... I boot nine OSs (and am considering adding Leopard) off two RAID0 pair of Velociraptors, and this is a problem for no other OS - Vista and Seven can assign 'C' wherever I want, but Xp - never!


Share
January 25, 2010 7:13:39 AM

bilbat, Thanks so much for taking the time to answer, I've been building my own systems for over ten years, and this one had me stumped. Both of your suggestions were right on target. I'll describe what steps I took in case anyone else might find it helpful:

1. Removed all other hard drives except for 150 Gig Raptor.

2. Performed low level format on the 150 Gig Raptor using Windows XP install disk. A low-level format must re-write the master boot record, as the stopping at "boot from CD....." did not return.

3. XP went ahead and installed OK (automatically, I didn't catch it) but wouldn't accept the Raptor as primary boot volume if any other HDD was added (a bug in XP not installing anywhere but on the first physical drive, as you mentioned). This GA-MA770T-UD3P Motherboard's BIOS is set up to start counting drives starting with IDE, then moving to SATA devices.

3. Installed Windows 7, overwriting XP install.

4. Added the additional HDDs back in--system now works perfect.

5. Went on Tomshardware forum, thanked "bilbat" for very helpful advice!
m
0
l
Related resources
January 26, 2010 3:22:47 AM

God I hate it when I read an entire thread so that I can give some advice and have it turn out that it's totally resolved but hasn't been marked as solved. Give best answer. Give him his reward and stop wasting everyone else's time.
m
0
l
January 26, 2010 4:21:24 AM

Best answer selected by temujinn.
m
0
l
!