Help with my memtest error please

Last night, my newly built comp started to run really slowly. It runs but u can see how slow the window is dragged around. And then I got a BSOD saying PFN_LIST_CORRUPT. Poking around google gets me to the belief of memory error. So I ran memtest and this is what Iget
Test Pass Failing Address Good Bad Err-Bits Count Chan
3 8 00000100014 7f7f7f7f 7f787f7f 00070000 1

3 10 00000100014 fdfdfdfd fdf8fdfd 00050000 1

The second test 3 is on the second time looping through the tests.

Specs:

i7-920
Asus p7x58d Premium (5069)
Mushkin Enhanced Redline DDR3 6 GB
HD 4850 512Mb

Please help me I don't really wanna go through the hassle of RMA but these RAMs were like 250 buks
Thank you
17 answers Last reply
More about help memtest error please
  1. If you haven't done so, go into the bios and check your ram settings. The voltage or timings may need adjusting manually. Check the ram label or newegg's manufacturer's link for the info.
  2. I've done that. It's running at XMP profile with the same setting posted on newegg. Bios is also up-to-date. I don't know why this is happening
  3. Now It's another problem..... RAMs are running on auto in BIOS and I'm getting PAGE_FAULT_IN_NONPAGED_AREA 000000050........ something 50. Seems to be indication of RAM problem. Can anyone help with this please
  4. Instead of using XMP or Auto, try setting the values yourself. If that doesn't work, let us know what fields you changed, and what values you set them to. Also, a link to your RAM will be helpful.
  5. Mushkin Enhanced Redline: http://www.newegg.com/Product/Product.aspx?Item=N82E16820226050
    I contacted the tech support and he told me to mannually set the stuff. I did but it didn't work
    AI Overclock Tuner: Manual
    DRAM Frequency: 1600
    UCLK Frequency: Auto
    QPI/DRAM voltage: 1.325V - 1.375V
    DRAM Bus Voltage: 1.60V - 1.65V

    Dram Timing Control
    DRAM CAS# Latency: 6
    DRAM RAS# to CAS# Delay: 7
    DRAM RAS# PRE Time: 6
    DRAM RAS# ACT Time: 18
    DRAM Timing Mode - 1N
    Leave the rest at auto

    It seems that if I run more than one stick of RAM, i'll get BSOD under intensive action such as gaming (mw2). I tried running single channel... no crash. Any double channel or above would crash no matter how I arrange it on the board. I can upload the minidump files if you want. BSOD includes:
    PAGE_FAULT_IN_NONPAGE_AREA
    IRQL_NOT_LESS_OR_EQUAL
    PFN_LIST_CORRUPT
    MEMORY_MANAGEMENT
    SYSTEM_SERVICE_EXCEPTION

    Thanks for your help
  6. Problem is, I don't know what to RMA. I did a clean windows install last night and ran memtest for 9 hours with no error
  7. Another option is that the memory's static read, aka tRD setting, is causing the problem. Most motherboards don't expose this outright. My Gigabyte allows this to be controlled through a setting called "Performance Enhance" in which you can pick Standard, Turbo, or Extreme.

    Based on some quick research I did of ASUS BIOSes you might have an option called "Transaction Booster". If so, try to disable it. Or set it to a higher number. You may have to enable DRAM Static Control (or Manual Control?) to see it. Or if you do have a field called DRAM Static Read Control, raise that number.
  8. TransactionBooster or DRAM Static Control are nowhere to be found in my BIOS. I've googled it to see if it's named differently but nothing came up. I don't see any field that has to do with tRD either. Do you have any other options
  9. What motherboard do you have?
  10. Asus P6x58D Premium. I just took out the CPU and put it back in there. Now I'm getting consistent BSOD of MEMORY_MANAGEMENT
  11. Do you have the memory installed in the correct slots? I know it's a dumb question, but it happens and it's easy to overlook. The slot closet to your CPU should be empty, the next one populated, the next one empty, the next one populated, the next one empty, and finally the last one populated.

    If that's done correctly, you've already set timings correctly, well you may have a bad stick. Test each one individually. Take out the RAM and put one stick in the second slot from the CPU. Run memtest86+ with just that one stick in place for a few hours. When done, pull out that stick and put one of the other two in its place. Run the same test. Finally, repeat with your last stick. If one of them is giving you errors, you have a bad stick.
  12. Before you run your tests, confirm that you have the latest BIOS. BIOS 0506 was released on 11-Jan-2010.

    Also make sure you are seating the RAM correctly, that they are firmly in place.
  13. Have done all you've said. Memories are installed in 2-4-6 . Ran Memtest with each stick for about an hour each. No error. Ran Memtest with all 3 of them again last night after a new install of Windows, no error for 9 hours.
  14. Ok. Had to ask because your first post mentioned memtest errors. It could be a voltage problem. But I don't know enough to advise here. I'll step back and let others chime in.
  15. Ok thank you. I did have memtest error before. But apparently it went away after my clean install of windows so I don't know. I heard it could be memory controller problem. Do you know anything about that one?
  16. Not enough to be sure. You could try a bump to your PLL or ICH Voltage. But it's a guess and I don't know what a small step up in those values would be.
  17. I haven't tried what you said but I might have pinpointed the problem. I disabled paging file and things ran flawlessly. I enabled it again and I get one of the BSOD's. My friend told me to try to up my paging file to 9 gb instead of the automatic 6gb so I did. And that gave me graphic card problem such as weird texture and crashing with weird colors on the screen. I dunno if it's the card now. I've ran furmark to test the stability and it's fine for a long time
Ask a new question

Read More

Memory Product