Ventrilo Mic Hiss with high quality Mic and X-Fi Titanium PCI-E

I have this headset. It works perfectly on other setups and is a very high quality headset.

Recently, I installed the X-fi Titanium PCI-E card. Everything sounds great and my mic works well in other programs and games, however, when talking in ventrilo there is a noticeable high pitch microphone hiss. The hiss goes away when I put my fist around the mic, but I can't exactly talk like that. Plus putting foam around the mic doesn't make it go away.

The headset works fine on other setups so it is not at fault. It's almost like there is a mic boost on, but there doesn't seem to be a mic boost feature in the Creative Console.

Windows 7 Home Premium 64-Bit

Intel Core I7 920 @ 3.4ghz


4870x2 GPU

Asus P6T Deluxe MOBO

Creative Sound Blast X-Fi Titanium PCI-E

Any ideas. I've tried everything. I used to exact same ventrilo settings on another computer and have had no problems, so it is not ventrilo and is not the mic. It has to be something wrong with the sound card.

2 answers Last reply
More about ventrilo hiss high quality titanium
  1. I would right click on your speaker in windows.
    Then click on recording devices, click on your mic/ headset mic, then into custon tab see if AGC is ticked, if so untick it.

    The other thing to check if its not electro magnetic noise.
    Eg. Lcd screen / transformer./ Invertor.
  2. Yea before coming back here I turned off my T.V. on a whim and that was it. Was just interference from it.

    Time to get a new T.V.

Ask a new question

Read More

Sound Cards Gaming Headsets PCI Express Components