Sign in with
Sign up | Sign in
Your question

File extensions deleted.

Last response: in Windows XP
Share
January 10, 2012 6:30:08 PM

Running XP sp 2. tried to rename my camcorder video files from MOD and MOI to MPEG using a video converter program but now all the file extensions have been deleted. How do I get them back? I have tried renaming them in explorer to what they were before but they wont open and ply. The converter program wont do anything either.
January 11, 2012 5:15:16 PM

kuhn said:
Running XP sp 2. tried to rename my camcorder video files from MOD and MOI to MPEG using a video converter program but now all the file extensions have been deleted. How do I get them back? I have tried renaming them in explorer to what they were before but they wont open and ply. The converter program wont do anything either.


Right-click on "My Computer" and choose "Explore" from the menu. This will open Windows Explorer.

Locate the file with the extension that has been deleted or renamed. Note the location of that file, i.e. "C:\My Documents."

Click on the "Start" button and choose "Run" from the menu. Type "CMD" in the box and click "OK." This will open up a DOS window.

Type ".." and hit the "Enter" key. Continue doing this until you see a "C:" in front of the cursor. Then type the name of the directory containing your file, i.e. "C:\My Documents" and hit enter.

Type "Rename filename filename.doc", or whichever extension you need. If you had a Power Point presentation named slideshow you would type "rename slideshow slideshow.ppt" to restore the lost .ppt extension.
January 12, 2012 8:08:16 AM

Thanks for the reply.

I'm no computer wiz so bare with me.

I understand everything up to when you say Type ".." in the DOS window.
Do I type ".." or just ..?

I have tried both and was still going ten minutes later and there was never a C: in front of the cursor.

Also I have 46 files all saved on my D drive that I need to get the extensions back for.

How do I continue considering your advice.
Related resources
January 12, 2012 8:47:54 AM

kuhn said:
Thanks for the reply.

I'm no computer wiz so bare with me.

I understand everything up to when you say Type ".." in the DOS window.
Do I type ".." or just ..?

I have tried both and was still going ten minutes later and there was never a C: in front of the cursor.

Also I have 46 files all saved on my D drive that I need to get the extensions back for.

How do I continue considering your advice.

Ignore previous instructions. Try this. (ignore entering quotes)
Click on the "Start" button and choose "Run" from the menu. Type "CMD" in the box and click "OK." This will open up a DOS window.

Type D: ( press enter or click ok) - Points to your D drive
type dir (your files should be listed unless they are in a folder on D)

If they are in a folder,
type cd \folder name (your folder name where objects are located)
type dir (your files should be listed)

For each file type ren filename filename.mpeg

Do one or two & make sure they are changed (do another "dir" command)

January 12, 2012 5:36:29 PM

kuhn said:
Running XP sp 2. tried to rename my camcorder video files from MOD and MOI to MPEG using a video converter program but now all the file extensions have been deleted. How do I get them back? I have tried renaming them in explorer to what they were before but they wont open and ply. The converter program wont do anything either.


The video converter program does not just rename the files, it "converts" them. Difference between putting on a cow outfit on a chicken to get milk and actually transforming the chicken into a cow. Just renaming a file won't make it an MPEG.

What exactly did you do to "rename" them in the converter program? How did you try to rename them in Windows after that? Are the file names and extensions showing up? Do you have "show extensions" on?
January 12, 2012 6:25:22 PM

Hang-the-9 has a point. If you don't have file extensions turned on, you won't see them. From a file explorer click on tools/folder options. Click the view tab. Scroll down until you see hide extensions of known file types. Uncheck it, then click ok.
!