Sign in with
Sign up | Sign in
Your question

Save Data on Raid 0+1

Last response: in Storage
Share
May 16, 2011 12:02:58 PM

Here is my problem:
I have a RAID 0+1 set up with four 500GB WD drives. This has been performing flawlessly since 08'. Recently one of the drives failed.
I was able to boot even with the degraded volume. But I did not act fast enough. Now I'm getting a BSOD upon startup. Now after the BSOD the machine dump out and restarts but this time the raid fails and no OS can be detected until I power down and restart. I have already replaced the bad drive in the raid volume. But now with the BSOD, the OS never get up to let the volume rebuild.

And No, no I don't have a good back up. Yes, it is very [fill in any adjective that means stupid] of me not to have a good back up.

That aside I'm trying to think of a scenario that would allow me to do a few things:

a) Get into the OS to let the raid volume rebuild.
b) Recover the data on the volume in order to
c) create separate backups of OS, programs and data.


So here is a scenario I have come up with:


Add new single drive.
Set new drive as boot in bios. Raid will be just a data drive.
Clean install of OS on new drive.

Once OS is up, let raid volume rebuild.
Create appropriate back ups.

Address BSOD (I suspect issues with AVG free)


Once Backups are taken care of:

Reset raid as boot.
Keep consistent restore points and back ups from that point on.

Best case scenario: Working machine with speedy raid, good backups and an extra OS drive in case of an emergency. Worst case scenario: I'll be kicking my self in the ass for losing 3 years of data.

Machine Specs:
Vista Ultimate x64
MSI 9800gx2
LSP 750w PSU
Intel Core2 Quad CPU Q9300 @ 2.50GHz
8GB RAM
1TB Raid 0+1 (four 500GB WD drives)
1 - 160GB WD Raptor scratch disk
standard dvd
1 Dell 2407WFP
1 Dell 2408WFP
All tucked nicely into a CoolerMaster 1000 with all five fans blowing.



Your thoughts are greatly appreciated.

More about : save data raid

May 16, 2011 4:02:37 PM

After POST test do you see the RAID controller prompt? Have you tried to rebuild the RAID within the controller? You will want to jump in the (looks like the BIOS) controllers config. You should have the option to rebuild the RAID in there, and this is all before you boot to the OS.

After you rebuild in the controller, you might be able to get into the OS... If not I would boot to an XP disk (OS that is installed), then choose the recovery console. In the recovery console I would run a chkdsk /r. This has worked for me many times in the past, but I have never tried a RAID 0+1...
m
0
l
May 17, 2011 1:21:00 PM

I forgot to mention that I was runnning Vista x64

I do get the controller message. But there is no option to rebiuld at that stage. Maybe I missed something. I will look agaian.

I have also already tried the chkdsk option (booting from original Vista disk)
m
0
l
Related resources
May 18, 2011 12:32:33 AM

Confirmed there is not option to rebuild in the controller. It says Volumes marked rebuild will be rebuilt in the OS.
m
0
l
May 30, 2011 1:50:19 PM

Thanks for the replys.
I decided to do a fresh install anyway. After 3.5 years of good performance, It was about time.
I was able to copy my data off the RAID with a copy of Acronis TrueImage I had laying around. I will get the OS and programs installed today (Memorial Monday) over a case of corona. Plus I added a N560GTX-TI Twin Frozr II. Fun!
m
0
l
!