Sign in with
Sign up | Sign in
Your question
Closed

No Full Screen using Windows 7 RC & Radeon 4870 in HDMI mode

Last response: in Graphics & Displays
Share
August 26, 2009 1:55:50 PM

Hi

I recently installed Windows 7 RC on my home PC to try it out. I have been using Windows Vista prior to this using an ATI Radeon 4870 on my recently purchased Acer H223H (23", 16X9 ratio, 1920*1080 - Full HD, 2ms, DVI, VGA, HDMI, Speakers) screen via HDMI with no problems.

Since I installed windows 7, I cannot get my screen to display full screen via HDMI, yet the resolution is set correctly. I fiddled with all the settings and even installed the lastest 9.8 Catalyst drivers with no luck.

I then tried connecting the screen via VGA & DVI instead of HDMI and it worked 100% correctly.

I did some searches on the net and the closest thing I could find wat the following relating to Catalyst Drivers:

" Known Issues Under the Windows 7 Operating System


Certain resolutions above 10 x 7 might not full screen for specific HDMI displays "

Fair enough, but this dates back to Catalyst version 9.3, or even possibly earlier versions. We currently have version 9.8, which is already 5 months newer!?!?

Has anyone had similar experiences like this???
a b $ Windows 7
August 27, 2009 6:48:07 PM

Spawn_eternal,

The Windows Hardware ecosystem is incredibly broad and offers a large selection tailored to very different needs. This is one of the things that makes Windows appealing to a variety of different users. To ensure that the user has a great experience with the devices that the user loves, we have been working closely with all our top partners including the top video card manufacturer. ATI and NVIDIA, for example, are both featured in our Ready.Set.7 campaign, where our top partners showcase their readiness and improvements with Windows 7. However, we cannot control the marketing, HW requirements, and life cycles of our vendor’s products. When a hardware partners decides not to support or chooses not to support some existing hardware on a new OS release, we can only acknowledge their business decision. To better understand the graphics changes in Windows 7 (including upgrade) please review the information available here: http://tinyurl.com/lt29jm

Also, Microsoft does have an official Windows 7 RC Support Forum located here http://tinyurl.com/9fhdl5 . It is supported by product specialists as well as engineers and support teams. You may want to check the threads there for additional support.

Jessica
Microsoft Windows Client Team
August 31, 2009 2:26:12 PM

Did you try the overscan / underscan settings in the catalyst control centre? I had a similar problem to begin with as well when I first started HDMI with my 4870x2, then discovered those settings in CCC and voila, fixed. HDMI was defaulted to underscan by 8%.
Related resources
September 2, 2009 2:27:57 PM

drachenyen said:
Did you try the overscan / underscan settings in the catalyst control centre? I had a similar problem to begin with as well when I first started HDMI with my 4870x2, then discovered those settings in CCC and voila, fixed. HDMI was defaulted to underscan by 8%.


Great, i'll give it a bash and report back to you tomorrow!!!
Anonymous
a b $ Windows 7
October 12, 2009 3:48:50 PM

Same story here. It was just a matter of removing underscan in Catalyst. Full screen here now.
October 13, 2009 6:54:32 AM

Yup, i forgot to get back to you, but yes, the under/overscan setting did the trick. Thanks guys.
Anonymous
a b $ Windows 7
October 29, 2009 3:05:06 AM

Where is the under/overscan setting located?
Anonymous
a b $ Windows 7
November 4, 2009 4:26:44 PM

Wow, I am so happy I found this thread. This fix worked for my I-INC monitor. Thanks guys.
November 9, 2009 3:24:54 PM

The under/over scan option is absent in Catalyst 9.10 64-bit - which version of CCC do I need?

Thanks.
November 29, 2009 4:32:11 PM

sshm said:
The under/over scan option is absent in Catalyst 9.10 64-bit - which version of CCC do I need?

Thanks.


thank you all so much for this thread. it fixed the problem, and i would have never found it myself.
sshm, i am using windows 7 64 bit and the latest catalyst driver, 9-11.
the option for underscan/overscan is there just not easy to find.
you need to choose "desktop and displays",
there in the bottom left you see a little monitor, right click it and select configure.
from there, you will find the hdmi settings and overscan/underscan.

good luck and thanks again for this forum and thread.
November 29, 2009 6:37:02 PM

Hi. I noticed this thread and wanted to ask you about how you can make the new settings stick? I have to change my resolution in order to get to the overscan section, and when I then revert to normal resolution my new setting is gone and I have to start all over again. I have to do this everytime I want the full screen. So, could anyone tell me how you can make your overscan settings permanent? Please...
Thanks in advance.
November 29, 2009 6:46:26 PM

I also had this problem when I first plugged my HD 4890 into my Asus X213H @ 1920x1080. For some reason it would remove the overscan when I set the monitor to operate at 59 Hz instead of 60, which worked until about a week later, at which point I looked around for a good two or three days (to no avail, unfortunately) and finally decided to mess with everything in CCC and found the overscan worked. This should really be in some FAQ somewhere that people can find, I know it annoyed the crap out of me and I thought the monitor was defective.
January 21, 2010 7:05:52 AM

I just got a new laptop, and all my games have this black border on the vertical edges.

I've read a lot on this as it seems to be a pretty pervasive problem. You would think Microsoft would be addressing this issue.

Anyhow, I read a lot about fixes for mine, which has an ATI Radeon 3200 in it. Unfortunately, my Catalyst Control Center does not appear to have the same selections others have. I have no under/over scaling, or any way to change any aspect ratio? What gives?

I at least finally got a little further after figuing out you need to right click on the little monitor under Desktops and Displays and go to Configure. But, there is nothing much from there. There is a toggle between Full Screen and Centered, but it is greyed out and unchangeable. That is about it.

I've read about all sorts of versions of this Control Center. What do I need to do...get a different version? Which one? I can't even tell which one I have. Under about it's got some godawful long Version #. 2009.0729.2227.38498

I also read elsewhere that this is how these games are supposed to look on Win 7, as stretched to fit, they don't look right. I beg to differ. Diablo 2 always fit my laptop and desktop screens under XP, and it's what I'm used to. With these borders, on this laptop, it looks downright weird, and everything looks too tall.

Sure hope someone can help fix this. I cannot believe this ATI driver is so unfriendly to change such a common problem.

January 30, 2010 2:44:28 PM

Thank you every one for solving my problem .....gracias
March 31, 2010 1:27:58 AM

Hey ozs your awesome. Thanks for the step by step. It really helped me. i was getting so frustrated. It even adjusted my clarity.
April 18, 2010 4:20:54 PM

Was having this same problem after latest driver update on my 5850. But now solved :) 
Many thanks!
Anonymous
a b $ Windows 7
July 10, 2010 1:06:54 PM

Same here - had the same problem and spen 3 hours on it before I got here. I remember fixing this problem with the old version of catalyst for my plasma tv - and it baffled me that I couldn't fix it again.

Thanks for pointing our how to get to those options. But once there they are sort-of confusing. There are 2 tabs that actually talk about underscan / overscan so I tried changing both but after I change one and then undid the change it wouldn't go back to the small screen again so I couldn't work out if the other tab would have done anything.

Bit of a mystery????
a b $ Windows 7
July 10, 2010 5:51:35 PM

This topic has been closed by Mousemonkey
!