Sign in with
Sign up | Sign in
Your question

Bios recognizes CDROM, but won't boot to it?

Last response: in Motherboards
Share
January 29, 2010 2:11:02 AM

Been a lurker for a long time, but am stumped enough to ask on this one:

I have a Gigabyte ga-ep35-ds3l (yeah, this is an older box now and that's a semi cheap mobo). The machine "works" just fine, but now won't boot to CDROM. I can't say when the problem started for certain since it may have been six months to a year since I last booted to CDROM on this box.

The DVD / CD burner is recognized in the bios screen. It's recognized on the initial load screen. Heck, it even says "booting to CDROM" for about a half a second before it starts up grub from the hard drive and continues booting. The CDROM doesn't even spin up.

The interesting thing (to me) is that it does this regardless of whether I have the hard drive in the boot order at all. I've found some snippets of conversation that suggest the boot order on these boards doesn't really work, but I don't recall having had problems with it before.

I've tried setting CDROM to all three boot order selectors, just CDROM to one and nothing to the rest, HDD as second, all the normal stuff. I even told the bios that my second HDD was the bootable one, which caused a boot error right after it said "Booting to CDROM".

The drive isn't broken, I can read from it just fine inside both linux and windows. It registers as a TSSTcorp CD/DVDW SH-S182M and it's a samsung writemaster.

The disks are also just fine. I've tried a windows boot disk, knoppix, ubuntu live cd, and even a mac boot disk ... nothing is recognized and they all (at least the first three) work on the computer sitting right next to this one.

I'm trying to swap out hard drives. Right now I've got two small sata drives in there and finally am upping to a 500Gb drive, but of course, that means re-installing the OS's, which means booting from CDROM.

I don't think it's pertinent, but it's got an E6600, 8800GT, and 4Gb in it (don't remember the make).

I'm holding off on attempting flashing it because I'd have to go find a stinking floppy drive that works still :) . Plus, I've no idea why it would have "changed" to not booting from CDROM and suspect this might still be something silly that /I've/ managed to do.

Any help would be greatly appreciated.
a b V Motherboard
January 29, 2010 2:47:53 AM

Is the DVD on the same controller as the HDD and is AHCI on? I have heard of some issues of running the DVD drive in AHCI mode (though it should still work, but perhaps worth a try).
January 29, 2010 2:58:26 AM

No, the DVD is on channel 4 (IIRC, this one is set up SATA 0-3, and I've got the HDD's on 0 and 2 as master), then IDE1 is 4. AHCI is turned off.

Though you did spark a memory ... it's quite possible that I've replaced the DVD player since I last booted to CDROM. I don't know why my older one might have booted and not this newer one, though, and I can't test the old one because it was replaced for dying.

I could try to find another CDROM and run it off that maybe, or even try a USBCDROM boot, but I've heard there's tons of trouble with that as well, and would much rather just get my own DVD player to work :) .
Related resources
January 29, 2010 10:38:26 PM

Well, that last idea is a bust. I have an external CDROM that I could try to boot to, but my OSX and Windows disks are both DVD's. Since I don't need to just reload linux on this box, guess I /have/ to get the internal DVD booting somehow.

But it's not just a CD/DVD problem for booting (aka: I tried to boot to a few linux CD's as well as these two DVD's).
a b V Motherboard
January 30, 2010 3:32:37 AM

At the first screen that comes up during boot, do you have any boot options listed there? On mine, F12 opens boot options (though I have not tried it, so it may be nothing more than a shortcut to the boot order).
January 30, 2010 4:25:33 AM

I have lots of problematic case with samsung dvd writemaster. I have piles of samsung drives since I routinely burn dvd - I have observed samsung drives won't sustained constant 'workout'. So I prefer liteon instead of samsung. In samsung sometimes I can write and read but I cannot boot and lots of times it spins to eternity. When I burn I won't go for maximum speed.
a b V Motherboard
January 30, 2010 1:09:05 PM

Nice, and I don't like Lite-on since I've gotten too many bad drives from them :lol: 

I guess this is to be expected for a $30 part.
January 31, 2010 1:56:53 AM

Well, I held off replying because I was testing two more DVDROMs. Neither works. Both can be read off of inside of windows or linux, but neither can be booted to.

At least the one feels (and sounds) like it's spinning up during boot, but even while that's happening (and while it's saying "Booting to CD"), within a second or two, the "Loading Grub" line comes in and starts grub up.

So no, it's almost /got/ to be something with the Bios.

Since the last message, I've even flashed to the latest bios. No new options have shown up and this problem hasn't gone away.

I'm stuck! Can't even install my new 500Gb HDD (other than as a third drive for storage).
February 6, 2010 11:33:22 PM

Damn. I have no idea what changed, but for some reason, the drive now recognizes everything and is booting fine.

Put it through the stress test I was planning on and now have a quad boot system up and running with zero glitches trying to get the dvd player to work.

I wish I could say which magic setting I changed, but I can't. Even went back and tried changing things back to where they were (I had the old bios settings saved) and no dice ... the drive still worked fine.

Just a bad week for that drive for whatever reason.

Thanks for the help all, and I wish I could end this topic more explicitly.

On a happy note, OSX, Ubuntu 9.1, Ubuntu 9.1, and Windows 7 are all playing nice on my PC now with all my old software re-installed.
a b V Motherboard
February 7, 2010 1:59:37 AM

:lol: 

Well, glad you got it sorted out. I have to keep telling myself these things aren't alive with a mind of their own, but they sure can seem moody at times.
Anonymous
a b V Motherboard
February 11, 2010 10:07:35 PM




Glad you got yours to work but I wonder how. I have the same issue. I installed a new MOBO and 500 gig HDD. Can not see the CD drive to install the OS. I even swapped the virgin HDD for a working HD running vista. Can not see that drive. I tried booting from a usb HDD and it looked like it might boot but only for 2 seconds. This is frustrating.
a b V Motherboard
February 12, 2010 2:35:14 AM

Does the CD Drive Open and close (to show it is at least partially working)?

Is the controller set to AHCI? Do you have two controllers so the CD drive can be on SATA IDE?

Newest MB BIOS and all?

Also, could you post the full specs?
May 24, 2012 8:46:23 PM

For what its worth, with a Gigabyte GA-MA790GPT-UD3H, I couldn't boot from the CD no matter what I tried.

The CD was set to AHCI. As soon as I changed it to IDE, it booted just fine.
!