Sign in with
Sign up | Sign in
Your question

Is my graphics card dead?

Last response: in Graphics & Displays
Share
August 29, 2009 3:31:55 AM

I've never ran into a problem as strange as this and I'm not sure how to classify it.

My computer is a Toshiba Satellite A305-S6916 with the following specifications:

Windows Vista 64-bit Home Premium
Intel Core 2 Duo T6400 @ 2.0 GHz
4.0 GB RAM
ATI Radeon HD3650 w/512 MB dedicated memory, factory specs (no overclocking)

There has been no previous problems with this computer and no overheating (estimating about 50 degrees Celsius under full load). The following games ran fine with good frame-rates: Battlefield Heroes, Burnout Paradise, Dead Space, Fallout 3, Far Cry 2, Grid, Morrowind, Oblivion, Prototype, and Spore. All of the sudden today none of the games worked. They all blackscreened and gave "Has Stopped Working" upon startup, or in the strange case of Grid (which loaded) the menu screen showed huge artifacting and random colors/planes/verticies where the menu would be but the music played. Fallout 3 loaded the menu but when I tried loading up a game it didn't load (just continued the loading animation for a long time without anything changing). Spore reports an ACCESS VIOLATION error.

First thing I tried were reboots (which didn't work), then a system restore, hoping that maybe it was a Vista update that messed everything up, but that didn't work either. I downloaded ATI tool, and perplexingly the fuzzy cube rendered fine and the fan kicked on like normal. Likewise the Catalyst Control Center was rendering the stock 3d animations fine. Aero works fine, no artifacts.

To test whether it was DirectX messing up, I tried a simple 3d demo (http://www.scene.org/file.php?file=/parties/2007/breakp...) which normally runs but that too crashed like the games. I ran dxdiag which reported no problems and saved the output file.

The computer is still under the 1 year warranty and is an option (though I'd be without a computer for a few weeks) but I'm not sure whether the problem is with the graphics card or the operating system. Right now I'm going to install the latest ATI drivers from Toshiba's website (which unfortunately aren't as good as from ATI's website but I dont want to f-up the ACPI fan capability like with my last laptop) What I find odd is that this problem happened and nothing stressful happened to the computer, it just popped up all of the sudden. Any help would be appreciated.

More about : graphics card dead

August 29, 2009 4:18:30 AM

If this were a desktop we'd worry about drivers, heat, power supply, and then finally gpu. You have theoretically "done" drivers and temps, though you might restore the *original* and then the *latest* graphics driver from *Toshiba* . . . and see if dust has somehow gummed up the airflow the little guy needs.

After that, its kinda beyond your screwdriver's reach - contact Toshiba and have them sort it out.
m
0
l
August 29, 2009 5:23:14 AM

Thanks for the reply Twoboxer. I just installed the new AMD drivers from Toshiba (replacing the default ones) and rebooted and now all the problems went away (mostly)! The only thing that is still messing up is the glitched Grid menu. How and why it worked is completely beyond me, but I have a suspicion that the particular combination of Vista/64-bit/ATI might have caused the strangeness that I was seeing (Vista causing the access violations and "Has Stopped Working" errors, and the non-functional 3d card on ATI's driver interfacing with the 64-bit Vista).

At least the graphics card is still good and I dont have to go through the hassle of factory restoring, reinstalling Windows (ugh), or sending in the computer (double ugh). Pfew. Hopefully something similar wont crop up in the future.

For anyone with this same laptop model and a comatose ATI card, I upgraded the video driver from the default driver to 8.611-090421a-080072C-Toshiba (http://cdgenp01.csd.toshiba.com/content/support/downloa...) and rebooted.
m
0
l
!