Sign in with
Sign up | Sign in
Your question

Clean wipe Crucial C300

Last response: in Storage
Share
May 24, 2011 5:02:50 PM

I purchased a new laptop and moved from xp to w7 and hdd to sdd so a lot to learn. When I wanted to reformat in the past I used Darik's Boot And Nuke which I know is not a good idea with ssd.



So I botched my first w7 install and want to restart clean. A few google searches suggested I use HDDerase. Ive tried booting version 4 from usb I got from here and booting version 4 from the ultimate boot cd. I've tried booting the laptop and pluggin in the ssd right before running hdderase.exe and still unable to get the software to find my ssd.



What other options do I have to reset my ssd to factory defaults?

Is it necessary to do this or just boot w7 and select clean install?



Laptop is a SAGER NP5160 Built on Clevo W150HN.
a c 205 D Laptop
a c 103 G Storage
May 24, 2011 8:26:54 PM

The only time you want to do a full wipe with such a disk utility is if you want zero of your data to be ever recoverable with an undelete utility. Since this is not what your plans are, a regular Win 7 setup with a drive format will do it for you.

When you sell or discard the drive, then you may want to do the full wipe.
m
0
l
May 25, 2011 4:17:52 AM

Actually you do want to zero your data for reasons other than security when it comes to SSD. Your SSD is much faster if it has been cleaned of data which is what I'm trying to do.
m
0
l
May 25, 2011 3:47:44 PM

I posted on the crucial forums and was told to use this guide.
http://www.ocztechnologyforum.com/forum/showthread.php?...

Ok here is my follow-up based on that guide. I had to play with it but these are the steps I took to get it to work.

I am using a laptop. I have a cdrom to hard drive carrier (http://www.amazon.com/gp/product/B004XIU4T2) so I can use both SATA ports on this laptop to try and execute security erase of my C300 SSD.

Booting Ubuntu and then trying to plug in the SSD in the hard drive bay as the guide instructs didn't cause ubuntu to recognize the drive. So I tried the cdrom bay but had the same result, no SSD detected by plugging it in after the boot.

So I decided to boot with the SSD in the cdrom bay and see if I could get the commands to work.
sudo hdparm -I /dev/sdb showed the drive frozen by the bios which is why you try and hot plug it in post boot.
Well I decided to keep going.
sudo hdparm --user-master u --security-set-pass test /dev/sdx gave me an Input/output error
Now when I try sudo hdparm -I /dev/sdb I get an Input/output error.
So I hot unplugged the SSD.
sudo hdparm -I /dev/sdb now shows Invalid exchange
So I hot plugged the SSD back in.
Ha success sudo hdparm -I /dev/sdb now shows the drive as not frozen.
sudo hdparm --user-master u --security-set-pass test /dev/sdx gave no errors.
sudo hdparm --user-master u --security-erase test /dev/sdx gave no errors.
sudo hdparm -I /dev/sdb shows the password not enabled and therefore I know the drive has been security erased.

What a pain to restore my SSD back to factory defaults!
m
0
l
!