Sign in with
Sign up | Sign in
Your question

PC will not boot from hard drive

Last response: in Storage
Share
May 24, 2011 5:10:36 PM

Hey everyone, I've been having a problem with a laptop that I brought from my school; It was working perfectly for a few months after I brought it home but a few days after I left the school to go to college the laptop stopped recognizing the internal hard drive. The hard drive is 100% working as I have tested it both on another computer and with SeaTools Diagnostic when It is in the laptop. So SeaTools recognizes it but it is not in the laptops boot menu. When I turn on the laptop the boot order jumps straight to the Network boot and ignored every other device except the DVD drive which I am able to boot from.

UBS pen drives als do not boot but do show up in the BIOS. I used the DVD drive to install ubuntu on the hard drive which finished successfully but after the computer restarts the had drive is again not recognized.

I was thinking that the school might have done something to stop people using the laptops after they leave the school. I have tried to have them help me but they keep refusing.

Can anyone help me with this...

Thank you.

More about : boot hard drive

May 24, 2011 6:18:07 PM

Chris19911210 said:
Hey everyone, I've been having a problem with a laptop that I brought from my school; It was working perfectly for a few months after I brought it home but a few days after I left the school to go to college the laptop stopped recognizing the internal hard drive. The hard drive is 100% working as I have tested it both on another computer and with SeaTools Diagnostic when It is in the laptop. So SeaTools recognizes it but it is not in the laptops boot menu. When I turn on the laptop the boot order jumps straight to the Network boot and ignored every other device except the DVD drive which I am able to boot from.

UBS pen drives als do not boot but do show up in the BIOS. I used the DVD drive to install ubuntu on the hard drive which finished successfully but after the computer restarts the had drive is again not recognized.

I was thinking that the school might have done something to stop people using the laptops after they leave the school. I have tried to have them help me but they keep refusing.

Can anyone help me with this...

Thank you.

I presume when you are talking about the boot menu, this is the one when you press F12, or F11 or F5 (depending upon the BIOS). Have you checked the setup menu on the BIOS (often F2)? Make sure that the drive is on the list of bootable drives (and the USB port while you are at it). If Seatools can see it, then the drive is being recognised by the BIOS at some level at least.
May 24, 2011 6:52:59 PM

The laptop is one from Stone Computers; when you get to their logo their is only the option to press F2. When I do I'm taken to the PheonixBIOS Setup Utility screen. In the Boot tab I only see the DVD drive and the PCI LAN. F12, F11 and F5 do nothing.

Do you think It is possible to stop the hard drive being recognised remotely?

I am also unable to turn off the network boot from the menu which most other laptops seem to be able to do.
Related resources
May 25, 2011 3:48:40 PM

If the BIOS is not seeing it at all, there could be a less sinister cause - it could simply be a connection inside the machine that has come loose... Probably best to wait for any other responses on the BIOS first before breaking out the screwdrivers.
May 25, 2011 9:36:03 PM

The thing that is annoying me the most about this is that the hard drive is accessible. I ran the latest version of ubuntu from a DVD and the hard drive was there, I was even able to create documents inside it. This makes me think that something has been done to the laptop by the school to stop hard drive and usb booting after a certain time.

Does anyone know if this is actually possible?
May 26, 2011 7:59:11 AM

Very puzzled... On the Boot screen you should see the list of boot devices, which you can change using +/-, as well as options to select the Hard Drive to boot from below. If there is a BIOS password set, you may want to reset this. Have a look at:

http://www.computerhope.com/help/phoenix.htm

which explains what the BIOS should look like, and how to reset passwords, and return control to you!
May 26, 2011 1:23:00 PM

I downloaded a boot disk called Hirens Boot CD and from there I was able to reset the BIOS so that the hard drive is in the boot menu. I tries to boot from it but I got 'operating system not found'. I went back into the boot disk and at the top it says 'boot from hard drive', so I clicked on that and the hard drive booted into ubuntu.

So how do I now fix the 'Operating system not found error'?
May 26, 2011 7:15:40 PM

That's a simple one - you are missing the master boot record on your hard drive. Normally this gets written when doing the install of Ubuntu, but in your case, this hasn't happened as it should have. It is a simple thing to fix for Ubuntu. Boot it using your CD as you've done, and then issue the command

sudo grub-install /dev/hda

(or it might be /dev/sda, depending on your type of drive. To know which it is type 'sudo fdisk -l', and see if you can spot your hard drive - the capacity given in the drive information before the list of partitions should be the clue.)
May 26, 2011 9:19:13 PM

@davel_68

Tried what you said but still no luck. I get

PXE-E61: Media test failure, check cable

PXE-M0F: Exiting Broadcom PXE ROM. Operating System not found

May 26, 2011 9:49:55 PM

These PXE errors indicate that it is trying to boot from the LAN. Check the boot order, and disable Boot from LAN, and see what happens...
May 27, 2011 11:48:46 AM

How do you disable LAN booting on a Phoenix BIOS. All I can do is move the boot priority order up or down and change a couple of other options, none of which have anything to do with LAN.

Thx
May 27, 2011 12:23:43 PM

OK - we're really getting down to challenging stuff here. You should be able to disable the LAN, but the exact details on how to do this may depend on the version of your BIOS. Certainly in one version you can disable this under the Advanced tab, and the I/O Configuration option, at the bottom disable the Network Boot ROMs. Looking at some documentation for one version of the BIOS suggests that enabling USB Legacy support, and network boot support at the same time can stop other drivers from working...

If that doesn't work, check that your MBR is not all zeros by booting into Linux, and issuing the command:

sudo dd if=/dev/hda bs=512 count=1 | od -x

(If your drive is detected as sda, then substitute this in place of hda). If the MBR looks to have data (code) in it, then this is most likely not the issue...
May 27, 2011 3:10:22 PM

@davel_68

The options that are available in the advanced tab are:

Internal mouse: Enabled
Legacy USB Support: Enabled
Disable Logo Screen: Disabled
Core Multi Processing: Enabled
Intel (R) SpeedStep (TM) technology: Enabled
Wireless LAN: Disabled

When I do the sudo command from above I get lots of question marks.

May 27, 2011 3:12:46 PM

You shouldn't get question marks - did you remember the -x?
May 27, 2011 3:22:15 PM

As this is getting tricky - have you tried booting from this drive on another laptop (I seem to remember you've tried this drive in another machine before...) If you can manage that, then it really is down to the BIOS, in which case I'd be suggesting you see if there is an update:

http://www.wimsbios.com/faq/determinebiosupdate.jsp

If it doesn't boot on another laptop, then I'd be checking that your MBR is valid, and doing the grub-install bit again to make sure that the MBR is written. (Be careful to specify the whole drive e.g. /dev/hda, rather than a partition e.g. /dev/hda1, when issuing the grub-install command).
May 27, 2011 10:04:15 PM

Just tried the hard drive in my other laptop and it booted straight away without any problems.

I couldn't find a link for the ubuntu version of the bios update utility though so I couldn't give that a go. I dont have access to a Windows hard drive at the moment.
May 28, 2011 6:24:39 PM

This is a real puzzler. As far as I can see we know the following:

- You know the drive is present and working as you can boot via the DVD option, so it is still accessible (i.e. the cables and power are all OK)
- The drive successfully boots on another machine, so the drive is set up correctly
- Your disk worked in the past as a boot device, so the laptop is capable of doing this with the current BIOS

This leads to the conclusion that your configurable BIOS settings are causing the problem.

Some (or is it all?) versions of the Phoenix BIOS have a supervisor password - does yours have this, and if so, do you know it? If not, see my suggestion below. If you do know it, enter this and look through all of the BIOS settings very carefully. (Entering the supervisor password will make new options appear). Try to understand what each one is setting (making a note of these as you go). In particular you are looking for any settings related to drive types/settings, network settings, or (of course) boot options. If you are not sure about something, try looking it up, or checking back here.

If all else fails, I would recommend clearing the CMOS settings completely, and set up the BIOS again. Before clearing it, go through all of the BIOS screens, noting what is set and what is not, so that you stand a fighting chance of getting most things working when you try booting it again. If you don't have a software option available for resetting the BIOS, you can also achieve this by removing its battery backup for 5 minutes - i.e. breaking out those screwdrivers! The BIOS battery is a button cell, probably about 1 - 2 cm in diameter.

Having said that, a thought has just occurred to me - its not that your battery backup for the BIOS has gone flat is it? (If you make changes to the BIOS, do they remain changed after powering off)?
May 28, 2011 8:37:12 PM

There doesnt seem to be a supervisor password present. When I try to enter a password It simply says:

"Enter new password:
Confirm new password:"

After I had a look at the password I tested to see of the battery was ok by turning the built in keyboard off, switching the laptop off after saving the settings and rebooting. When I went back into the settings the mouse was still disabled. So I think the battery is all right.

Removing the battery is my next step I think but it could be a bit of a challenge as some of the screws are stuck.
May 28, 2011 8:45:27 PM

Something interesting I just found. I booted into Hiren's boot CD and started PLoP Boot Manager, I selected HDA Partition 1 and a warning appeared saying "No valid bootsector signature, continue boot Y/N"

When I click on partition 2 I get a flashing white line at the top left of the screen which never goes off.

Any thoughts on this?
May 29, 2011 12:46:50 PM

I don't think this is sinister - for one the hard drive works fine on another machine.
I'm not sure how PLoP works, but this message may simply indicated that there is no "active" partition. Having checked my Linux build (on a second disk), this is perfectly normal for Ubuntu. Grub doesn't need the partition to be "active" to know that there is a bootable OS on there. You don't say whether selecting Y works or not for partition 1. (Partition 2 is an extended partition that contains the swap space partition, so I'm not surprised that the machine just hangs).
May 29, 2011 4:30:56 PM

When I press Y from PLoP the computer just restarts. When I take the disk out and restart manually I get the same 'Media test failure' error as before. Is there another way of disabling the network boot without going into the bios?
May 29, 2011 6:44:17 PM

I think the PLoP route is a bit of a red herring. Having a think about how Linux works, and is loaded up, you need to specify a number of parameters that are normally held in the boot area of the disk. You've got grub in the MBR, but as it is too large for that, will also occupy some of partition 1. That's why partition 1 is not listed as active, and why you can't boot directly into this. There is a warning in the PLoP documentation to this effect:

Quote:
Warning Linux users: Install LILO or GRUB to the boot sector of your Linux instead of the Master Boot Record (MBR). The Plop Boot Manager is not a Linux loader and cannot start Linux without LILO, GRUB, Syslinux and similar!


It keeps coming back to the same thing - it is the BIOS that is the issue here. If the BIOS were to not only detect, but also boot, from the drive, then you would be up and running. What configuration parameters are available to you for the drive? For example, Hard disk type, access methods, parameters (both non editable and those you can change), whether Boot recovery is enabled or not (controls whether you can hit F11 during boot to get a boot menu or not). It is time to dig around *everything* you can find in the BIOS.
May 30, 2011 2:54:07 PM

Ok ,so I've had a look at what parameters I'm able to change and I see:

Type: User
CHS Format
Cylinders: 16383
Heads: 16
Sectors: 63
Maximum Capasity: 8455MB SATA 1

LBA Format

Total Sectors: 488397168
Maximum Capasity 250GB SATA 1

Multi-Sector Transfers: 16 Sectord
LBA Mode Control: Enabled
32 Bit I/O: Disabled
Transfer Mode: FPIO 4 / DMA 2
Ultra DMA Mode: Mode 5

I don't see anything about Boot Recovery.

I see "Fixed disk boot sector" which is set to normal. The other option is "Write Protected".



June 5, 2011 1:29:45 PM

About the only thing I would suggest is that you set 32 Bit I/O to enabled. (Also, it might be worthwhile setting the drive type to Auto instead of User - most modern drives will be able to handle this - user is normally reserved for older drives).

It is very odd that you don't see anything about enabling boot options (i.e. pressing F11 during the boot sequence). Have you tried pressing F11 during boot to see if the Hard Drive is listed?

You seem to have had access to other machines - do you know if your computer will boot another hard drive you know works in someone else's machine?
!