Sign in with
Sign up | Sign in
Your question

Asrock Conroe1333 -D667 and Radeon HD 5770

Last response: in Motherboards
Share
February 2, 2010 2:34:10 PM

Hi all,

I recently bought a sapphire hd 5770 and it wont work with my mobo! i thought it would have been my psu because it was a 500 watt one worth £10- 15. So i bought a corsair 650 watt psu worth around £80. installed it plugged it in and still no luck! i dont get any POST! I ended up trying the card in my mates PC which is a dell (and has a 375 watt PSU btw) and it worked perfectly on his pc! i was very confused so then i knew it has something to do with my mobo, so i contacted asrock and they told me to update my bios to 1.83. I checked their site and the latest bios update on there was 1.80 which i already have installed! after carefully re-reading the e-mail they sent me i realized they attached the update 1.83 so i was pleased. After downloading it, i tried to run it but didn't have any luck because it was an 'unknown application'... it says that its a file type : 83 File. Any idea how i can get this to work so i can install it? my mate says that it 'sounds like firmware' but because i have so little experience i had no idea what to do but ask on here. So can anyone help me out?

Thanks for your time,
Funk.
a c 234 V Motherboard
February 2, 2010 4:07:22 PM

What's the complete file name that was attached to the email and how large is it? Your manual should indicate how to update the BIOS, but you can also find instruction at ASRock: http://www.asrock.com/MB/download.asp?Model=ConRoe1333-...

Click the + icon that corresponds to the OS that you'll be using (DOS or Windows). The link above is for version 1.0 or the motherboard (you didn't specify if yours is 1.0, 2.0 or 3.0), but the instructions are the same for all versions.
February 2, 2010 4:53:09 PM

yes my mobo is version 1.0 and is updated to bios v 1.80. the file name i got from Asrock was called CR13D6_1 the instructions when i click the plus sign are for an exe file which i followed when installing bios 1.80 but for some reason this isnt like the other files on the net which is weird.
Related resources
a c 234 V Motherboard
February 2, 2010 7:03:45 PM

If ASRock support didn't provide instructions, e.g., rename the file to its correct name, contact them again and ask them for the missing instructions. If you know how large the file is, then it's relatively easy to determine what it is. You could also inspect it's contents to make sure that it's a BIOS file.
February 2, 2010 8:33:04 PM

i cant inspect its contents, i dont know how to. and contacting asrock would only result in me waiting another 2-3 weeks before i get a reply...
February 2, 2010 8:34:29 PM

oh and btw, the file is about 512 kb so its not large i think all the downloads from the site are roughly this big but they are exe and not some weird file format :??: 
a c 234 V Motherboard
February 2, 2010 8:37:44 PM

Did you rename the file as 1.83.exe?
February 2, 2010 8:40:53 PM

ye but for some reason it keeps a .83 at the end. so it was 1.83.exe.83 and i cant do anything about that
a c 234 V Motherboard
February 2, 2010 8:43:35 PM

Yes you can. Just rename the file from a DOS (cmd) window as follows:

cd folder_containg_the_file
ren 1.83.exe.83 1.83.exe

It's that easy.
February 2, 2010 8:56:25 PM

hmm managed that and when i click on the file now it opens cms prompt for a split sec then closes it and nothing happens :S maybe its meant to be a diff file type? also i think the .83 might have been an error on asrock's behalf (god i hate that company) because they names it 1.83 at the end as in bios 1.83 and it understood it as a .83 file. i tried .zip and .rar but no luck i cant extract it. any ideas?
February 2, 2010 9:00:00 PM

oh wait i just downloaded the 1.80 from the site and it has an exe file opening a system file that has the exact name as the file i downloaded from the e-mail! it is called CR13D6_1.80 instead of 1.83 so all i need to do is make an exe that will open the 1.83 system file and i might be able to install! if only i knew how too :p 
a c 234 V Motherboard
February 2, 2010 10:36:38 PM

Then they only provided the BIOS file and not the tool to flash the BIOS. Don't you have a tool to flash the BIOS? I haven't worked on an older ASRock motherboard, but they are not that difficult to flash. If need be, download the DOS (preferred) or Windows utility to flash it.
February 2, 2010 11:27:38 PM

i just figured out that this is a way to setup the DOS. if i downloaded the 1.80 DOS setup version of 1.80 i get the same file and an exe. apparently the exe can run any of the files so its not set to a specific one aslong as i type the file name. but the thing that annoys me is i have to do it via floppy drive...

»Updating BIOS Procedures:
1- Create a bootable system floppy disk.

2- Download an updated ASRock BIOS file (WinZip format with .zip file extension) from the web site, unzip the BIOS file and save both ASRFLASH.EXE utility and BIOS file to the disk you created in step 1.

3-Boot from the disk you created in step 2.

4-At the "A:\" prompt, type ASRFLASH, hit space bar once, and type BIOS file name then press <Enter>. For example: A:\ASRFLASH K7S41GX2.00 <Enter> then you will see a message "Please wait for BIOS loading ROM".

5-After 30 seconds, you will see the message "Flash ROM Update Completed - Pass", then you have finished upgrading the BIOS.

6-After finishing upgrading the BIOS, please remove the floppy disk. Restart your system and press <F2> to enter the BIOS setup utility during boot up.

7-In Exit menu, please select "Load Default Settings" and press <Enter> to continue.

8-Select "Exit Saving Changes" and press <Enter> to exit the BIOS setup utility.

9-Now, system is booting up with new BIOS.

Now to find a floppy from God knows where and learn how to make a bootable system floppy disk...
February 3, 2010 9:41:24 PM

bingo, managed to install it via windows Dos mode and it works, graphics card works excellently and I am now pleased... But im never buying an Asrock ever again...
a c 234 V Motherboard
February 3, 2010 10:54:29 PM

ASRock should not necessarily be blamed. That motherboard is based on the Intel 945GC chipset and they got it to run properly with a PCIe 2.0 video card. ASRock usually build good motherboards.
February 6, 2010 4:34:09 AM

funkmeister 3000 said:
bingo, managed to install it via windows Dos mode and it works, graphics card works excellently and I am now pleased... But im never buying an Asrock ever again...


Hi there,

I am also having the same issue with a 5750 card and a ConRoe1333-D667!

Would it be possible to email me bios 1.83?

cheers

Scott
February 7, 2010 2:14:11 PM

Hallo,

Is it possible to upload the Bios on rapidshare or somewhere else?
I need the bios for my system

Thx

Mike
February 8, 2010 6:59:57 AM

Hi Mike,

I am still waiting to get hold of this bios update!

I have a request in with Asrock and my supplier....

If/when I get it I will let you know!

cheers, Scott
February 8, 2010 6:15:57 PM

That would be fine!

Till then i couldn´t use my hd 5770...

February 9, 2010 4:21:02 AM

Mike I now have Bios 1.83 (Dos & Win)

I have yet to try it as the pc is at my folks place, will be getting done tomorrow!

Send your email address and I will forward you the files...

cheers, Scott
February 10, 2010 2:57:30 AM

Bios update fixed the issue!
February 10, 2010 4:22:10 AM

itgadgets said:
Bios update fixed the issue!

Can you please send me the Bios update to 1.83 to my email plz. ter0211@hotmail.co.uk
thx alot :) 
February 10, 2010 2:34:34 PM

I just send you the BIOS which i get from asrock.

Mike
February 13, 2010 9:58:14 AM

can u please send me bios 1.83 because i just got my hd 5770 and its not working for now with my current bios
February 13, 2010 10:04:48 AM

if you can mail it to me on drazen_runtas@yahoo.com
February 14, 2010 5:07:50 PM

I can´t update the Bios. it won´t be start when i try to boot from cd.
Anybody who knows how to update the Bios 1.83?
February 14, 2010 6:28:20 PM

thank you heavy88 but i have the same problem ,it won´t boot from cd...
February 14, 2010 8:25:48 PM

pls can anyone email me the asrock 1.83 bios update? i have the 945GCM-s board and my new 5770 won't post. My email is victornjie@gmail.com Thanks.
February 15, 2010 12:26:16 PM

Hey Scott,

Can you send me your version of Bios, maybe i haven´t the same...

Email: heavy-88@online.de
a c 234 V Motherboard
February 15, 2010 2:40:03 PM

victornjie said:
pls can anyone email me the asrock 1.83 bios update? i have the 945GCM-s board and my new 5770 won't post. My email is victornjie@gmail.com Thanks.

You can't use the BIOS for a Asrock Conroe1333 -D667. You have to get the one for your motherboard.
March 8, 2010 8:53:31 AM

Hello!Can you send me v 1.83 bios Conroe 1333?
My email is manu_vick@hotmail.com

Thanks!
March 11, 2010 7:27:40 PM

go to : http://www.pendrivelinux.com/boot-iso-from-usb-flash-dr... and download bootmyiso program.

This will make ur usb stick become bootable !

Open it then,select your usb key (E:\...K:\, dont make
mistake)Let him format your usb stick.


Then copy bios files on the usb stick. Boot on usb (F11 at startup) then
select FreeDos. Wait few secs. On c:\prompt type
c:\ASRFlash CR13D6_1.83

Wait. When you finally see the success message, it"s all right !restart with
Crtl-alt-del...


thanks david from france for this solution!!!!
March 18, 2010 12:12:32 PM

Hello! Can you send me v 1.83 bios Conroe 1333?
My email is alex1653@gmail.com
Thanks
Anonymous
a b V Motherboard
March 19, 2010 3:43:04 PM

would anyone be kind enough to email me a copy too?
barry@rimmerhome.co.uk
Anonymous
a b V Motherboard
March 22, 2010 3:32:00 PM


Hello! Can you send me v 1.83 bios Conroe 1333?
My email is bauwong.burschenKasing@web.de
Thanks
March 31, 2010 1:20:43 PM

Hi. I'm having the same problem with this mobo. Can you send me the 1.83 bios too.

Here's my email: rjginesmd@yahoo.com.

thanks you very much!
April 3, 2010 1:23:57 PM

If anyone's still got a copy of the 1.83 Conroe1333 bios, could you mail it on to me at scarredknuckle2002@yahoo.co.uk ?

Thanks in advance

-Kneel
a b V Motherboard
April 4, 2010 7:21:37 PM

Contact ASRock Support.
April 4, 2010 10:58:07 PM

I have, but it's a long Easter weekend without ASRock tech support and I was hoping someone might be able to help out in the meantime.
Anonymous
a b V Motherboard
April 30, 2010 3:26:16 PM

Me too please !! I've this Mobo and Ati 5450 , no POST , no BOOT
Please send me the bios : j.tixi@free.fr

Big big thanks
Julien
May 7, 2010 11:32:01 PM

Also have the same issue.
So if someone can post me bios 1.83

mail : snett2k@hotmail.com

Many thanks
Snett
May 10, 2010 6:55:17 PM

Same :( 

Bought the hd5770 and nogo...
Hit the forums and found out...

Pls 1.83 for Witte9503610@hotmail.com

Thnx
May 11, 2010 7:50:49 AM

Heavy88 said:
I just send you the BIOS which i get from asrock.

Mike


Could you send it to me too pls :) 

Thnx in advance

witte9503610@hotmail.com
May 12, 2010 8:47:26 AM

Can I please also get the latest Bios mailed maybe?
Bought a HD5770 yesterday and thought it was broken, was about to bring it back until I saw this thread, so hopefully it will solve the problem :) 

Thanks!

b3n.ji@gmx.net
Anonymous
a b V Motherboard
June 2, 2010 4:56:48 PM

May I also have the 1.83 BIOS update or which is the latest one? I have the same MoBo and same card
Also does it work for Windows 7 32-bit?

e-mail: shark1995shark@yahoo.com
June 11, 2010 5:52:25 AM

Could you send it to me too pls :) 

Thx

lagovka@gmail.com
a b V Motherboard
June 15, 2010 1:48:24 AM

Contact ASRock support and request it.
Anonymous
a b V Motherboard
August 10, 2010 8:23:11 PM

can you send me bios 1.83 tnx
jak2612@gmail.com
Anonymous
a b V Motherboard
August 10, 2010 10:05:35 PM

pleas!!!!!
Anonymous
a b V Motherboard
August 25, 2010 4:25:00 PM

Can some1 please send me the 1.83 bios i beg you


bagy.kralj@hotmail.com
!