Sign in with
Sign up | Sign in
Your question

Totally stuck! SATA Drives not seen in windows.

Last response: in Storage
Share
May 26, 2011 9:07:08 AM

Hello, I'm having a very hard time with my SATA back up drives.

History! I got a virus so had to format and reinstall windows. Everthing worked fine before so I know my hardware setup must be correct. Now I can't get windows to see my drives. Does not show in my computer. does not show in disk managment and it does not show in device manager. I can however see the drives in the Nvidia hard drive health check utility, in the nvidia raid setup utility and in the bios. Windows also saw the drives as new hardware when I installed the Nvidia Nforce4 driver chipset update from their website. I'm running on an old MSI KN8 NEO4 main board. the drives I want to access are all my backup data which I need to use to recover my old programs and files. I use them unraided and as regular drives. My two system drives are on a silion image raid controller and set to raid 0 which works perfectly. With my back up drives the nvidia utility wanted me to farmat both drives. this is not an option or I will loose 13 years worth of data. Can anyone help?
May 26, 2011 11:19:56 AM

Sorry got the full details here now I'm fully registered!

First the history!

I’m running an MSI KN8 NEO4 main board with two raptor drives in raid 0 for my system. This is off the on board Silicon Image raid controller with windows spsp2 install disc. I also run two unraided WD drives off the additional Marvel/Nforce 4 onboard SATA controller as single drives. These are my programs and vital information backups. This has worked successfully for years until I got the infamous Google redirect virus and had to format my system drive and reinstall windows to get rid of it.

procedure

With my backup drives disconnected

I have installed a new copy of windows xp using the F6 option and inserting the floppy disk for the silicon image raid drivers as requested by setup. Press S etc and it all works as it should with no problems.

Next I install the drivers from the MSI driver disc supplied with the main board including the nvidia raid controller driver and Nvidia IDE driver as supplied and restart

Next a trip to AMD/ATI to get the most recent drivers for my radion x850PE graphics card. These install just fine.

Sound comes in third for my Audigy 4 pro which again works perfectly ok

And last of all I have a wintv card which again sets up just perfectly.

Then just to make sure everything is ok I go into the system to check for conflicts etc and all was fine.

Now I reconnect my two SATA storage drives one by one and bingo we find new hardware and in a moment or two it’s ready to use.

Then win update etc until the system is current and up to date.

The problem.

Try as hard a I might I simply cannot get windows to see my two backup drives. It is almost as though they are not there. Windows seems to recognize the drives when plugging them in and that’s it. I also see the plug and play sys tray icon for these devices as well.

Nothing in my computer.
Nothing in disk management.
Nothing in device manager that’s obvious.

(I have however found the two drives under the section SCSI Raid controllers listed as SCSI raid devices. These were only found after I checked “show hidden devices” in the devices manager’s settings.)

What I have tried.

Reinstalled windows with all hard drives connected – this failed with the same results

Reinstalled windows inserting both Si Image and Nvidia raid controller driver disks using S option when prompted by setup (F6 etc) – also failed

Under device manager

Tried uninstalling the drivers for disks (listed as SCSI raid devices) and then hardware update option – this just reinstalls back to the same as before so this failed.

Tried uninstalling the Nvidia raid controller and then reinstalling it again – failed and returned the system back to the same.

Went to Nvidia website and downloaded the latest Nforce4 chipset drivers and installed them – The outcome was positive! It added SATA controllers to the SCSI/Raid section in device manager and then windows recognized the drives as SATA SCSI/Raid disk devices. The SCSI raid devices items then disappeared from device manager. The plug and play sys icon also disappeared. (This is as it was when my system was working properly, no plug and play icon!) (I assume my original main board software disc didn’t have all the drivers on it and some SATA drivers I needed were added as a result of the update.) The download also added an HD health check and Nvidia raid utility.

Next a popup said before you can use these drives you may need to format them. It also wanted me to raid array the drives. I didn’t do this because I can’t! I will loose all my data. Interestingly the disk health check utility can see both drives but not windows.

Unfortunately after all this I am still stuck with the same problem. Nothing in my computer, nothing in disk management and nothing in device manager. I can't acess any of by back up data and I don’t see a format will do anything to help other than wipe all my stuff which i'm not willing to do. There’s nothing wrong with the current partition on these disks and windows should be able to see them as normal drives with my data on them. Can anyone help me solve this please? I just can’t understand it!

Thanks

Paul
!